Closed Bug 1266424 Opened 3 years ago Closed 3 years ago

Update internal timezone database to version 2016j

Categories

(Calendar :: Internal Components, defect)

Lightning 4.7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ssitter, Assigned: Fallen)

References

Details

(Whiteboard: [timezone][late-l10n])

Attachments

(2 files)

The 2016d release of tz code and data is available:
https://mm.icann.org/pipermail/tz-announce/2016-April/000038.html
The 2016e release of tz code and data is available:
https://mm.icann.org/pipermail/tz-announce/2016-June/000039.html
Summary: Update internal timezone database to version 2016d → Update internal timezone database to version 2016e
The 2016f release of tz code and data is available:
https://mm.icann.org/pipermail/tz-announce/2016-July/000040.html
Summary: Update internal timezone database to version 2016e → Update internal timezone database to version 2016f
Summary: Update internal timezone database to version 2016f → Update internal timezone database to version 2016g
The 2016h release of tz code and data is available:
https://mm.icann.org/pipermail/tz-announce/2016-October/000042.html
Summary: Update internal timezone database to version 2016g → Update internal timezone database to version 2016h
Blocks: ltn54
The 2016i release of tz code and data is available:
https://mm.icann.org/pipermail/tz-announce/2016-November/000043.html

This will have impact on localization due to the new timezones.
Summary: Update internal timezone database to version 2016h → Update internal timezone database to version 2016i
Whiteboard: [timezone] → [timezone][l10n impact]
Can you prepare a patch for this? Merge date is on Monday, so landing this before would be great.
Attached patch Update to 2016iSplinter Review
Ah yes, I should have gotten around to this. Given the timezone strings are in the filter.py ignore rules, I think it would be ok to do late-l10n for this.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #8811206 - Flags: review?(makemyday)
Whiteboard: [timezone][l10n impact] → [timezone][late-l10n]
Comment on attachment 8811206 [details] [diff] [review]
Update to 2016i

Review of attachment 8811206 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Even though timezone names are not required to be localized, many locales do this. That said, regarding the landing on Autora, I propose do land all late l10n strings in a coordinated way. See https://bugzilla.mozilla.org/show_bug.cgi?id=1312113#c5

As this just missed the latest ESR release, we would have time for backporting to Beta and ESR anyway, but you maybe can already grant the approvals.
Attachment #8811206 - Flags: review?(makemyday) → review+
Attached patch Update to 2016jSplinter Review
2016j was just released with more strings
Attachment #8814032 - Flags: review?(makemyday)
Summary: Update internal timezone database to version 2016i → Update internal timezone database to version 2016j
Attachment #8811206 - Attachment description: Fix - v1 → Update to 2016i
Attachment #8814032 - Flags: review?(makemyday) → review+
Comment on attachment 8811206 [details] [diff] [review]
Update to 2016i

a+ from Philipp on irc for both patches
Attachment #8811206 - Flags: approval-calendar-aurora+
Attachment #8814032 - Flags: approval-calendar-aurora+
Duplicate of this bug: 1335328
Duplicate of this bug: 1337852
Users are affected by the out-of-date and incorrect timezone information in Lightning 4.7 releases. Would it be possible to port the changes back to comm-release?
Flags: needinfo?(philipp)
Turkish time problem exist current community version TB 45.7.1, Lightning 4.7.7.1. The problem is well defined in the bug 1335328 which is closed.
(In reply to Stefan Sitter from comment #15)
> Users are affected by the out-of-date and incorrect timezone information in
> Lightning 4.7 releases. Would it be possible to port the changes back to
> comm-release?

Lightning 5.4 is about to be released, so I don't think it is worth doing now (nor a month ago when you asked). We should work on a mechanism to do Timezone updates quicker though. I guess the only chance we have is to release en-US only, or wait 12 weeks and then backport the aurora strings to release manually.
Flags: needinfo?(philipp)
You need to log in before you can comment on or make changes to this bug.