Make CreateProfileWizard part of a meta wizard

VERIFIED FIXED in M12

Status

P3
major
VERIFIED FIXED
19 years ago
2 years ago

People

(Reporter: gayatrib, Assigned: gayatrib)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
Create a framework for a meta wizard that allows the createProfileWizard,
dialup wizard, mailnews wizard to be all included as part of profile wizard.

This should take care of the existing localization issues in the various
profile ui xul files, take care of using tabs to accomodate feature enhancement
requests, greyout buttons as required etc.

I am filing this bug against myself so that when I check in the new ui today, I
can use this as the tracking bug, and mark the various other related bugs as
dups of this bug.
(Assignee)

Comment 1

19 years ago
*** Bug 10248 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

19 years ago
*** Bug 10250 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

19 years ago
*** Bug 10243 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

19 years ago
*** Bug 7322 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

19 years ago
*** Bug 6603 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

19 years ago
*** Bug 11315 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Severity: normal → major
Status: NEW → ASSIGNED
Target Milestone: M10
(Assignee)

Comment 7

19 years ago
Accepting the bug, marking severity as major and setting target milestone to
M10.

Updated

19 years ago
Blocks: 12696
(Assignee)

Comment 8

19 years ago
*** Bug 6690 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

19 years ago
*** Bug 6692 has been marked as a duplicate of this bug. ***

Comment 10

19 years ago
Files to be checked in verifying this bug:

./res/profile/renameProfile.html
./res/profile/profileManager.html
./res/profile/errorDialog.html
./res/profile/preg.html
./res/profile/content1.xul
./res/profile/content2.xul
./res/profile/content3.xul
./res/profile/content4.xul
./res/profile/contentManager4.xul
./res/profile/navigationStart.xul
./res/profile/navigationFinish.xul
./res/profile/navigationManagerStart.xul
./res/profile/navigationManagerFinish.xul
(title?) ./res/profile/cpwManager.xul
(title?) ./res/profile/profileManagerContainer.xul
./res/profile/pm.xul
./res/profile/pmrename.xul
(title?) ./res/profile/cpwPreg.xul
./res/profile/navStartPreg.xul
./res/profile/navFinishPreg.xul
./res/profile/pmDelete.xul
./res/profile/pmMigrateAll.xul

Comment 11

19 years ago
I think this bug was fixed by Gayatri's UI checkin.  Unless there is still a
problem with the I18N stuff, this should probably have been marked fixed.

Grace, Tao, can you verify?

Thanks, Steve

Comment 12

19 years ago
I verified the duplicates associated with this bug, I think this bug is fixed
now
(Assignee)

Updated

19 years ago
Target Milestone: M10 → M12
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 14

19 years ago
build 1999101308 -ok

Updated

19 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 15

19 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.