Closed Bug 1273209 Opened 4 years ago Closed 2 years ago

scrollbar not visible on many sites

Categories

(Core :: Widget: Gtk, defect, P2)

46 Branch
x86
Linux
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: carlos, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: tpi:+)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

Open for example
http://www.vatera.hu/
There are other sites too....


Actual results:

After the last update ( 46.0.1 )
No scrollbar on the right side of the browser, I can only scroll with my mouse scroll button:(


Expected results:

There should be a scrollbar!
OS: Unspecified → Linux
Hardware: Unspecified → x86
FF46 supports Gtk3 now.
Blocks: gtk3
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Is GTK 3.20 in use?  If so, this bug 1230955.
(In reply to Karl Tomlinson (ni?:karlt) from comment #2)
> Is GTK 3.20 in use?  If so, this bug 1230955.

I think so...

firefox   16252             root  mem       REG        8,1   7991796    4725068 /usr/lib/i386-linux-gnu/libgtk-3.so.0.1400.5
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1230955
(In reply to Harka Győző from comment #3)
> firefox   16252             root  mem       REG        8,1   7991796   
> 4725068 /usr/lib/i386-linux-gnu/libgtk-3.so.0.1400.5

Thanks.  That's actually GTK 3.14, which is not affected by bug 1230955, so this is a separate issue.

Do you see scrollbars on any sites?
Try about:config.

Is there a gap instead of the scrollbar?
What GTK theme is in use?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
> Do you see scrollbars on any sites?
> Try about:config.

about:config ( and many other sites ) has the scrollbar
Btw. for example bugzilla.mozilla.org hasn't!
 
> Is there a gap instead of the scrollbar?

Hard to say, but as I can see no.

> What GTK theme is in use?

'Adwaita'
(I never changed anything on this, so this should be a default)
Another issue with the same component I think, that autocompletion in text fields where the autofill is a scrolling select list, the list placed wrong in some pages..
Ohh and there is no favicons, so I can't drag and drop sites to the bookmarks (only the https sites, the cert name is there and that is responsive for the dragging)... annoying :(
Any add-ons installed.  If so, try running in safe mode.
i.e. Help -> "Restart with Add-ons Disabled".
Very strange. I tried safe mode, but no menu, etc. as the default "theme" was also disabled.
After a restart, theme is back, and it seems everything to work.
Have no clue how to reproduce this...
Duplicate of this bug: 1278126
Priority: -- → P2
Whiteboard: tpi:+
Is this still an issue (with Gtk 3.14)? If it is please let us know the Linux distribution.
Should be fixed now after the scrollbar code rewrite. Please reopen if you still see that.
Status: REOPENED → RESOLVED
Closed: 4 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.