Closed Bug 1274721 Opened 4 years ago Closed 3 years ago

Add %SYSTEM_CAPABILITIES% to the Thunderbird app.update.url preference

Categories

(Thunderbird :: Preferences, defect)

defect
Not set

Tracking

(thunderbird47 wontfix, thunderbird48 fixed, thunderbird49 fixed, thunderbird50 fixed, thunderbird_esr4549+ fixed)

RESOLVED FIXED
Thunderbird 50.0
Tracking Status
thunderbird47 --- wontfix
thunderbird48 --- fixed
thunderbird49 --- fixed
thunderbird50 --- fixed
thunderbird_esr45 49+ fixed

People

(Reporter: rstrong, Assigned: mkmelin)

References

Details

Attachments

(1 file)

In bug 1271761 a new value (%SYSTEM_CAPABILITIES%) will be added to the update url so it is possible to prevent updating of Windows systems that don't have SSE2 support.
Attached patch patch rev1Splinter Review
I'll let a Thunderbird dev take the patch from here. This patch should not land until after the dependent bugs are fixed. This will also need to be uplifted to Mozilla 48 and ESR if applicable for Thunderbird.
See Also: → 1274722
Summary: Add %SYSTEM_CAPABILITIES% to the app.update.url preference → Add %SYSTEM_CAPABILITIES% to the Thunderbird app.update.url preference
Attachment #8755058 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8755058 [details] [diff] [review]
patch rev1

Review of attachment 8755058 [details] [diff] [review]:
-----------------------------------------------------------------

The dependent bugs have landed, and this looks good. Thx for the patch! r=mkmelin
Attachment #8755058 - Flags: review?(mkmelin+mozilla) → review+
Comment on attachment 8755058 [details] [diff] [review]
patch rev1

Magnus, as Robert stated in the opening post, he is not going to drive this into the tree.
This also has to land on comm-aurora and comm-beta (see bug 1274721 for SeaMonkey).

[Approval Request Comment]
Regression caused by (bug #): bug 1271761
User impact if declined: no updates
Testing completed (on c-c, etc.): untested
Risk to taking this patch (and alternatives if risky): looks trivial but may depend on work on the server side
Attachment #8755058 - Flags: approval-comm-beta?
Attachment #8755058 - Flags: approval-comm-aurora?
https://hg.mozilla.org/comm-central/rev/bcca6d9ed725 -> FIXED
Assignee: nobody → mkmelin+mozilla
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 50.0
(In reply to rsx11m from comment #3)
> Risk to taking this patch (and alternatives if risky): looks trivial but may
> depend on work on the server side
So what about the server work?
Does that not also have to be uplifted to ESR 45? Bug 1271761 got ESR 45 uplift. Why didn't you request it?
Flags: needinfo?(rsx11m.pub)
IOW: If I uplift to TB 48/49, will those versions be fixed or broken ;-)
Comment on attachment 8755058 [details] [diff] [review]
patch rev1

(In reply to Jorg K (GMT+2, PTO during summer, NI me) from comment #5)
> So what about the server work?

Frankly, I have no clue. My initial assumption based on Robert's post was that once all dependencies are satisfied, this can be checked in. The dependent patches landed on mozilla-aurora at the time, which is now the beta channel. Hence my assumption that we need to land it on comm-aurora/beta but not comm-esr45 (I've only noticed after seeing your comment that it landed on mozilla-esr45 too). Then ewong stated that there is some work to do in the server setups to make it create the correct update snippets for the affected channels. That was for SeaMonkey though, I don't know if the same applies to Thunderbird.

Ewong, if you have a minute, can you explain what's needed or redirect the needinfo to rstrong? Thanks.
Flags: needinfo?(rsx11m.pub) → needinfo?(ewong)
Attachment #8755058 - Flags: approval-comm-esr45?
(In reply to Jorg K (GMT+2, PTO during summer, NI me) from comment #6)
> IOW: If I uplift to TB 48/49, will those versions be fixed or broken ;-)

We should see with tomorrow's nightly if it breaks TB 50 on trunk. I've left a heads-up in http://forums.mozillazine.org/viewtopic.php?f=29&t=3002177&start=15#p14635367
Sure, and we assume that if it works, the other versions (Earlybird, beta and ESR) will work, too?
How will we make sure that the current beta 47 will update to beta 48 one day when the new code isn't in beta 47? And how does FF make sure that they update from 47 to 48 when they only uplifted bug 1271761 (which landed on 49) to 48 and ESR 45?

That all depends on how the website answers the request for
https://aus5.mozilla.org/update/3/%PRODUCT%/%VERSION%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/update.xml
and
https://aus5.mozilla.org/update/6/%PRODUCT%/%VERSION%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%SYSTEM_CAPABILITIES%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/update.xml

So I wonder whether the uplifts are necessary or whether the website is smart enough to recognise "old format" requests.
(In reply to rsx11m from comment #7)
> Comment on attachment 8755058 [details] [diff] [review]
> patch rev1
> 
> (In reply to Jorg K (GMT+2, PTO during summer, NI me) from comment #5)
> > So what about the server work?
> 
> Frankly, I have no clue. My initial assumption based on Robert's post was
> that once all dependencies are satisfied, this can be checked in. The
> dependent patches landed on mozilla-aurora at the time, which is now the
> beta channel. Hence my assumption that we need to land it on
> comm-aurora/beta but not comm-esr45 (I've only noticed after seeing your
> comment that it landed on mozilla-esr45 too). Then ewong stated that there
> is some work to do in the server setups to make it create the correct update
> snippets for the affected channels. That was for SeaMonkey though, I don't
> know if the same applies to Thunderbird.
> 
> Ewong, if you have a minute, can you explain what's needed or redirect the
> needinfo to rstrong? Thanks.

AIUI, TB already uses balrog for the updates, so there really shouldn't
be anything needed for TB or rstrong since if Firefox works with updating,
then TB should work as well.
Flags: needinfo?(ewong)
Attachment #8755058 - Flags: approval-comm-beta?
Attachment #8755058 - Flags: approval-comm-beta+
Attachment #8755058 - Flags: approval-comm-aurora?
Attachment #8755058 - Flags: approval-comm-aurora+
This needs to be done eventually, but I think can wait until a beta cycle. Really two beta cycles would be nice since it affects updates.
Comment on attachment 8755058 [details] [diff] [review]
patch rev1

http://hg.mozilla.org/releases/comm-esr45/rev/9b6e406c4875
Attachment #8755058 - Flags: approval-comm-esr45? → approval-comm-esr45+
You need to log in before you can comment on or make changes to this bug.