Setting (pref) needed to save/remember tabs/windows state for next (or default) start of mozilla

VERIFIED DUPLICATE of bug 36810

Status

SeaMonkey
Tabbed Browser
--
enhancement
VERIFIED DUPLICATE of bug 36810
16 years ago
9 years ago

People

(Reporter: Christophe Combelles, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When stopping mozilla or when mozilla crashes,
it would be very nice to let it reopen the same tabbed web pages at the next start.
(Just like Opera)

Since mozilla can have several windows with several tabs in each, the same
tab/windows config could be restarted, for example : 2 windows, the first with 3
tabs, and the 2nd with 5 tabs.
(Assignee)

Comment 1

16 years ago
-> future
Target Milestone: --- → Future

Comment 2

16 years ago
BTW this bug is related to bug 33328 and to bug 102130. This bug is IMHO very
similar to bug 105264 (which was duped to bug 102130). Jag, check it for dupes.

*** This bug has been marked as a duplicate of 102130 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
This bug is not a dupe of bug 102130 because that bug is only about saving
groups of tabs as a "Bookmark Group". This bug is about remembering the *state*
of the open browser windows and tabs for the *next startup*.

This bug should probably be implemented via a preference: "Remember state of
windows and tabs when exiting (state will be restored on next startup)".

I suggest to reopen this bug, so this useful feature doesn't get buried.

Comment 5

16 years ago
The summary probably needs changing to something more "findable":
"Setting (pref) needed to save/remember tabs/windows state for next (or default)
start of Mozilla"
(Reporter)

Comment 6

15 years ago
This wanted feature is implemented very well in Opera.
It is absolutely not the same than bug 33328 or bug 102130.
The purpose it to start mozilla with the same tabs than at the last exit.


The most similar is bug 105264 :
"i expected my old tabbed windows to reappear on a restart."
(which should not be duped to bug 102130)


Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: reopen tab that were opened when exited → Setting (pref) needed to save/remember tabs/windows state for next (or default) start of mozilla

Comment 7

15 years ago
*** Bug 137481 has been marked as a duplicate of this bug. ***
Peter, thanks for the clarification.... Then this bug is a duplicate of
"Autosave URIs of open windows"

*** This bug has been marked as a duplicate of 36810 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE

Comment 9

15 years ago
v
Status: RESOLVED → VERIFIED

Comment 10

15 years ago
No, this shouldn't be a dupe of bug 36810. That bug is about restoring tabs
after a crash. This bug is about being able to save a set of tabs/windows as the
"Homepage" preference - so it opens those tabs on *every* startup (not just
after a crash).
Then that's a dup of the "set bookmark group as homepage" bug (no bug number
handy, but it's filed).
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.