Closed Bug 1285974 Opened 3 years ago Closed 3 years ago

Land version 1.4.3 of the Loop system add-on in mozilla-central

Categories

(Hello (Loop) :: Client, defect, P1)

defect

Tracking

(firefox48 verified, firefox49 verified, firefox50 verified)

VERIFIED FIXED
mozilla50
Tracking Status
firefox48 --- verified
firefox49 --- verified
firefox50 --- verified

People

(Reporter: standard8, Assigned: standard8)

References

()

Details

(Whiteboard: [btpp-fix-now])

Attachments

(1 file)

Attachment #8769716 - Flags: review+
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/2578ab43cad6
Land version 1.4.3 of the Loop system add-on in mozilla-central, rs=Standard8 for already reviewed code.
https://hg.mozilla.org/mozilla-central/rev/2578ab43cad6
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Comment on attachment 8769716 [details] [diff] [review]
Land version 1.4.3 of the Loop system add-on in mozilla-central, rs=Standard8 for already reviewed code.

Approval Request Comment
[Feature/regressing bug #]: Firefox Hello connectivity analysis & improvements. This includes:

- Increases a timeout which we think might be responsible for some of our issues.
- Further improvements in metrics logging to allow easier analysis.
- Latest L10n changes (includes a bunch of string removals)
- Updates to react 15.2.1

[User impact if declined]: Potentially fixes some timeout issues caused by a shorter limit. 
[Describe test coverage new/current, TreeHerder]: Landed in m/c, has unit tests.
[Risks and why]: Low - small changes to continue to work on connectivity issues.
[String/UUID change made/needed]: None
Attachment #8769716 - Flags: approval-mozilla-beta?
Attachment #8769716 - Flags: approval-mozilla-aurora?
Hi Mark,
If we let this ride the train on 49/50 only and won't fix in 48, will this be a big impact for user for 48 because these patches seem big to me and I would like the extra bake time?
Flags: needinfo?(standard8)
Hi Gerry,

(In reply to Gerry Chang [:gchang] from comment #5)
> If we let this ride the train on 49/50 only and won't fix in 48, will this
> be a big impact for user for 48 because these patches seem big to me and I
> would like the extra bake time?

The functional changes to the patch aren't that big - they are just the changes in roomViews.js (trivial correction), otSdkDriver.js and sdk.js. The latter two are going out on our "standalone" web pages today, where they'll immediately be going to all our users (the standalone web pages have a different shipping process).

Most of the loop.properties changes are updates to almost all our locales - as we removed 20 or so obsolete strings and hence they all got updated (we don't use the m-* system of l10n).

The react-* changes are a minor upgrade of a well established third party library that's well tested in itself and is used in lots of projects. There's 4 of these files because of how react is structured and the fact that we export debug and release versions of the react libraries into the m-* repos.

The only other changes are to test files to support the small functional changes we've done.

I realise its slightly later in the cycle than we would normally land big changes for system add-ons, however I really don't think these are big changes. As described above, the main parts of the changes are small, the rest is utility/due to how we do our l10n.
Flags: needinfo?(standard8)
flod, does any of this concern you (about locales and strings)?  Just double checking, sounds like this should be ok.
Flags: needinfo?(francesco.lodolo)
Yes, this is just a dump of strings localized outside in an external GitHub repository, and they're not exposed to dashboards.
Flags: needinfo?(francesco.lodolo)
Comment on attachment 8769716 [details] [diff] [review]
Land version 1.4.3 of the Loop system add-on in mozilla-central, rs=Standard8 for already reviewed code.

OK, let's uplift this to aurora and beta. This should be in place for beta 8 build and release later this week.
Attachment #8769716 - Flags: approval-mozilla-beta?
Attachment #8769716 - Flags: approval-mozilla-beta+
Attachment #8769716 - Flags: approval-mozilla-aurora?
Attachment #8769716 - Flags: approval-mozilla-aurora+
I think we can close this as verified fixed based on our testing done using version 1.4.3 of the add-on on Firefox 48 beta 9. Here is the testsuite for more information: https://goo.gl/cQ9oyt
You need to log in before you can comment on or make changes to this bug.