system add-ons should not honor "empty" Balrog response

RESOLVED DUPLICATE of bug 1292029

Status

()

RESOLVED DUPLICATE of bug 1292029
2 years ago
2 years ago

People

(Reporter: rhelmer, Assigned: rhelmer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: triaged)

(Assignee)

Description

2 years ago
Noticed this while testing bug 1284564 (see bug 1284564 comment 2):

* if we have not applied any updates, nothing happens and this is logged:
https://dxr.mozilla.org/mozilla-central/rev/c9a70b64f2faa264296f0cc90d68a2ee2bac6ac5/toolkit/mozapps/extensions/internal/XPIProvider.jsm#3045

* if there *have* been any updates applied, then instead all updates are removed and all default add-ons are disabled, as documented.

Osmose points out why this is happening in bug 1284564 comment 4:

Ah, that makes sense, the two empty sets match. Reading through the code again, `addonList` is `null` if the `<addons>` tag is missing, and `[]` if it is present but empty.
(Assignee)

Comment 1

2 years ago
Unless there is an urgent need for this feature, we might want to just do bug 1272672 instead.
Status: NEW → ASSIGNED
See Also: → bug 1272672

Updated

2 years ago
Whiteboard: triaged
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1291752
(Assignee)

Comment 3

2 years ago
(In reply to Robert Helmer [:rhelmer] from comment #1)
> Unless there is an urgent need for this feature, we might want to just do
> bug 1272672 instead.

So the reason our tests didn't catch this before is that some tests weren't running due to a JS scoping bug, see bug 1291569.

I'm going to go ahead and fix this now so we can fully enable existing tests, before I start on bug 1272672.
(Assignee)

Comment 4

2 years ago
The more I think about this, the more I think we should just remove this feature.

Right now the way an "empty" Balrog response is treated is to remove all updates, and disable all built-in add-ons. There isn't really a great way to re-enable the built-in add-ons other than to continue pushing updates.

I don't think there's really a great use case for doing this, and having it happen by accident would be pretty harmful.

We should remove this feature, and also implement bug 1273709 which will give us a way to specify that either the built-in or the updated version should be used.
Summary: missing add-on in system add-on set only disables if updates have been applied → system add-ons should not honor "empty" Balrog response
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1292029
You need to log in before you can comment on or make changes to this bug.