email preferences redesign

RESOLVED FIXED in Bugzilla 2.20

Status

()

Bugzilla
User Interface
--
enhancement
RESOLVED FIXED
16 years ago
5 years ago

People

(Reporter: myk, Assigned: gerv)

Tracking

2.15
Bugzilla 2.20

Details

(Reporter)

Description

16 years ago
Notify me of the following changes: 

                        | assignee | qa | cc | reporter |
                        +----------+----+----+----------+
   - include option 1   |          |    |    |          |
                        +----------+----+----+----------+
   - ...                |          |    |    |          |
                        +----------+----+----+----------+
   - include option n   |          |    |    |          |
                        +----------+----+----+----------+

but do not send me any notification (overrides above):

                        +----------+----+----+----------+
   - at all             |          |    |    |          |
                        +----------+----+----+----------+
   - for my own changes |          |    |    |          |
                        +----------+----+----+----------+
   - for UNCONFIRMED    |          |    |    |          |
                        +----------+----+----+----------+
(Reporter)

Comment 1

16 years ago
That description is a bit ambiguous, so let me clarify further.  This bug is for
redesigning the "email preferences" page.  Some redesign work already took place
during the templatization of userprefs.cgi (bug 117060), but more needs to be
done because of new email preferences for unconfirmed bugs (bug 122900, from
which this bug is broken off) and disabling all notifications (bug 123971),
which might work better as "excluding" preferences.  This bug probably relies on
the email preferences table work going on in bug 73665.

Adding dependency ot bug 73665, moving to User Interface component, and
reassigning to default owner and QA contact of that component.
Assignee: jake → myk
Component: Email Notifications → User Interface
Depends on: 73665

Comment 2

16 years ago
Bug 73665 has a rough patch on it that contains some of my preliminary work at
redesigning this page. It actually seperates it out into tabs, one for global
prefs, and another for direct relationships. This leaves room to add new tabs
for things like product/component watching (bug 76794) and setting specific
prefs when you're watching a specific user (bug 74996).

Comment 3

16 years ago
Note that in this design, the include options are not necessarily mutually
exclusive. Thus the current 'elsif' stuff needs to be replaced by a loop
independently checking each option. See the discussion in bug 146261, in
particular around bug 146261 comment 4.
some recent things I've seen on mozilla.org indicate we do have a need for this
feature. :)

targetting at 2.18, but I may be dreaming.  This is basically a ping to see if
anyone was still thinking about this.
Severity: normal → enhancement
Target Milestone: --- → Bugzilla 2.18
The User Interface component now belongs to Gerv.  Reassigning all UNCONFIRMED
and NEW (but not ASSIGNED) bugs currently owned by Myk (the previous component
owner) to Gerv.
Assignee: myk → gerv
Reassigning back to Myk.  That stuff about Gerv taking over the User Interface
component turned out to be short-lived.  Please pardon our confusion, and I'm
very sorry about the spam.
Assignee: gerv → myk
(Reporter)

Comment 7

14 years ago
Pushing off, although this could still happen if 73665 gets into 2.18.
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
Bugzilla 2.20 feature set is now frozen as of 15 Sept 2004.  Anything flagged
enhancement that hasn't already landed is being pushed out.  If this bug is
otherwise ready to land, we'll handle it on a case-by-case basis, please set the
blocking2.20 flag to '?' if you think it qualifies.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22
Blocks: 262318
(Assignee)

Comment 9

13 years ago
The UI checked in in bug 73665 was inspired by this bug.

Gerv
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Target Milestone: Bugzilla 2.22 → Bugzilla 2.20

Updated

13 years ago
No longer blocks: 262318
Assignee: myk → gerv
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.