Minor issues when upgrading Daily to 51.0

RESOLVED DUPLICATE of bug 1271153

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 1271153
2 years ago
2 years ago

People

(Reporter: psn, Unassigned)

Tracking

51 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160803030226

Steps to reproduce:

Manually start upgrade of 0.50 in the following configurations.
1) Windows Server 2012r2 64-bit, Daily 64-bit
2) Windows 10 32-bit Daily 32-bit
3) Windows 8.1 64-bit, Daily 64-bit



Actual results:

1) Upgraded to 0.51

2) Button text was about 0.51, Daily upgraded, but displayed version was 0.50. I downloaded installer and unpacked it - displayed version is still 0.50 even though Explorer shows thunderbird.exe version as 51.0.0.6058, file created 03.08.2016 10:23

3) Did not find any upgrades. Downloaded installer and unpacked, displayed version 0.51


Expected results:

1) All is good
2) Should be 0.51 in About dialog
3) Upgrades should have been found.
(Reporter)

Comment 1

2 years ago
Addidtionally, in thunderbird-51.0a1.en-US.win32.installer.exe file thunderbird.exe has timestamp 02.08.2016 14:34
The new file, version_display.txt, introduced by bug 1271151 wasn't bumped at the uplift.

Do we need this file really? It is redundant information in it.

Patrick, you are the one who makes the version bumps, what do you think about this file?
Blocks: 1271151
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(sledru)
Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(clokep)

Comment 3

2 years ago
See bug 1271153
Flags: needinfo?(mkmelin+mozilla)
I will try to land and fix that this afternoon
Flags: needinfo?(sledru)
I'll dupe this bug to bug 1271153 as the action is there.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(clokep)
Resolution: --- → DUPLICATE
Duplicate of bug: 1271153
You need to log in before you can comment on or make changes to this bug.