Closed Bug 1301940 Opened 3 years ago Closed 3 years ago

compare-locales is not processing mozilla/devtools/client for SeaMonkey

Categories

(SeaMonkey :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: iann_bugzilla, Assigned: Pike)

References

Details

Attachments

(1 file)

SeaMonkey's l10n.ini has an entry for mozilla/devtools/client
https://dxr.mozilla.org/comm-central/source/suite/locales/l10n.ini#12
but when you run a compare-locales against that l10n.ini file it is not picking up any required changes
running against Firefox's l10n.ini it does

Steps to reproduce:
1. Have comm repo and locale repo where there are known changes in devtools/client needed
2. Run compare-locales between the two repos for Firefox's l10n.ini file
3. Run compare-locales between the two repos for SeaMonkey's l10n.ini file

Expected result:
1. The devtools/client changes are the same for both compare-locales runs

Actual result:
1. No changes showing for devtools/client for the SeaMonkey compare-locales run

Workaround:
1. Always do the Firefox compare-locales run first and update locale for devtools/client before doing the SeaMonkey compare-locales
compare-locales in its current config options doesn't support cross-repo directories, just cross-repo includes.

We're currently in the process of redesigning the configuration of compare-locales, and I can add this to the wish list.

If you want to fix this before, you'll need to add an l10n.ini to devtools/client, and include that from suite/locales/l10n.ini.
Depends on: 1305206
When sanitizing the l10n.ini files, I removed the edits from bug 1223338. I can't see how they would have worked, tbh.

What we need is a l10n.ini in devtools/client/locales, and then import that. I filed bug 1305206 to get the l10n.ini created.
Attachment #8794502 - Flags: review?(iann_bugzilla)
Comment on attachment 8794502 [details]
bug 1301940, including devtools/client for SeaMonkey,

https://reviewboard.mozilla.org/r/80932/#review79598

r/a=me
Attachment #8794502 - Flags: review?(iann_bugzilla)
Comment on attachment 8794502 [details]
bug 1301940, including devtools/client for SeaMonkey,

https://reviewboard.mozilla.org/r/80932/#review79600
Attachment #8794502 - Flags: review+
https://hg.mozilla.org/comm-central/rev/d0061f4bceb92a21de92bbdcabbd11bf978e6f53, now that bug 1305206 is fixed.
Assignee: nobody → l10n
Status: NEW → RESOLVED
Closed: 3 years ago
Component: compare-locales → Build Config
Product: Localization Infrastructure and Tools → SeaMonkey
Resolution: --- → FIXED
> l10n-aurora.ini l10n-beta.ini l10n-central.ini 
Are these files used? If not they should be removed to avoid confusion.
NI: ewong and adrian
Flags: needinfo?(ewong)
Flags: needinfo?(akalla)
These files are used by the l10n dashboard.

And yes, all three need the same fix, reopening. Sorry for the oversight. I'll come up with a follow-up patch tomorrow.
Status: RESOLVED → REOPENED
Flags: needinfo?(ewong)
Flags: needinfo?(akalla)
Resolution: FIXED → ---
Blocks: 1307247
https://hg.mozilla.org/comm-central/rev/55af8d226425f16cc78c8a2973ca2afbb6fc1af5

landed the follow-up with r/a=me, as they only affect the l10n dashboard, and confirmed that they show the intended data there.

Does this need uplifts? If so, it should be done for both patches.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
No longer blocks: 1307247
(In reply to Axel Hecht [:Pike] from comment #9)
> Does this need uplifts? If so, it should be done for both patches.

+1

If it was bug 1182722 that broke this (?), then they even need uplift to 45. Are there broken strings in the ESR?
Flags: needinfo?(iann_bugzilla)
Yes, it will need uplift, assuming the m-c patch is too. Though don't the l10n-aurora.ini l10n-beta.ini changes already require m-b and m-a to be patched?
Flags: needinfo?(iann_bugzilla) → needinfo?(l10n)
Yes, if this needs uplift, so does the devtools bug this depends on, even for the patch to l10n.ini.
Flags: needinfo?(l10n)
(In reply to Axel Hecht [:Pike] from comment #12)
> Yes, if this needs uplift, so does the devtools bug this depends on, even
> for the patch to l10n.ini.

As the patch author, please request uplift here and on bug 1305206 in that case. Thanks!
Comment on attachment 8794502 [details]
bug 1301940, including devtools/client for SeaMonkey,

[Approval Request Comment]
Regression caused by (bug #): see bug 1305206
User impact if declined: broken strings
Testing completed (on m-c, etc.): yes
Risk to taking this patch (and alternatives if risky): low

Please only uplift after the uplift has happened in bug 1305206
Attachment #8794502 - Flags: approval-comm-beta?
Attachment #8794502 - Flags: approval-comm-aurora?
Comment on attachment 8794502 [details]
bug 1301940, including devtools/client for SeaMonkey,

a=me
Attachment #8794502 - Flags: approval-comm-beta?
Attachment #8794502 - Flags: approval-comm-beta+
Attachment #8794502 - Flags: approval-comm-aurora?
Attachment #8794502 - Flags: approval-comm-aurora+
jorgk: more material for your next c-a/c-b pushes ;)
Flags: needinfo?(jorgk)
C-A: https://hg.mozilla.org/releases/comm-aurora/rev/b55b11a021eacc22460a25708e9d3584279277b2
C-B: https://hg.mozilla.org/releases/comm-beta/rev/2d248210cfeae43757dded4619b2ee9e8e3d7c29
The patch didn't apply to beta, so I did it by hand, I hope I got it right, please check.

Please set tracking flags as appropriate, I always get confused with SM version numbers.
Flags: needinfo?(jorgk)
You need to log in before you can comment on or make changes to this bug.