Closed Bug 1307247 Opened 3 years ago Closed 3 years ago

repacks failing all platforms for TB beta 50: Locale doesn't have a manifest entry for 'devtools'

Categories

(Thunderbird :: Build Config, defect)

50 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: wsmwk, Assigned: Fallen)

References

Details

Attachments

(1 file)

question for pike...recommendations?

Repacks failing all platforms for Thunderbird beta 50. 

**rail	Error: Locale doesn't have a manifest entry for 'devtools'
in https://archive.mozilla.org/pub/thunderbird/candidates/50.0b1-candidates/build1/logs/release-comm-beta-linux_repack_1-bm74-build1-build6.txt.gz

Callek	rail: wsmwk: actually I think there's a chance https://hg.mozilla.org/comm-central/rev/830d0c78b663 may just need porting to beta --- I'd check in with :Pike on the error
Callek	isn't certain though, just a guess.

Fallen	Callek: wsmwk: there was another issue lately in Seamonkey where the solution was just to add the devtools include to l10n.ini
Fallen	I don't remember the details, but Pike would know about that too
Flags: needinfo?(l10n)
There is bug 1301940 and bug 1305206 for SeaMonkey around devtools/client
Duplicate of this bug: 1307273
I'm generally worried about the state of l10n of thunderbird here.

There are no localized nightlies, nor aurora builds. Now also beta is broken. And the release repack seems to use an unsupported version of compare-locales, too.

I tried to find the latest aurora or nightly builds, and all I heard was one localizer being stuck on aurora from October 15 last year. I can't spot any actual builds, all I found in my spot tests on archive.mozilla.org were logs of various bustages during repacks.

My suggestion is to fix central, i.e. 52. There's a lot to do there, AFAICT.

Given the limited resources that the thunderbird team has, I suggest to carefully evaluate whether uplifting to 51 makes sense, and then if uplifting to 50 makes sense.

I also suggest to do quite intensive manual QA on those builds once they come up, as my suspicion is that you lost basically all community testers on those builds.
Flags: needinfo?(l10n)
(In reply to Axel Hecht [:Pike] from comment #3)
> I'm generally worried about the state of l10n of thunderbird here.

it is a bit of a mess


> There are no localized nightlies, nor aurora builds. Now also beta is
> broken. And the release repack seems to use an unsupported version of
> compare-locales, too.
> 
> I tried to find the latest aurora or nightly builds, and all I heard was one
> localizer being stuck on aurora from October 15 last year. I can't spot any
> actual builds, all I found in my spot tests on archive.mozilla.org were logs
> of various bustages during repacks.

my impression is aurora is broken mainly from such things as bug 1222878 and friends. 


The list of l10n issues https://mzl.la/2decpMd   Some are making progress, like bug 1267523, but it does tend to be slow compared to our ability to fix non-l10n build issues

 
> My suggestion is to fix central, i.e. 52. There's a lot to do there, AFAICT.
I think this bug is evidence that there are regressions hiding behind the build bustages, and that we won't find the regressions unless we have builds and people looking at them. And I wouldn't be surprised if we had to go through a series of build regressions until we get to functional regressions.
Pike, I agree with you that Thunderbird l10n is in a bad shape and it is sad that we haven't managed to get nightly builds back in the last year. As you surely know, the beta build and repack process works much differently from the nightly process. I am not saying that we shouldn't be fixing aurora or central, but the repacks failing here is likely a separate issue. The correct place to vent about nightly builds missing (if on bugzilla at all) is bug 1222878, which desperately needs some progress. 

The fix for this is likely minor, fixing the nightly l10n builds looks like it is much more work.
Depends on: 1301940
this doesn't depend on seamonkey patches, cleanup up the dependency to bug 1280683.

note, the fact that this dies with 'devtools' missing probably indicates a problem with devtools/shared (via toolkit), not with devtools/client.
No longer depends on: 1301940
Summary: repacks failing all platforms for Thunderbird beta 50 → repacks failing all platforms for TB beta 50: Locale doesn't have a manifest entry for 'devtools'
Attached patch Fix - v1 β€” β€” Splinter Review
This should take care. I've tested locally and it works great. I didn't do the changes from comment 1 because the dependent bug has not yet taken the train to beta.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #8798979 - Flags: review?(aleth)
I seriously doubt that this is going to produce builds that don't YSOD.
Comment on attachment 8798979 [details] [diff] [review]
Fix - v1

[Approval Request Comment]
Regression caused by (bug #): 1305206

Thanks!
Attachment #8798979 - Flags: review?(aleth)
Attachment #8798979 - Flags: review+
Attachment #8798979 - Flags: approval-comm-beta?
Depends on: 1305206
Keywords: checkin-needed
No longer depends on: 1305206
https://hg.mozilla.org/comm-central/rev/baf4cfd72cb654470219f5b0420951fd538fd7d5
That patch couldn't be applied since the patch has spaces and the file to be patched has tabs.

Uplifts coming.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Depends on: 1305206
Keywords: checkin-needed
Resolution: --- → FIXED
(In reply to Jorg K (GMT+2) from comment #11)
> https://hg.mozilla.org/comm-central/rev/
> baf4cfd72cb654470219f5b0420951fd538fd7d5
> That patch couldn't be applied since the patch has spaces and the file to be
> patched has tabs.
Sorry, I used the paste attachment feature which of course broke tabs.


(In reply to Axel Hecht [:Pike] from comment #9)
> I seriously doubt that this is going to produce builds that don't YSOD.

Given we aren't yet using the devtools UI in Thunderbird, I don't think it will be a problem. Aside from that, l10n merge should take care of it? This will become more relevant in bug 1279834, I will make the l10n.ini changes there.
> (In reply to Axel Hecht [:Pike] from comment #9)
> > I seriously doubt that this is going to produce builds that don't YSOD.
> 
> Given we aren't yet using the devtools UI in Thunderbird, I don't think it
> will be a problem. Aside from that, l10n merge should take care of it? This
> will become more relevant in bug 1279834, I will make the l10n.ini changes
> there.

l10n-merge doesn't do anything for thunderbird and devtools, neither for devtools/shared nor devtools/client.

And if we're not using devtools/client UI, why would we want to package the strings?

toolkit/locales/l10n.ini OTH does include devtools/shared,

http://hg.mozilla.org/releases/mozilla-beta/file/tip/toolkit/locales/Makefile.in#l19
http://hg.mozilla.org/releases/mozilla-beta/file/tip/toolkit/locales/l10n.ini#l13

Which makes me think that triggering devtools/client covers up for a problem with devtools/shared.
(In reply to Axel Hecht [:Pike] from comment #14)
> > (In reply to Axel Hecht [:Pike] from comment #9)
> > > I seriously doubt that this is going to produce builds that don't YSOD.
> > 
> > Given we aren't yet using the devtools UI in Thunderbird, I don't think it
> > will be a problem. Aside from that, l10n merge should take care of it? This
> > will become more relevant in bug 1279834, I will make the l10n.ini changes
> > there.
> 
> l10n-merge doesn't do anything for thunderbird and devtools, neither for
> devtools/shared nor devtools/client.
> 
> And if we're not using devtools/client UI, why would we want to package the
> strings?
This may actually be the browser console. We'll keep an eye out for what happens during testing, but frankly this fix is all I have time for at the moment. If it doesn't work out we can uplift the l10n.ini changes you did for Seamonkey to make sure we have all the strings we need.
You need to log in before you can comment on or make changes to this bug.