Troubleshooting Information completely broken

RESOLVED DUPLICATE of bug 1300562

Status

RESOLVED DUPLICATE of bug 1300562
2 years ago
2 years ago

People

(Reporter: jorgk, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
In today's Daily 51.0a1 (2016-09-19) (64-bit) I get this when opening the Troubleshooting Information:

XML Parsing Error: undefined entity Location: jar:file:///C:/Program%20Files/Mozilla%20Thunderbird%2051/omni.ja!/chrome/messenger/content/messenger/about-support/aboutSupport.xhtml Line Number 122, Column 19:
                  &aboutSupport.showWin.label;
------------------^

Strangely enough, my local build on latest C-C trunk and M-C a few days outdated doesn't show the problem. That indicates that some bustage has crept in here via an M-C change in the last few days.

It's not related to bug 1302830 I hope.

Alice, can you help identifying the problem.
How can we thank enough you for your invaluable help ;-)
Flags: needinfo?(alice0775)
(Reporter)

Comment 1

2 years ago
(In reply to Jorg K (GMT+2, never had any PTO during summer) from comment #0)
> It's not related to bug 1302830 I hope.
It's not. I tried the Tinderbox debug and opt builds
https://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win32-debug/1474116258/
https://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win32/1474116258/
of that push and it works. So it broke somewhere between Sat Sep 17, 14:43:56 and now.

Comment 2

2 years ago
#1 Regression window:
Last Good:
http://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win32/1473799447/

First crash:
http://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win32/1473839167/

#1 Pushlog:
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=c482d8a2cd6178a9e5990c07b6c7c09dc63d919d&tochange=44003aa9b4def847e79458ca5756e50c1f0032b3
https://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2016-09-13+13%3A00%3A00&enddate=2016-09-14+01%3A00%3A00

#1 Regressed by:
77a72b7f61d4	Sotaro Ikeda — Bug 1281785 - JavaScript error: chrome://messenger/content/about-support/gfx.js, line 46: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]. r=mkmelin


#2 Regression Window:
Last crash:
http://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win32/1474276578/

Parse Error:
http://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win32/1474279342/

#2 Pushlog
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=dce2850d96b9a891bb078367bcf6e07c5cc5d585&tochange=dce2850d96b9a891bb078367bcf6e07c5cc5d585
https://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2016-09-19+02%3A00%3A00&enddate=2016-09-19+04%3A00%3A00

#2 Not found suspicious bug of candidate.
   Presumably due to the difference in the build config(or build machine) between nightly build and tinderbox build.
Flags: needinfo?(alice0775)

Comment 3

2 years ago
I assume fallout from not yet checked in patch in bug 1300562.
Should be fixed by https://hg.mozilla.org/comm-central/rev/a2836536b7e00825a6e108ecd749460d54498cd3

Alice, can you see why your method didn't find it? Was the breaking checkin to m-c too recent?

Comment 4

2 years ago
Bug 1281785 triggers the crash on Windows10.
Probably, Bug 1300562 hides the crash. And the crash will reappear after fixing bug 1300562.
I will file a bug if crash after fixing bug 1300562.

Comment 5

2 years ago
What crash? I assume from the bug report that the is an error about missing entity, but otherwise TB continues to run.
Confirmed it doesn't work. But:
(In reply to :aceman from comment #3)
> I assume fallout from not yet checked in patch in bug 1300562.
> Should be fixed by
> https://hg.mozilla.org/comm-central/rev/
> a2836536b7e00825a6e108ecd749460d54498cd3

With this check-in it's working again.

I close this bug as WORKSFORME because the error in comment 0 is gone. Crashes etc. should go in new bugs (I see no crash).

Comment 7

2 years ago
(In reply to :aceman from comment #5)
> What crash? I assume from the bug report that the is an error about missing
> entity, but otherwise TB continues to run.

Bug 1303301
(Reporter)

Comment 8

2 years ago
Thanks to all involved, making this a duplicate of bug 1300562.
Just bad timing that M-C and C-C parts landed hours apart.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: regression, regressionwindow-wanted
Resolution: --- → DUPLICATE
Duplicate of bug: 1300562

Comment 9

2 years ago
(In reply to Alice0775 White from comment #4)
> Bug 1281785 triggers the crash on Windows10.
> Probably, Bug 1300562 hides the crash. And the crash will reappear after
> fixing bug 1300562.
> I will file a bug if crash after fixing bug 1300562.

http://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win32/1474300577/
https://hg.mozilla.org/comm-central/rev/a2836536b7e00825a6e108ecd749460d54498cd3

As I expected, the crash is back on latest tinderbox build(incl the patch of bug 1300562).
You need to log in before you can comment on or make changes to this bug.