Last Comment Bug 1300562 - On about:support, "Show Folder" (Windows) is misleading
: On about:support, "Show Folder" (Windows) is misleading
Status: VERIFIED FIXED
: polish
Product: Toolkit
Classification: Components
Component: General (show other bugs)
: Trunk
: x86 Windows
P5 normal with 1 vote (vote)
: mozilla51
Assigned To: Ton
:
:
Mentors:
: 1303741 (view as bug list)
Depends on: 559500 631909
Blocks: 725971 559501
  Show dependency treegraph
 
Reported: 2016-09-05 08:08 PDT by Ton
Modified: 2017-01-09 02:12 PST (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard: [good first verify]
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified


Attachments
bug 1300562_mc.patch (2.40 KB, patch)
2016-09-07 10:05 PDT, Ton
dtownsend: review+
Details | Diff | Splinter Review
bug 1300562_cc.patch (1.00 KB, patch)
2016-09-07 10:06 PDT, Ton
acelists: review+
Details | Diff | Splinter Review

Description User image Ton 2016-09-05 08:08:52 PDT
+++ This bug was initially created as a clone of Bug #559500 +++

In bug 559500, the wording for opening the profile folder on Windows seems to have been erroneously changed to "Show Folder" even though there was consensus about "Open Folder" (see bug 559500 comment 4 and 5), possibly due to the Mac wording using "Show".

That bug changed "Open Containing Folder" to
Linux: Open Directory
Mac: Show in Finder
Win: Show Folder

Windows should probably need "Open Folder" rather than "Show Folder", since the folder _content_ is displayed and hence the folder itself is opened, like in Linux. Using "Show Folder", a user would expect to see e.g. C:\Users\<username>\AppData\Roaming\Mozilla\Firefox\Profiles\ i.e. the profile’s parent folder containing one or more profiles. I was told that’s what happens on Mac, but this is clearly not true on Windows.

Please change "Show Folder to "Open Folder" for Windows.
Comment 1 User image Ton 2016-09-07 10:05:16 PDT
Created attachment 8788957 [details] [diff] [review]
bug 1300562_mc.patch

This should do it.
Comment 2 User image Ton 2016-09-07 10:06:39 PDT
Created attachment 8788958 [details] [diff] [review]
bug 1300562_cc.patch

… and for TB.
Comment 3 User image Mark Banner (:standard8) 2016-09-07 10:56:36 PDT
Comment on attachment 8788957 [details] [diff] [review]
bug 1300562_mc.patch

You probably need a toolkit peer here.
Comment 4 User image Mark Banner (:standard8) 2016-09-07 10:57:13 PDT
Comment on attachment 8788958 [details] [diff] [review]
bug 1300562_cc.patch

I'm not active on Thunderbird any more, but I believe aceman can review this.
Comment 5 User image :aceman 2016-09-07 13:48:47 PDT
Comment on attachment 8788958 [details] [diff] [review]
bug 1300562_cc.patch

Review of attachment 8788958 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Comment 6 User image Pulsebot 2016-09-18 19:51:46 PDT
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/18d6932a3c5b
Change "Show Folder" to "Open Folder" in Windows. r=Mossop
Comment 7 User image Carsten Book [:Tomcat] 2016-09-19 03:16:57 PDT
https://hg.mozilla.org/mozilla-central/rev/18d6932a3c5b
Comment 8 User image :aceman 2016-09-19 08:57:58 PDT
Landed on comm-central too:
https://hg.mozilla.org/comm-central/rev/a2836536b7e00825a6e108ecd749460d54498cd3
Comment 9 User image Jorg K (GMT+1) 2016-09-19 09:56:04 PDT
*** Bug 1303741 has been marked as a duplicate of this bug. ***
Comment 10 User image Aminul Islam Alvi 2017-01-07 04:06:04 PST
I have reproduced this bug with Firefox 50.0b9(build ID:20161020152750)on 
windows 7(64 bit)

I have verified this bug as fixed with Firefox beta 51.0b12(build ID:20170105155013)
User Agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

[testday-20170106]
Comment 11 User image Bogdan Maris, QA [:bogdan_maris] 2017-01-09 02:12:40 PST
(In reply to Aminul Islam Alvi from comment #10)
> I have reproduced this bug with Firefox 50.0b9(build ID:20161020152750)on 
> windows 7(64 bit)
> 
> I have verified this bug as fixed with Firefox beta 51.0b12(build
> ID:20170105155013)
> User Agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101
> Firefox/51.0
> 
> [testday-20170106]

Thanks for verifying this bug!

Note You need to log in before you can comment on or make changes to this bug.