Closed Bug 1306670 Opened 3 years ago Closed 3 years ago

Scrolling in bookmarks menu hides text for 4 seconds and other issues with buttons & menus in Mozilla Firefox Nightly 52.0a1 (2016-09-30)

Categories

(Core :: Graphics: Text, defect, major)

52 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla52
Tracking Status
firefox49 --- unaffected
firefox-esr45 --- unaffected
firefox50 --- unaffected
firefox51 + verified
firefox52 + verified

People

(Reporter: Virtual, Assigned: bas.schouten)

References

(Depends on 1 open bug)

Details

(Keywords: nightly-community, regression)

Attachments

(4 files, 1 obsolete file)

I suspect that it was caused by bug #1303570,
as I remember similar issue in the past in bug #626299, which was caused by bug #622482.
Flags: needinfo?(bas)
@ Jonathan Kew (:jfkthame) - Could you please look in your free time on this bug, as it's nearly identical to the bug #626299, which you fixed. Thanks.
Has Regression Range: --- → yes
Has STR: --- → yes
Also there is some flickering after pressing download button, like just 1 second of not visible text.
Summary: Scrolling in bookmarks menu hides text for 4 seconds in Mozilla Firefox Nightly 52.0a1 (2016-09-30) → Scrolling in bookmarks menu hides text for 4 seconds and text in download button flickers for 1 second after pressing it in Mozilla Firefox Nightly 52.0a1 (2016-09-30)
Assignee: nobody → bas
Flags: needinfo?(bas)
(In reply to Virtual_ManPL [:Virtual] - (ni? me) from comment #5)
> Also there is some flickering after pressing download button, like just 1
> second of not visible text.

I can reproduce this, with a non 1.0 devPixelsPerPx. Not the issue with bookmarks, but let's assume it's the same bug for now.
Just FYI, I have by default set "layout.css.devPixelsPerPx" to "-1.0" on Windows 7 (64bit) with Nightly (64bit)
Status: NEW → ASSIGNED
(In reply to Virtual_ManPL [:Virtual] - (ni? me) from comment #8)
> Just FYI, I have by default set "layout.css.devPixelsPerPx" to "-1.0" on
> Windows 7 (64bit) with Nightly (64bit)

Same here on Win10 and I can reproduce.
I also see other issues that appeared in the same build and are likely related:

1. drag the devtools button to the nav-bar, click on it. The menu paints the previous content for a while, then clears and paints again.
2. Downloads in the downloads panel are missing the status greytext (the text below the file name indicating the host, size and so on).
Summary: Scrolling in bookmarks menu hides text for 4 seconds and text in download button flickers for 1 second after pressing it in Mozilla Firefox Nightly 52.0a1 (2016-09-30) → Scrolling in bookmarks menu hides text for 4 seconds and other issues with buttons & menus in Mozilla Firefox Nightly 52.0a1 (2016-09-30)
Tracking 52+ for this regression.
Flags: needinfo?(jfkthame)
Comment on attachment 8797195 [details]
Bug 1306670: Properly disable cleartype when the underlying surface indicates it may not be opaque.

https://reviewboard.mozilla.org/r/82796/#review81842
Attachment #8797195 - Flags: review?(jmuizelaar) → review+
Pushed by bschouten@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/df26b07efb46
Properly disable cleartype when the underlying surface indicates it may not be opaque. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/df26b07efb46
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Attached image No Cleartype on downloads panel (obsolete) —
The flickring on the panels has gone, thank you.

On the other side, I noticed the status text on the downloads panel is missing cleartype, see the difference compared to the Library window (on the right).

I guess this may be expected based on the name of the patch?
Any ideas on how we can workaround the problem in the UI?
The downloads details are set as:
.downloadDetails {
  opacity: 0.7;
  font-size: 95%;
Comment on attachment 8798034 [details]
No Cleartype on downloads panel

(In reply to Marco Bonardo [::mak] from comment #15)
> Created attachment 8798034 [details]
> No Cleartype on downloads panel
> 
> The flickring on the panels has gone, thank you.
> 
> On the other side, I noticed the status text on the downloads panel is
> missing cleartype, see the difference compared to the Library window (on the
> right).
> 
> I guess this may be expected based on the name of the patch?
> Any ideas on how we can workaround the problem in the UI?
+
(In reply to Marco Bonardo [::mak] from comment #16)
> The downloads details are set as:
> .downloadDetails {
>   opacity: 0.7;
>   font-size: 95%;

Confirmed and reported it here - bug #1307833
Attachment #8798034 - Attachment is obsolete: true
Duplicate of this bug: 1307439
Duplicate of this bug: 1307466
[Tracking Requested - why for this release]: Regression

Marking Firefox 51 as affected per uplift to Aurora bug #1303570 comment #56.
Track 51+ as regression.

Hi :bas.schouten,
could you please nominate this uplift to Beta51?
Flags: needinfo?(bas)
Hi Milan,
Can you help find someone to create uplift request for Beta51?
Flags: needinfo?(milan)
Duplicate of this bug: 1318571
Comment on attachment 8797195 [details]
Bug 1306670: Properly disable cleartype when the underlying surface indicates it may not be opaque.

Approval Request Comment
[Feature/regressing bug #]: 1303570
[User impact if declined]: Missing text in some fallback scenarios
[Describe test coverage new/current, TreeHerder]: Aurora
[Risks and why]: Can disable cleartype in some cases where it -could- be used.
[String/UUID change made/needed]: None
Flags: needinfo?(milan)
Flags: needinfo?(bas)
Attachment #8797195 - Flags: approval-mozilla-beta?
Duplicate of this bug: 1318612
Comment on attachment 8797195 [details]
Bug 1306670: Properly disable cleartype when the underlying surface indicates it may not be opaque.

Fix a regression when scrolling in bookmarks menu. Beta51+. Should be in 51 beta 2.
Attachment #8797195 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1318832
Duplicate of this bug: 1318898
Flags: qe-verify+
Blocks: 1335119
You need to log in before you can comment on or make changes to this bug.