Checking compatibility of Add-ons crashes Thunderbird with no crash report

RESOLVED DUPLICATE of bug 1265242

Status

Thunderbird
Untriaged
--
critical
RESOLVED DUPLICATE of bug 1265242
2 years ago
2 years ago

People

(Reporter: EN, Unassigned)

Tracking

(Depends on: 1 bug, {crash})

45 Branch
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

When starting Thunderbird the 'Checking compatibility of Add-ons' box briefly displays, and looks like its doing a task, and then the program abruptly crashes with no crash report. It may have started after a update - I am using Thunderbird version 45.4.0.  I discovered in the prefs.js file an entry that seems to be causing the problem...   
user_pref("extensions.lastAppVersion", "45.3.0"); 
I disabled the line and the program starts working again.


Actual results:

Could not start Thunderbird.


Expected results:

Program should have started

Comment 1

2 years ago
sounds like bug 1265242.
what do you think?
(Reporter)

Comment 2

2 years ago
I read  Mickael Pointier's Comment 11 on  bug 126524, where he changed the values of the user_pref("extensions.lastAppVersion", "45.3.0"); entry in the prefs.js file.  I did not try changing the values, I just deleted the whole line and the program started working again.  

When I was investigating the code lines, by progressively disabling/enabling them, it seemed another line worked in conjunction with the problem and displayed a slightly different looking prompt box asking if I would like to disable unused add-ons, I think it was the user_pref("extensions.lastPlatformVersion", "45.3.0"); line.  I can't recall the disable sequence but is seemed to me that these lines were close to each other and seemed to be related.  Don't know if I'm adding anything helpful here.

Anyway, spent several hours finding that problem line and am happy I was able to get the program operating again.

QUICK FIX:
If anybody comes here looking for a quick fix, here is what I did/discovered:  The prefs.js file is a javascript file that holds your Thunderbird profile settings.  The file seems to be dynamically written by the program, but can be edited.  Evidently this file can sometimes become corrupt (perhaps even by a update) and, as in this case, can make the program crash.  The file is located in the C:\Users\<users name>\AppData\Roaming\Thunderbird\Profiles directory, where where users profiles are stored, and there should be different folders for each profile.  The default profile will be named something like 2ufqb5ub.default and this folder will contain the prefs.js file.  With Thunderbird not running I opened up the file in notepad for editing and did a find for the user_pref("extensions.lastAppVersion", "45.3.0"); entry and deleted it. (in javascript each statement will end with a semicolon).  Save the file and start Thunderbird.

Supporting References:
http://kb.mozillazine.org/Recovering_a_profile_that_suddenly_disappeared#Corrupt_or_empty_prefs.js   
http://www-archive.mozilla.org/support/thunderbird/profile

Comment 3

2 years ago
Let's hope that bug 1265242 fixes this
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Depends on: 1265242
Keywords: crash
Resolution: --- → DUPLICATE
Duplicate of bug: 1265242
You need to log in before you can comment on or make changes to this bug.