Ctrl-M in news invokes Composer with blank address field and From field set to default identity

VERIFIED FIXED

Status

MailNews Core
Composition
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Victor Kazmirenko, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({regression})

Trunk
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
If Ctrl-M ('New message') is issued in a newsgroup Composer invokes with blank
address field. Described behavior appears independently of pointing any pane
i.e. it appears when newsgroup pointed in accounts pane, when message subject is
pointed in right-top pane and when body of message (right-bottom pane) is pointed.

Steps to reproduce:
1. Go to any newsgroup. 
2. Press Ctrl-M

Actual result:
Composer window invokes. Address selector is 'To:' and address field is blank.

Expexted result:
Address selector should be 'Newsgroup:' and address field should be filled with
name of current newsgroup.

Comment 1

16 years ago
Good catch Victor. This is actually a regression.

The correct behaviour is that the Compose Window should have the "Newsgroup:"
menuitem selected by default if a newsgroup or news-server is selected in the
folderpane.

Ducarroz, might this be a regression due to the recycled compose window?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
-->varada
Assignee: ducarroz → varada

Comment 3

16 years ago
Additionally, the wrong sender account is selected (I think it selects the
default account and not the one associated with the news server).

Comment 4

16 years ago
This looks like it has been caused by varada's fix for bug 105838.

Comment 5

16 years ago
*** Bug 146506 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
*** Bug 146822 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
*** Bug 148083 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Should bugs 164145 and 147071 be marked as duplicates of this bug? I think yes.
And I think we should add the "wrong FROM field" fact to the summary of this bug.

Comment 9

16 years ago
*** Bug 147071 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
knocte's right -- changing summary
Summary: Ctrl-M in news invokes Composer with blank address field → Ctrl-M in news invokes Composer with blank address field and From field set to default identity

Comment 11

16 years ago
This issue concerns only the keyboard shortcut. If you klick the
"Compose"-button or go via File -> New -> Message (Ctrl-M), then the expected
behaviour occurs.

Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.2a) Gecko/20020910

Comment 12

16 years ago
*** Bug 171788 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
sometimes it'a really hard to find bugs in here (I've looked up more than 200
bugs), sorry about the dupe

1.2b, 20020927-08

Comment 14

16 years ago
*** Bug 149779 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
Since the bug is related to newsgroups, the word "newsgroup" should show up in
the title. It took me a while to find to find this bug (about 4 month :p).
If we mark this bug as a dup of Bug 129402, we should add to the Summary the
fact "and From field set to default identity", which is not present on Bug 129402.

I think we should rather mark 129402 as a dup of 131536.

Comment 18

16 years ago
*** Bug 152227 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
It seems that the Strg-M-bug causes other strange behaviours of mailnews

nightly 20021011-04
===================

1) click a newsgroup
2) click an article
3) Strg-M
4) close the window via "x" at the right upper edge
5) Strg-R
6) now you see a window that looks like that

|--------------------------------|
| XYZ wrote in article...        |
|                                |
|--                              |
|signature of your mailaccount   |
|signature of your mailaccount   |
|signature of your mailaccount   |
|quotation of the clicked article|
|quotation of the clicked article|
|quotation of the clicked article|
|                                |
|--                              |
|signature of your newsaccount   |
|signature of your newsaccount   |
|signature of your newsaccount   |
|--------------------------------|

it's reproducable on my PC
-------------------------------
nightly 20021108-08
===================
not reproducable

nightly 20021109-??
===================
someone told, that he can reproduce "like that". He only sees his
mail-signature. I haven't tested on my own

Updated

15 years ago
QA Contact: sheelar → esther

Comment 20

15 years ago
*** Bug 129402 has been marked as a duplicate of this bug. ***
taking all of varada's bugs.
Assignee: varada → sspitzer

Comment 22

15 years ago
Hm, can't reproduce it.  Ctrl-M / Ctrl-R always "create a message" in the newsgroup.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030113
(Reporter)

Comment 23

15 years ago
That is good news. On my 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
I have correct behavior for Ctrl-R, but Ctrl-M still invokes composer with 'To:'
menuitem selected (instead of newsgroup).

Comment 24

15 years ago
This was fixed by the patch in bug 99363.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 25

15 years ago
Trunk build 2003-05-22: Mac 10.1.5, WinMe
Verified Fixed. Checked using Ctrl+M, Ctrl+R and it results in Address selector
set to 'Newsgroup:' and address field filled with name of current newsgroup.
Also uses the currently selected news server's identity for the From setting.
Status: RESOLVED → VERIFIED

Updated

15 years ago
QA Contact: esther → nbaca
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.