[e10s] Dropdown menu list is using wrong font size

VERIFIED FIXED in Firefox 52

Status

()

Core
Layout: Form Controls
P1
major
VERIFIED FIXED
9 months ago
21 days ago

People

(Reporter: Virtual, Unassigned)

Tracking

(Blocks: 1 bug, 5 keywords)

52 Branch
mozilla53
x86_64
Windows 7
multiprocess, nightly-community, regression, ux-consistency, ux-minimalism
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 unaffected, firefox-esr45 unaffected, firefox50 unaffected, firefox51 unaffected, firefox52+ verified, firefox53- verified)

Details

(Whiteboard: [fixed by patches from bug #1316722 and bug #1316404], URL)

Attachments

(5 attachments)

+++ This bug was initially created as a clone of Bug #1313418 +++

[Tracking Requested - why for this release]: Regression

STR:
1. Open this website page - https://bugzilla.mozilla.org/enter_bug.cgi?product=Core
2. Open second "Platform" dropdown menu list
3. See that font in text on dropdown menu list is using other size family than on button. The font is smaller. It's consistency and compatibility issue, comparing to other browsers.
Has Regression Range: --- → yes
Has STR: --- → yes
Hey Philipp, what do you think about the difference between the font being used on the button and what shows up in the popup?

You can look at https://bug1313418.bmoattachments.org/attachment.cgi?id=8805455 to see the difference. We didn't change the font on the button because we are worried about web compat.
Flags: needinfo?(philipp)

Comment 2

9 months ago
Created attachment 8809181 [details]
selects.jpg

I think this is a recent regression. might have something to do with recent gfx changes related to oopc.

Updated

9 months ago
Attachment #8809181 - Attachment is patch: false
Attachment #8809181 - Attachment mime type: text/plain → image/jpg

Comment 3

9 months ago
Created attachment 8809184 [details]
51selects.jpg

here's aurora, which doesn't have the issue.

Updated

9 months ago
Flags: needinfo?(florin.mezei)
Keywords: regressionwindow-wanted
(In reply to Jim Mathies [:jimm] from comment #2)
> Created attachment 8809181 [details]
> selects.jpg
> 
> I think this is a recent regression. might have something to do with recent
> gfx changes related to oopc.
+
(In reply to Jim Mathies [:jimm] from comment #3)
> Created attachment 8809184 [details]
> 51selects.jpg
> 
> here's aurora, which doesn't have the issue.

It's bug #1315568,
not this one, which is about wrong size of the fonts
Firefox 51 - https://bug1313418.bmoattachments.org/attachment.cgi?id=8805454
Firefox 52 - https://bug1313418.bmoattachments.org/attachment.cgi?id=8805455
It regressed because of patch from bug #1091592.

Updated

9 months ago
Flags: needinfo?(florin.mezei)

Updated

9 months ago
No longer blocks: 653064, 516752
Keywords: regressionwindow-wanted
status-firefox49: --- → unaffected
status-firefox50: --- → unaffected
status-firefox-esr45: --- → unaffected
status-firefox53: --- → affected
tracking-firefox53: --- → ?

Updated

9 months ago
Priority: -- → P1
This is fixed by the patch in bug 1316722.
Depends on: 1316722
Flags: needinfo?(philipp)
Fixed by bug 1316722.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
Thank you very much! \o/
Status: RESOLVED → VERIFIED
status-firefox53: affected → verified
Whiteboard: [fixed by patch from bug #1316722]
Tracking 53- since this is verified fixed.
tracking-firefox53: ? → -
Reopening, as it's not fixed for all dropdown menu lists
Status: VERIFIED → REOPENED
status-firefox53: verified → affected
tracking-firefox53: - → ?
Resolution: FIXED → ---
Created attachment 8813359 [details]
good size.png
Whiteboard: [fixed by patch from bug #1316722]
Created attachment 8813361 [details]
bad size.png
Flags: needinfo?(jaws)
Created attachment 8813403 [details]
font-size.png

This screenshot shows Firefox Beta 51 on the right and Firefox Nightly 53 on the left. The font-sizes here are the same between the two.

There were some changes in look between non-e10s and e10s but those are considered wontfix. The only changes that these two screenshots show is lighter border color, increased padding, and a grey background for the optgroup headers. These changes are by design.
Flags: needinfo?(jaws)
Status: REOPENED → RESOLVED
Last Resolved: 9 months ago9 months ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
status-firefox52: affected → fixed
status-firefox53: affected → verified
tracking-firefox53: ? → -
No longer depends on: 1313418
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #12)
> [...] There were some changes in look between non-e10s and e10s
> but those are considered wontfix.
> [...] These changes are by design.

So the font size in the button won't be the same, as the font size in the dropdown menu,
and it's considered wontfix, as it's intended by design?
status-firefox52: fixed → verified
Flags: needinfo?(jaws)
Whiteboard: [fixed by patch from bug #1316722]
tracking-firefox52: ? → +
(In reply to Virtual_ManPL [:Virtual] - (ni? me) from comment #13)
> (In reply to Jared Wein [:jaws] (please needinfo? me) from comment #12)
> > [...] There were some changes in look between non-e10s and e10s
> > but those are considered wontfix.
> > [...] These changes are by design.
> 
> So the font size in the button won't be the same, as the font size in the
> dropdown menu,
> and it's considered wontfix, as it's intended by design?

I tested on Windows 10 and we can match the default font of the button to that of the popup if we set `font: -moz-list;` on the menucaptions and menuitems inside of the #ContentSelectDropdown. I will upload a patch to bug 1316404. Thank you for your persistence.
Flags: needinfo?(jaws)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #14)
> (In reply to Virtual_ManPL [:Virtual] - (ni? me) from comment #13)
> > (In reply to Jared Wein [:jaws] (please needinfo? me) from comment #12)
> > > [...] There were some changes in look between non-e10s and e10s
> > > but those are considered wontfix.
> > > [...] These changes are by design.
> > 
> > So the font size in the button won't be the same, as the font size in the
> > dropdown menu,
> > and it's considered wontfix, as it's intended by design?
> 
> I tested on Windows 10 and we can match the default font of the button to
> that of the popup if we set `font: -moz-list;` on the menucaptions and
> menuitems inside of the #ContentSelectDropdown. I will upload a patch to bug
> 1316404. Thank you for your persistence.

Thank you very much for reconsidering and creating the patch and ! \o/
Depends on: 1316404
Whiteboard: [fixed by patch from bug #1316722] → [fixed by patches from bug #1316722 and bug #1316404]
Keywords: nightly-community
Target Milestone: --- → mozilla53
QA Contact: Virtual
You need to log in before you can comment on or make changes to this bug.