Closed Bug 1321866 Opened 3 years ago Closed 3 years ago

Wrong size of Flash plugin when open many tabs

Categories

(Core :: Plug-ins, defect)

52 Branch
x86
Windows 10
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox51 --- unaffected
firefox52 --- affected
firefox53 --- affected

People

(Reporter: alice0775, Unassigned)

References

()

Details

(Whiteboard: STR in comment #0 (intermittent))

Attachments

(2 files)

Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/f65ad27efe839ce9df0283840a1a40b4bbc9ead0
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0 ID:20161202030204

Wrong size of Flash plugin when open many tabs(5-6tabs, when I encountered in real use-case).

I can reproduce the problem on Aurora52.0a2 and Nightly53.0a1 with the following STR, but not on Firefox51.0a6.

Reproducible: often

Steps to reproduce(An example for ensuring that the problem is reproduced):
1. Open https://bug1312242.bmoattachments.org/attachment.cgi?id=8803677 (URL is not restricted this).

2. After tab-throbber stops spinning, Middle button click on "Reload Button" so that the tab will be duplicated. Or open page which is containing Flash Plugin.
   --- observe size og Flash Plugin

3. In problem not happen, repeat step2 until 5-15 times.
4. If the problem not occur, close tabs and repeat from start.
Typo
s/3. In problem not happen/3. If problem not happen/
Is this an issue with async drawing? nightly/aurora have that preffed on but beta/release have it off.
Flags: needinfo?(alice0775)
Setting dom.ipc.plugins.asyncdrawing.enabled = false seems to fix the problem
Blocks: 1229961
Flags: needinfo?(alice0775)
Whiteboard: STR in comment #0 (intermittent)
I've been debugging this in layout and in the plugin instance code. The STR here is actually simpler than using middle click to open new tabs, you can trigger the size issue after a refresh of the page. I can reproduce once every three or four refreshes.

AFAICT, layout has the proper size, plugin instance code has the proper size, and the plugin which renders using async RecvShowDirectBitmap, has the proper size. The buffer we get back from plugin code is also correct. But for some reason when we go to paint the actual plugin buffer, we paint it at 0,0 using improper dims.

David, could you take a look at this and see if you can find the cause? This bug impacts flash games on facebook occasionally so I'd really like to get a fix in. (We'd like to ship async drawing in 54 and we're really close.)

'broken' plugin setup logging, which isn't actually broken:

[BCA1CB0] nsPluginFrame::CallSetWindow
[BCA1CB0] nsPluginFrame::FixupWindow 238 216 715 647
[6163190] nsPluginInstanceOwner::UpdateWindowPositionAndClipRect mPluginWindowVisible=0 mPluginDocumentActiveState=1
[BCA1CB0] nsPluginFrame::FixupWindow 238 216 715 647
[6163190] nsPluginInstanceOwner::UpdateWindowPositionAndClipRect mPluginWindowVisible=0 mPluginDocumentActiveState=1
[BCA1CB0] nsPluginFrame::CallSetWindow
[36864B0] PluginInstanceParent::AsyncSetWindow (239, 327, 715, 646) (0, 0, 0, 0)
[BCA1CB0] nsPluginFrame::CallSetWindow
[36864B0] PluginInstanceParent::AsyncSetWindow (239, 327, 715, 646) (0, 0, 0, 0)
[6163190] nsPluginInstanceOwner::UpdateWindowPositionAndClipRect mPluginWindowVisible=1 mPluginDocumentActiveState=1
[BCA1CB0] nsPluginFrame::CallSetWindow
[36864B0] PluginInstanceParent::AsyncSetWindow (239, 327, 715, 646) (0, 0, 715, 646)
[36864B0] buffer: width=715 height=646
[6163190] nsPluginInstanceOwner::UpdateWindowPositionAndClipRect mPluginWindowVisible=1 mPluginDocumentActiveState=1
[36864B0] buffer: width=715 height=646
Flags: needinfo?(dvander)
Blocks: 1314491
Attached file testcase
I think this might be a flash bug. AFAICT we're handing the right information to flash, but for some reason flash paints in a smaller area of the space allocated.
Attached image flashgame1.png
from adobe:

> This issue is fixed in the next release, which is supposed to go live on April 11. 
> 
> The fix is also available in current Beta.
> http://labs.adobe.com/technologies/flashruntimes/flashplayer/
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Flags: needinfo?(dvander)
Verified on Win7 with latest Nightly 55.0a1 20170330030213 and ADP 25.0.0.143 (beta)

My STR's are slightly different but consistently reproduce the issue with release Flash Player.

1) Middle click on Jim's test case under attachments
2) Wait for the page to load in the background.
3) Then click on that tab

- bug; dancer is about 25% of expected size

- in fixed Flash Player; dancer fills allocated space as expected.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.