Closed Bug 1314491 Opened 3 years ago Closed 3 years ago

Kongregate's Flash game doesn't load with Flash protected mode disabled and plugin asyncdrawing enabled

Categories

(Core :: Plug-ins, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: kalviskajaks, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: fixed by bug 1348629)

Attachments

(1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

1) Go to http://www.kongregate.com/games/ConArtists/the-last-stand-dead-zone
2) Log in and make sure game loads fine
3) Turn off Flash protected mode(restart to be sure the change sticks)
4)Open http://www.kongregate.com/games/ConArtists/the-last-stand-dead-zone again


Actual results:

Game does not load. Tried with new profile in both release 49 and nightly 52.


Expected results:

Game should load without problems.
You should report the issue to Adobe.
Ok, I'm able to reproduce the issue in this situation:
1) Flash protected mode disabled
2) plugin asyncdrawing enabled (dom.ipc.plugins.asyncdrawing.enabled=true)

Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=02c69f4f896255189ce2f9f4e0d875e383bcfbd7&tochange=a1bd47d76f71162534090485acc57866dcd55eef

Same issue with FF49 or 52.
Blocks: 1229961
Keywords: regression
Summary: Flash protect mode turned OFF breaks flash game → Kongregate's Flash game doesn't load with Flash protected mode disabled and plugin asyncdrawing enabled
Whiteboard: hold
Async plugin drawing is still nightly only, but I will leave this as affecting 52 in case we decide to uplift.
Jim, any idea how we should proceed?  Is disabling the protected mode something we want to support with async drawing?
Flags: needinfo?(jmathies)
This is async painting related.
Flags: needinfo?(jmathies)
Depends on: 1321866
Whiteboard: hold
http://www.kongregate.com/games/GaiaByte/cosmos-quest
http://www.kongregate.com/games/SoulGame/swords-and-souls
http://www.kongregate.com/games/Ninjakiwi/bloons-td-5
http://www.kongregate.com/games/tensquaregames/lets-hunt (webgl)

^ all play fine with protected mode off

Not having a lot of issues here, although the original game listed in comment 1 is almost impossible to get into to test.
Ok. Just tested and the 4 games you tried indeed work fine. The original one at 
http://www.kongregate.com/games/ConArtists/the-last-stand-dead-zone 
is still broken with protected mode off and dom.ipc.plugins.asyncdrawing.enabled=true

Why do you mean by impossible to get into? If you are seeing a black screen with a spinner and the text "Connecting to Kongregate..." Than you have actually reproduced the bug.
(In reply to kalviskajaks from comment #9)
> Ok. Just tested and the 4 games you tried indeed work fine. The original one
> at 
> http://www.kongregate.com/games/ConArtists/the-last-stand-dead-zone 
> is still broken with protected mode off and
> dom.ipc.plugins.asyncdrawing.enabled=true
> 
> Why do you mean by impossible to get into? If you are seeing a black screen
> with a spinner and the text "Connecting to Kongregate..." Than you have
> actually reproduced the bug.

On this game I get stuck at "Connecting to Kongregate..." with async drawing enabled and disabled though.
Ok, turns out this is is similar to bug 1323403.

Kongregate has a small subset of games that use wmode=direct rendering. These applets normally get windowed mode for this. However through the new async drawing feature these apps get converted over to windowless by flash. There's a quirk with windowed mode plugins such that even if the underlying content is collapsed flash will still display. This is because the child window associated with windowed mode consumes space even if the div or other element container is collapsed.

In Kongragate markup we have:

<div id="game_wrapper" style="height: 0px;">
 <object type="application/x-shockwave-flash" id="deadzonegame" name="deadzonegame" data="http://r.playerio.com/r/dev-the-last-stand-iret8ormbeshajyk6woewg/game/preloader.swf" width="100%" height="100%">
 ..
 </object>
</div>

They set the height on this div to 0, which prevents the flash applet from loading. If I modify that vis inspector the game loading screen shows up.
Karl, I've got another popular flash site here similar to bug 1323403. According to the forums Kongregate has a large number of firefox users on it, so presumably they'll be open to testing and addressing this in their html.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(kdubost)
Component: Plug-ins → Desktop
Product: Core → Tech Evangelism
Version: 49 Branch → Firefox 54
Do they serve the same markup to mac users? Mac has never had windowed mode.

We could apply hacks to this site using the site compatibility addon, if we think this is a limited problem.
(In reply to Benjamin Smedberg [:bsmedberg] from comment #14)
> Do they serve the same markup to mac users? Mac has never had windowed mode.
> 
> We could apply hacks to this site using the site compatibility addon, if we
> think this is a limited problem.

Generally looks about the same. Looking at the markup I see the game_wrapper div with a height of 100%, vs 0px on windows. That migth have changed dynamically though during the game load, which completes on mac.
Taking this bug back to search for a local fix.
Component: Desktop → Plug-ins
Flags: needinfo?(kdubost)
Product: Tech Evangelism → Core
Version: Firefox 54 → Trunk
Depends on: 1348629
No longer depends on: 1348629
The part of this bug tied to async drawing technically is a dupe of bug 1348629. The remainder is general plugin bug 1352395.

The bit about Flash games not working with protected mode off needs investigating still. I tested against non-stage 3d games on kongragate and experienced no issues.
Depends on: 1348629
(In reply to Jim Mathies [:jimm] from comment #19)
> The part of this bug tied to async drawing technically is a dupe of bug
> 1348629. The remainder is general plugin bug 1352395.
> 
> The bit about Flash games not working with protected mode off needs
> investigating still. I tested against non-stage 3d games on kongragate and
> experienced no issues.

Just tested with flash protected mode off, async drawing on and off, both 64 and 32 bit builds, the game fails to load. So this doesn't appear to be async drawing related.
(In reply to Jim Mathies [:jimm] from comment #20)
> (In reply to Jim Mathies [:jimm] from comment #19)
> > The part of this bug tied to async drawing technically is a dupe of bug
> > 1348629. The remainder is general plugin bug 1352395.
> > 
> > The bit about Flash games not working with protected mode off needs
> > investigating still. I tested against non-stage 3d games on kongragate and
> > experienced no issues.
> 
> Just tested with flash protected mode off, async drawing on and off, both 64
> and 32 bit builds, the game fails to load. So this doesn't appear to be
> async drawing related.

Filed bug 1353768.
Whiteboard: fixed by bug 1348629
Just tested with the newest beta flash version, and can confirm that the game loads fine now.
(In reply to kalviskajaks from comment #22)
> Just tested with the newest beta flash version, and can confirm that the
> game loads fine now.

Thanks for testing, kalviskajaks! Adobe fixed this bug in Flash (bug 1348629).
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
I am unable to load games from http://www.virteract.com/
Please help!
You need to log in before you can comment on or make changes to this bug.