Fix link to GLES lib on android

RESOLVED DUPLICATE of bug 1325298

Status

()

RESOLVED DUPLICATE of bug 1325298
2 years ago
2 years ago

People

(Reporter: sotaro, Assigned: sotaro)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 obsolete attachments)

(Assignee)

Description

2 years ago
Needs to fix link to GLES lib on android build.
(Assignee)

Updated

2 years ago
Blocks: 1323612, 1311790
(Assignee)

Updated

2 years ago
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Comment 1

2 years ago
Created attachment 8819709 [details] [diff] [review]
patch - Fix link to GLES lib on android
(Assignee)

Comment 2

2 years ago
attachment 8819709 [details] [diff] [review] does not work when the following is not set.

> ac_add_options --with-android-version="18"
(Assignee)

Comment 3

2 years ago
Created attachment 8819733 [details] [diff] [review]
patch - Fix link to GLES lib on android
Attachment #8819709 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Depends on: 1324338
(Assignee)

Comment 4

2 years ago
attachment 8819733 [details] [diff] [review] does static link to GLES lib. Instead it might be better to use dynamic link since we are going to support dynamic ES3 to ES2 fallback.
(Assignee)

Comment 6

2 years ago
Created attachment 8830014 [details] [diff] [review]
patch - Fix link to GLES lib on android

Rebased.
Attachment #8819733 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Attachment #8830014 - Attachment is obsolete: true
(Assignee)

Comment 7

2 years ago
With https://github.com/servo/webrender/pull/791, I confirmed rendering on android device.
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1325298
You need to log in before you can comment on or make changes to this bug.