Closed Bug 1325298 Opened 3 years ago Closed 3 years ago

Remove static link to GL of webrender

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

By bug 1324648, webrender does not use static link to GL. But it is necessary since offscreen_gl_context does static linking. But webrender in gecko does not use offscreen_gl_context.
Blocks: webrender
There seems to be 2 options to do it. [2] seems easier.
[1] Add a feature to remove offscreen_gl_context from webrender
[2] Add a feature to use dynamic link to GL in offscreen_gl_context
      offscreen_gl_context always use static link to GL
Update: emilio has patches to do option 1 (so we don't need to build offscreen_gl_context at all), but he's waiting for custom derives to be in Rust stable before he can merge the patches. Custom derives should be in Rust 1.15.0 which aims to be released on Feb 02 [1].

[1] https://github.com/rust-lang/rust/blob/34a3709f74d7c089927827038a3ebba50b180e0f/RELEASES.md
Duplicate of this bug: 1324326
Blocks: 1349967
New pull request is created to allow webrender to not depend on offscreen_gl_context.
  https://github.com/servo/webrender/pull/1009
The patch expects https://github.com/servo/webrender/pull/1009 and "./mach vendor rust".
Assignee: nobody → sotaro.ikeda.g
Attachment #8850867 - Flags: review?(bugmail)
Comment on attachment 8850867 [details] [diff] [review]
patch - Remove static link to GL of webrender

Review of attachment 8850867 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks! I'll land this once we pull in the webrender with your PR.
Attachment #8850867 - Flags: review?(bugmail) → review+
It would be great that this lands soonish.

My local development machines did not install libGL by defaults (very minimum install for C-C TB patch creation.)
It started to fail to build C-C TB due to ld's complaining -lGL missing and I could not figure out what was going on until
I figured that it was complaining that libgl-dev package was missing (under Debian.)

TIA
Sorry, we need to wait https://github.com/servo/webrender/pull/1009 is merged and webrender is updated in gecko.
(In reply to Sotaro Ikeda [:sotaro] from comment #8)
> Sorry, we need to wait https://github.com/servo/webrender/pull/1009 is
> merged and webrender is updated in gecko.

Thank you, Ikeda san, I will wait.
I put the comment above so that others who got bitten by the issue will realize that it is libGL that is missing.
(Never happened before, and I was quite surprised that the library was not loaded on my minimal linux configuration. I suspect if one installs graphics-intensive application, er like games, libGL may have been installed already.)

TIA
The PR got merged to webrender. I'll try and get the WR update landed and then land this patch as well.
Depends on: 1349692
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/projects/graphics/rev/a5222d76fff2
Remove static link to GL of webrender. r=kats
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.