Run mochitest-browser-screenshots on Windows 10

RESOLVED FIXED

Status

Taskcluster
Task Configuration
RESOLVED FIXED
10 months ago
4 months ago

People

(Reporter: MattN, Unassigned)

Tracking

(Depends on: 2 bugs, Blocks: 1 bug)

Details

(URL)

(Reporter)

Description

10 months ago
We should get screenshot coverage on Windows 10.

I did a try push at https://treeherder.mozilla.org/#/jobs?repo=try&revision=b7a34454c5f6ede0c8cdd17e87bc98f069e547d2&filter-tier=1&filter-tier=2&filter-tier=3&selectedJob=71005661 and it ran fine but all of the screenshots were solid black so this probably depends on getting the Windows 10 VMs ready for Tier 1.
Blocks: 1326419

Comment 1

8 months ago
This is probably a dupe of bug 1343580.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1343580
(Reporter)

Comment 2

8 months ago
This depends on bug 1343580 to fix the black screenshots but we'll still need to schedule M(ss) on Win10.
Status: RESOLVED → REOPENED
Depends on: 1343580
Resolution: DUPLICATE → ---
There is a workaround for this now, described in: https://bugzilla.mozilla.org/show_bug.cgi?id=1343580#c6
Depends on: 1359760
these were enabled but seem to have stopped working. last run was here:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=2e7c10a9b86e30691f67855f6c8f98d984508d7c&filter-searchStr=mochitest-browser-screenshots
(Reporter)

Comment 5

5 months ago
I see them running fine now at tier 3 though I didn't confirm that the results are sane.

Johann, any chance you want to go through each image and make sure it's showing the correct thing?

Push for the analysis tools to support windows10: https://github.com/mnoorenberghe/mozscreenshots/commit/d2b206a92dce99bf953b7aadd559c13923761bfc
Flags: needinfo?(jhofmann)
Absolutely!
(Reporter)

Updated

5 months ago
Depends on: 1373178
I think we can close this as resolved, we've filed bugs 1373563, 1373178 and 1373551 to deal with the intermittent comparison issues, but it's definitely running on Windows 10 now and generally doing the correct thing.

Thanks!
Status: REOPENED → RESOLVED
Last Resolved: 8 months ago5 months ago
Depends on: 1373551
Flags: needinfo?(jhofmann)
Resolution: --- → FIXED
Depends on: 1373563
You need to log in before you can comment on or make changes to this bug.