Closed Bug 1332981 Opened 3 years ago Closed 3 years ago

[EME][Fennec] Pref on EME API not only for Nightly build.

Categories

(Firefox for Android :: Audio/Video, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Firefox 54
Tracking Status
relnote-firefox --- -
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: JamesCheng, Assigned: JamesCheng)

References

Details

Attachments

(1 file)

Bug 1267141 will put the clearkey CDM into Fennec.

and Bug 1149374 will start to enable the related EME test cases.

Here is the test result which runs the test case 20 times

https://treeherder.mozilla.org/#/jobs?repo=try&revision=cb87066e573698aaf4045cb8bfe49eb4302c0426
Assignee: nobody → jacheng
Priority: -- → P2
Update treeherder result since the EME test only runs on real device.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=9b4b2899ab104941f203b004f25c7accc6c6be74

It seems "test_eme_request_notifications.html" expects widevine CDM did not install but on Android real device Widevine CDM is available.
Attachment #8829324 - Flags: review?(cpearce)
Blocks: 1333315
Comment on attachment 8829324 [details]
Bug 1332981 - [EME][Fennec] Pref on EME API not only for Nightly build.

https://reviewboard.mozilla.org/r/106424/#review107998
Attachment #8829324 - Flags: review?(cpearce) → review+
Pushed by jacheng@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bcf8aab15bda
[EME][Fennec] Pref on EME API not only for Nightly build. r=cpearce
Comment on attachment 8829324 [details]
Bug 1332981 - [EME][Fennec] Pref on EME API not only for Nightly build.

The uplift request is to fix the error described in Bug 1333315 comment 2. 

Approval Request Comment
[Feature/Bug causing the regression]:Bug 1333315
[User impact if declined]:No
[Is this code covered by automated tests?]:Yes
[Has the fix been verified in Nightly?]:Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]:No
[Is the change risky?]:No
[Why is the change risky/not risky?]:It is only a fix for fixing the try fail described in Bug 1333315.
[String changes made/needed]:No
Attachment #8829324 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/bcf8aab15bda
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Comment on attachment 8829324 [details]
Bug 1332981 - [EME][Fennec] Pref on EME API not only for Nightly build.

enable EME for fennec in aurora53
Attachment #8829324 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Release Note Request (optional, but appreciated)
[Why is this notable]: EME enabled on adnroid
[Affects Firefox for Android]: yes, specific android
[Suggested wording]: EME enabled on Firefox for Android
[Links (documentation, blog post, etc)]: ? the MDN doc?
relnote-firefox: --- → ?
Added to Fx53 Aurora release notes.
Duplicate of this bug: 1329557
According to bug 1340172, EME will only be enabled in nightly. Remove release note flag for 53.
Thanks for catching that Gerry! I removed the relnote.
You need to log in before you can comment on or make changes to this bug.