Closed Bug 1333704 Opened 3 years ago Closed Last year

Update support libraries to 24.2.0 ( at Least )

Categories

(Firefox for Android :: General, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1385464

People

(Reporter: ryang, Unassigned)

References

(Blocks 2 open bugs)

Details

In order to support the updated method for custom tab bottom toolbar, 
we have to upgrade supporting libraries to  at least 24.2.0 .
See Also: → 1267884
HI Joe and Barbara, in order to support the new functionalities of custom tab bottom toolbar,
we have to upgrade supporting libraries to (at least) 24.2.0 .

But Updating libraries takes time, and we are not sure if we have enough dedicated engineering resources on this.

Could you please share your perspective on this ?? Thank you !!
Flags: needinfo?(jcheng)
Flags: needinfo?(bbermes)
Note that this is blocked by bug 1259098: We first need to build with the 24 SDK before we can use a 24.x support library. They introduced new compilers with 24 so this is more work than similar tasks in the past - it might be worth to switch to full gradle builds first - that makes it easier. But this also is a bigger task.

My two cents: The bottom toolbar API has been introduced pretty late to custom tabs. I have seen no app using it - expect "Spaces" for which this API was apparently introduced:
https://plus.google.com/+LukeWroblewski/posts/b1GVyXMd8MK?sfc=false
I think it's absolutely feasible to ship an MVP that doesn't support bottom toolbars. However sooner or later we will have to switch to the new SDK.
Depends on: build-android-n
Oh, and what feature do we actually need from the new support library? I was expecting this to just be a second optional Toolbar in the layout?
Hi Sebastian, 
as I knew and discussed with Julian, the new support library allows users to change and apply custom tab bottom toolbars just exactly the style they made.
however, the old support library  could support only at most  5 icons to display in the custom tab bottom toolbars.

The new support library will provide more flexibilities for users.
But I am not sure if any other new features in custom tab which might use the updated support library will be needed and planned in the long term ...



Hi Julian, 
Can you please help elaborate the main differences of custom tab bottom toolbars which suggests us to upgrade the new android support library  if I am not clear enough or any wrong message above ?

Thank you very much!
Flags: needinfo?(walkingice0204)
Sebastian: It is likely more complex than I thought (ouch). Bug 1329146 asks to implement bottom toolbar, then we have to upgrade support library if would like to use property such as `CustomTabsIntent.EXTRA_REMOTEVIEWS_VIEW_IDS`. This is the initial reason to upgrade support-library. Yes as you said soon or later we need to switch to new version.
Flags: needinfo?(walkingice0204)
I guess, if critical, we could import some constants like EXTRA_REMOTEVIEWS_VIEW_IDS (and maybe even some code if needed) into mozilla-central?
Priority: -- → P2
I suggest we really only do the minimal work (MVP!) for custom tabs to get this out, validate if/how it's being used. I don't want to block on any other things. So if we can confirm that we only need the new support library for the bottom toolbar, I'd say, let's ship it without that specific toolbar and without upgrading the library.

Joe?
Flags: needinfo?(bbermes)
agree. let's ship the MVP without bottom toolbar customizations and then we will iterate
Flags: needinfo?(jcheng)
Blocks: 1408691
If we go to the trouble of upgrading, we might as well use a more recent version and so far, the main difficulty seems to be problems caused by some AsyncTaskLoader changes introduced in 24.0.0, so not upgrading all the way to 26.0.0 (at least) wouldn't help, either.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1385464
You need to log in before you can comment on or make changes to this bug.