Add UA override for directTV

RESOLVED FIXED in Firefox 51

Status

()

defect
RESOLVED FIXED
3 years ago
8 months ago

People

(Reporter: miketaylr, Assigned: miketaylr)

Tracking

Trunk
Firefox 54
Points:
---

Firefox Tracking Flags

(firefox51 verified, firefox52 verified, firefox-esr52 fixed, firefox53 verified, firefox54 verified)

Details

Attachments

(1 attachment)

Pretending to be Android fixes both issues reported in Bug 1338128. Let's ship an override then try to get DirecTV to upgrade their version of Sencha Touch.
Comment on attachment 8835654 [details]
Bug 1338260. Add Fennec-only UA override for directv.com.

https://reviewboard.mozilla.org/r/111328/#review112558

awesome, thanks!
Attachment #8835654 - Flags: review?(mconnor) → review+
Thanks! I'm gonna land this w/o a try run because there's no real tests around it (and I've built and tested the patch locally to confirm it like, works and doesn't blow up).
Pushed by mitaylor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2ce5a893da4f
Add Fennec-only UA override for directv.com. r=mconnor
We'll want to get this uplifted all the way to release for now. I'll work with relman to figure out how we can get a build with it.
Product: Web Compatibility → Firefox for Android
Version: unspecified → Trunk
Comment on attachment 8835654 [details]
Bug 1338260. Add Fennec-only UA override for directv.com.

Approval Request Comment
[Feature/Bug causing the regression]: Make directv work
[User impact if declined]: directv.com doesn't work properly (partner issue)
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: See bug 1338128
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Modifies existing table adding exception for 1 sight.
[String changes made/needed]:


As far as mozilla-release goes, we're going to need to do a one off . release for this partner. I'll contact relman separately.
Attachment #8835654 - Flags: approval-mozilla-release?
Attachment #8835654 - Flags: approval-mozilla-beta?
Attachment #8835654 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/2ce5a893da4f
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Comment on attachment 8835654 [details]
Bug 1338260. Add Fennec-only UA override for directv.com.

UA override for fennec, for aurora and beta
Attachment #8835654 - Flags: approval-mozilla-beta?
Attachment #8835654 - Flags: approval-mozilla-beta+
Attachment #8835654 - Flags: approval-mozilla-aurora?
Attachment #8835654 - Flags: approval-mozilla-aurora+
Comment on attachment 8835654 [details]
Bug 1338260. Add Fennec-only UA override for directv.com.

UA override for fennec. Release51+.
Attachment #8835654 - Flags: approval-mozilla-release? → approval-mozilla-release+
We're building 51.0.4 especially for this but won't be uploading it to Google Play. 
Do we know that this doesn't break things for other devices or sites?
What testing can we do here (especially to make sure it is OK on beta 52)?
Here's a manual test plan:

-1) verify that the UA override has been synced to the CDN:
https://dynamicua.cdn.mozilla.net/0/%7Baa3c5121-dab2-40e2-81ca-7ea25febc110%7D
0) open browser, clear app data (this forces the browser to load the override list from the APK, otherwise it could be up to a 
week before it calls home for new overrides)


1) navigate to directv.com
2) scroll down

PASS if you can scroll to the bottom
FAIL if it jumps back up automatically

3) rotate device to landscape orientation

PASS if you see the whole viewport, in landscape orientation, and can scroll to the bottom
FAIL if you see partially painted viewport, and cannot scroll to the bottom

4) go to about:config?filter=general.useragent.updates.enabled, set to false
5) try to scroll, note that you cannot.
6) rotate device to landscape orientation, note "cut off" paint bug and inability to scroll
7) go to about:config?filter=general.useragent.updates.enabled, set to true
8) reload directv.com
9) re-test steps 1 through 3

As for testing if it doesn't break other sites, I guess you can just make sure google.com loads, or something, before and after toggling the pref. 

The patch only comes into play for the directv.com TLD and subdomains.
Devices:
 - Nexus 9 (Android 7.1.1)
 - Nexus 6P (Android 7.0)
 - Honor 8 (Android 6.0)

Hello,

 I've verified this issue, it seems that other sites are not affected by this setting (Google, Yahoo, Bing, Amazon), they load and work as intended.
 With the value set to true directtv.com works without any issue. If set to false the page loads and behaves as described, no scrolling is possible and the page is "cut off".
See Also: → 1464106
See Also: → 1505722
You need to log in before you can comment on or make changes to this bug.