Closed Bug 1340276 Opened 3 years ago Closed 3 years ago

Force wmode=direct for certain Flash applets

Categories

(Core :: Plug-ins, defect)

54 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox54 --- fixed

People

(Reporter: jimm, Assigned: jimm)

References

Details

Attachments

(1 file, 1 obsolete file)

For applets that:

1) do not specify a wmode value
2) specify wmode=window

this should be behind a new pref, enabled by default in dev channels.
Assignee: nobody → jmathies
Attached patch patch (obsolete) — Splinter Review
Comment on attachment 8838256 [details] [diff] [review]
patch

Review of attachment 8838256 [details] [diff] [review]:
-----------------------------------------------------------------

r=me w/ comment either addressed or refuted ;-)

::: dom/plugins/ipc/PluginModuleParent.cpp
@@ +2730,5 @@
> +    NS_NAMED_LITERAL_CSTRING(directAttributeValue, "direct");
> +    auto wmodeAttributeIndex =
> +        names.IndexOf(wmodeAttributeName, 0, comparator);
> +    if (wmodeAttributeIndex != names.NoIndex) {
> +        if (values[wmodeAttributeIndex].EqualsLiteral("window")) {

Do we need to care about case insensitivity for this comparison?
Attachment #8838256 - Flags: review?(aklotz) → review+
(In reply to Aaron Klotz [:aklotz] from comment #3)
> Comment on attachment 8838256 [details] [diff] [review]
> patch
> 
> Review of attachment 8838256 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> r=me w/ comment either addressed or refuted ;-)
> 
> ::: dom/plugins/ipc/PluginModuleParent.cpp
> @@ +2730,5 @@
> > +    NS_NAMED_LITERAL_CSTRING(directAttributeValue, "direct");
> > +    auto wmodeAttributeIndex =
> > +        names.IndexOf(wmodeAttributeName, 0, comparator);
> > +    if (wmodeAttributeIndex != names.NoIndex) {
> > +        if (values[wmodeAttributeIndex].EqualsLiteral("window")) {
> 
> Do we need to care about case insensitivity for this comparison?

There's another check just above this one that does the same case insensitive search, so my guess is yes we want that. These attributes are pulled from content so I'm going to guess that ignoring case is a good idea.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9f91a792c4f9
Force wmode=direct for certain Flash objects. r=aklotz
Keywords: checkin-needed
Blocks: 1336517
No longer depends on: 1336517
https://hg.mozilla.org/mozilla-central/rev/9f91a792c4f9 - landed 28 hours ago
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Duplicate of this bug: 1311985
Blocks: 1359450
You need to log in before you can comment on or make changes to this bug.