Closed Bug 13406 Opened 25 years ago Closed 25 years ago

[BLOCK] can't differentiate btw leaving frame & entering child with [mouse/drag]Exit events

Categories

(Core :: XUL, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: mikepinkerton, Assigned: joki)

References

Details

(Whiteboard: [PDT+])

After all that rigamarole last night with the target of synthetic events not
being set properly, I've discovered another problem that I need for d&d with
dragExit's and hyatt needs for mouseExit's in xp-menus.

The gist of the problem is that when I get an exit event, I need to know where
I'm exiting to. Say I have a drag and my mouse is over an empty area of the
toolbar. If the mouse leaves the toolbar, I get a drag exit and the toolbar is
the target (since I patched it in rdf per my comments from last night). The
problem arises because I also get a dragExit event when the mouse enters one of
the titledButtons on the toolbar! Since the target is still the toolbar, I have
no way to differentiate between the two situations. In the first case, I want to
disable drop feedback on this toolbar because the mouse is no longer inside of
it. In the second case, I want to ignore this event since I"m now inside a child
and want to keep the drop feedback the way it was.

Hyatt needs this for xp-menus with mouseExit. He needs to be able to
differentiate between a mouse exit into another menu and a mouse exit that causes
the menus to go away.

Do you know of any way to get this info? It seems that exit events are pretty
close to useless on any kind of containers w/out a way to differentiate between
the two situations.
Blocks: 9657, 11828
Severity: normal → blocker
Summary: can't differentiate between leaving frame and entering child with [mouse/drag]Exit events → [BLOCK] can't differentiate between leaving frame and entering child with [mouse/drag]Exit events
marking blocker and adding dependencies.
Blocks: 11346
Summary: [BLOCK] can't differentiate between leaving frame and entering child with [mouse/drag]Exit events → [BLOCK] can't differentiate btw leaving frame & entering child with [mouse/drag]Exit events
Target Milestone: M14
set to M14 (post-beta) since drag and drop is not in for the beta
Whiteboard: [PDT+]
Putting on [PDT]+ radar.
Is this still needed for XPMenus?
Blocks: 16950
Blocks: 17432
Blocks: 17907
Status: NEW → RESOLVED
Closed: 25 years ago
Resolution: --- → FIXED
relatedNode is now hooked up for mouse/over exit events.  I believe it should be
hooked up for the drag events too but didn't know how to test that.
joki, what is the method to get this relatedNode? I can't find the method on
nsIDOMEvent.
Its on nsIDOMMouseEvent, same place I had to move all the coordinate stuff to.
QA Contact: phillip → claudius
Resetting QA Contact.
Status: RESOLVED → VERIFIED
low-level fix, marking VERIFIED.
No longer blocks: 17432
No longer blocks: 17907
No longer blocks: 11346
You need to log in before you can comment on or make changes to this bug.