Closed Bug 134435 Opened 21 years ago Closed 14 years ago

RFE: Advanced Address Book Search: ability to search address book's "Other" flap, custom and notes

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 184483

People

(Reporter: hakon_, Unassigned)

References

Details

The "Advanced Address Book Search" should offer the ability to search for a
string  located anywhere in the "Other" flap. This doesn't seem practically
feasible currently.
Status: UNCONFIRMED → NEW
Ever confirmed: true
mass re-assign.
Assignee: racham → sspitzer
This is a pretty serious bug.  The fields available in the address book are
limited and a lot of info gets lumped into the Other field.  If you can't search
the OTHER field, Address Book isn't that much better than a piece of paper.

(Also The OTHER field displays without line breaks in the Card view)
I would use a Custom field to categorize my contacts. For example, I would enter
"Christmas" or "Prospects." Then I could search for everyone that I want to send
a Christmas card to or for everyone I need to contact for potential business.

In the notes field I would add something about the contact like "this lady
rescues animals." Then next time I need help for an animal I could search for
all contacts that have "animals." This is important because I might not remember
their name or organization name.
a. This bug is also in the Windows version of Mozilla.

b. Really, I'd like to see the ability to search on _every_ field in the address
book: Zip code, Notes, Custom 1, 2, 3, 4, Web address, etc.

c. From Comment #2:
> (Also The OTHER field displays without line breaks in the Card view)

I've filed this as a seprate report, under bug 214822.
Product: Browser → Seamonkey
hardware -> all
OS -> all
add custom and note to summary
Depends on: 136309, 184483
OS: Linux → All
Hardware: PC → All
Summary: RFE: ability to search for string in the address book's "Other" flap → RFE: ability to search address book's "Other" flap, custom and notes
Assignee: sspitzer → mail
The right solution here might just be to include an "Any Field" (as well as
maybe an "Any Custom", see bug 184483) item in the drop-down. The risk from a UI
perspective is including too many fields and thus making the search unweildy.
QA Contact: nbaca → addressbook
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 184483
Summary: RFE: ability to search address book's "Other" flap, custom and notes → RFE: Advanced Address Book Search: ability to search address book's "Other" flap, custom and notes
No longer depends on: 184483
You need to log in before you can comment on or make changes to this bug.