Box.com filelink uploads broken

RESOLVED FIXED in Thunderbird 55.0

Status

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mkmelin, Assigned: mkmelin)

Tracking

({regression})

unspecified
Thunderbird 55.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird_esr52 fixed, thunderbird53 fixed, thunderbird54 fixed, thunderbird55 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Posted patch bugXXX_box-com-broken.patch (obsolete) — Splinter Review
Box.com filelink uploads broken.

TypeError: Not enough arguments to File.

(As you noted in bug 1348663).
Attachment #8848924 - Flags: review?(jorgk)
Comment on attachment 8848924 [details] [diff] [review]
bugXXX_box-com-broken.patch

Review of attachment 8848924 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, I didn't test, did you?

::: mail/components/cloudfile/nsBox.js
@@ +784,1 @@
>                   .createInstance(Ci.nsIDOMFormData);

Nit: this should shift to spaces to the right, right?
Attachment #8848924 - Flags: review?(jorgk) → review+
Yes worked ok with the patch. I shifted the spaces two more to the right now (dunno if there's a style rule for this case).
Attachment #8848924 - Attachment is obsolete: true
Attachment #8848925 - Flags: review+
Blocks: 1303518
Keywords: regression
Comment on attachment 8848925 [details] [diff] [review]
bug1348691_box-com-broken.patch

[Approval Request Comment]
Regression caused by (bug #): bug 1303518
User impact if declined: Can't upload file to cloud storage.
Testing completed (on c-c, etc.): Manual.
Risk to taking this patch (and alternatives if risky):
Can't get worse ;-)
Attachment #8848925 - Flags: approval-comm-esr52?
Attachment #8848925 - Flags: approval-comm-beta+
Attachment #8848925 - Flags: approval-comm-aurora+
https://hg.mozilla.org/comm-central/rev/998197376939565dbbc14409cc330c4b65ade947
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 55.0
Attachment #8848925 - Flags: approval-comm-esr52? → approval-comm-esr52+
Wrong uplift for TB 53 and TB 52. The async part .then() will only work from mozilla54 since
  Bug 1338138 - Make call to createFromNsIFile() async (port bug 1335536 to mail). r=mkmelin 
only landed on TB 54/mozilla54.

Same issue as in bug 1348663 comment #7.

Too late to fix TB 53 beta, but I'll fix TB 52 here and now.

TB 52 ESR:
https://hg.mozilla.org/releases/comm-esr52/rev/18a456796cf1c6ce4bb2f207a08cb66e40111222 (backout)
https://hg.mozilla.org/releases/comm-esr52/rev/b8034a160796746409a3a2a002243f3531e21198 (correct patch)
Thanks for fixing this in 52 ESR
You need to log in before you can comment on or make changes to this bug.