Closed Bug 1361294 Opened 3 years ago Closed 3 years ago

show "import from other browser" link on Activity Stream

Categories

(Firefox :: New Tab Page, enhancement, P2)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 56

People

(Reporter: gasolin, Unassigned)

References

(Depends on 1 open bug)

Details

Based on UX spec bug 1360109, we need

* Show "import from other browser" link at bottom of the new tab page
* Send message to trigger the manual import procedure
Depends on: 1361286
Priority: -- → P1
Whiteboard: [photon-onboarding]
Flags: qe-verify+
QA Contact: jwilliams
Summary: show "import from other browser" link at bottom of the new tab page → show "import from other browser" link at the new tab page
Target Milestone: --- → Firefox 56
Assignee: nobody → gasolin
Status: NEW → ASSIGNED
In reviewing the PR to also implement this in Activity Stream, I noticed that the strings used for this seem a bit odd for potential localization issues as well as usability (at least from my first impression).

https://mozilla.invisionapp.com/share/Y3BGDY88H#/screens/234912781

That spec shows the string:

"No problem. We can start you off with a few popular sites instead. You can always [import your information] later."

With the [import your information] being a link that when clicked triggers the import dialog. That seems a bit confusing as the action is actually to import things now even though the whole sentence seems to imply later -- although technically if one only looked at the linked text, it would seem to imply that it would do the import now.

I would think this is tricky to localize as it's a partial fragment within a larger sentence.

In the PR, I suggested having two separate sentences to translate and linkify:

"No problem. We can start you off with a few popular sites instead."
"Import your information when you're ready."

https://github.com/mozilla/activity-stream/pull/2650

bryantmao, is there flexibility on that messaging?

flod, will it be difficult to localize the strings as currently specced?
Flags: needinfo?(francesco.lodolo)
Flags: needinfo?(bmao)
(In reply to Ed Lee :Mardak from comment #1)
> flod, will it be difficult to localize the strings as currently specced?

No, I don't see any issue with localizability, as long as we explain that the text is used in a link to open the import dialog.
Flags: needinfo?(francesco.lodolo)
Priority: P1 → P3
Rebased and added manual import wizard link PR. 
https://github.com/mozilla/activity-stream/pull/2650

Due to priority shift I have been asked to help on other photon things. So I will not continue to finish these patch.
Assignee: gasolin → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(bmao)
Depends on: 1361287
Blocks: 1268708
Component: New Tab Page → Activity Streams: Newtab
Summary: show "import from other browser" link at the new tab page → show "import from other browser" link on Activity Stream
Priority: P3 → P2
Currently this bug is intended to be fixed after bug 1361287, if we want to re-purpose this bug without automigration support, 
we need new UX spec for that.
Flags: needinfo?(pdolanjski)
also ni verdi
Flags: needinfo?(mverdi)
Bryant is corp with Activity-Stream team to work on the UX spec. We'll get the spec before ALL HANDS.
Blocks: 1374560
Flags: needinfo?(pdolanjski)
Flags: needinfo?(mverdi)
Target Milestone: Firefox 56 → Firefox 57
No longer blocks: 1361283
Per discussion with Tim, Kate, Mardak and Ursula, it is confirmed that this feature will be implemented by activity stream team in their code base.

remove whiteboard tag for onbaording team.

activity stream team tracks this bug in github https://github.com/mozilla/activity-stream/issues/2787 


hi Kate,

how would you like to handle this bug? please feel free to Duplicate or close it.

thank you very much
Flags: needinfo?(khudson)
Whiteboard: [photon-onboarding]
No longer blocks: 1268708
Fixed with https://github.com/mozilla/activity-stream/pull/2858 to be uplifted via bug 1383917.
Blocks: 1383917
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(khudson)
Resolution: --- → FIXED
I can see "import from other browser" show link on Activity Stream on new tab in latest nightly 56.0a1 on Ubuntu 16.04, 64 bit!


Build ID 	20170725144053
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170726]
I have seen this feature "import from other browser" show link on Activity Stream on new tab has been implemented on Windows 8.1 (64 bit).

Build ID : 20170726030207
User Agent : Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

[bugday-20170726]
As per Comment 9 and Comment 10, I am marking this bug as verified fixed.
Status: RESOLVED → VERIFIED
while use keyboard tab to browse through AS page, the buttons inside of the import message seems not get hovered, we may need add some visual for that. 

Yura do you have any suggestion?
Flags: needinfo?(yzenevich)
Depends on: 1385235
(In reply to Fred Lin [:gasolin] from comment #12)
> while use keyboard tab to browse through AS page, the buttons inside of the
> import message seems not get hovered, we may need add some visual for that. 
> 
> Yura do you have any suggestion?

Yeah I mentioned it here already: https://github.com/mozilla/activity-stream/issues/2874
I think those buttons should have the same hover/focus styling similar to activity stream cards.
Flags: needinfo?(yzenevich)
Target Milestone: Firefox 57 → Firefox 56
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.