Closed Bug 1363728 Opened 6 years ago Closed 5 years ago

Should remove the search field's focus after clicking outside of the search field

Categories

(Firefox :: Preferences, enhancement, P1)

enhancement

Tracking

()

RESOLVED WONTFIX
Firefox 56

People

(Reporter: evanxd, Assigned: evanxd)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Should remove the search field's focus after clicking outside of the search field. Check the "Click outside of the search field" in the spec[1].

[1]: https://mozilla.invisionapp.com/share/ZDAGPK3AF#/screens/218928188_5-0_Search_Field
Assignee: nobody → evan
Status: NEW → ASSIGNED
Priority: P2 → P1
Attachment #8866496 - Flags: review?(jaws)
Comment on attachment 8866496 [details]
Bug 1363728 - Remove the search input focus after clicking outside of the search input

https://reviewboard.mozilla.org/r/138134/#review141636

::: browser/components/preferences/in-content/preferences.js:74
(Diff revision 2)
> +  document.documentElement.addEventListener("mousedown", function() {
> +    this.focus();

This will break normal focus behavior for the whole document. For example, when a dropdown is clicked on and then the page is clicked on, the dropdown should still have focus styling.

I think this bug should be changed to WONTFIX as I have not seen a strong argument for changing it.
Attachment #8866496 - Flags: review?(jaws) → review-
Discussed with Jared for this issue. We found out the root cause is that gecko don't file "blur" event to the search textbox XUL element after clicking outside of it. I'll file a follow bug to address that.

> I think this bug should be changed to WONTFIX as I have not seen a strong
> argument for changing it.

At the meantime, I agree, WONTFIX it.
See Also: → 1364197
Hi Tina,

Previously, we discussed this last week. So how about updating the spec for this. We've filed a follow up bug (Bug 1364197) to address that.

Thanks.
Flags: needinfo?(thsieh)
This bug should be fixed in the gecko module (Bug 1364197).
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Flags: needinfo?(thsieh)
Whiteboard: [photon-preference]
Duplicate of this bug: 1473116
Duplicate of this bug: 1467843
Duplicate of this bug: 1449208
Duplicate of this bug: 1392041
Duplicate of this bug: 1366503
You need to log in before you can comment on or make changes to this bug.