Closed Bug 1334189 Opened 3 years ago Closed 2 years ago

Get mochitests running on linux64-qr builds in automation

Categories

(Core :: Graphics: WebRender, defect, P3)

54 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox56 --- unaffected
firefox57 --- unaffected
firefox59 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 1 open bug)

Details

(Whiteboard: [wr-reserve] [gfx-noted])

Attachments

(1 file)

The biggest problem right now is that mochitests run on Ubuntu 12.04 machines, which have this:
  OpenGL version new 2.1 Mesa 9.2.1

which causes this:
  Failed to compile shader: "debug_font"
  0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, and 1.00 ES
  thread '<unnamed>' panicked at '-- Shader compile failed - exiting --', /home/worker/workspace/build/src/gfx/webrender/src/device.rs:884
  note: Run with `RUST_BACKTRACE=1` for a backtrace.
  Redirecting call to abort() to mozalloc_abort

The reftests run on Ubuntu 16.04 which uses OpenGL version new 3.3 (Core Profile) Mesa 11.2.0 and doesn't have this problem. Therefore we either need to make webrender compatible with the older GLSL or we need to get mochitests running on 16.04 in automation (which is bug 1290183).
:jrmuizel says that we don't plan on having webrender support OpenGL 2.1 in the short term, so if we want mochitest coverage for webrender we need to get those tests migrated to ubuntu 16.04 images.
what specific mochitests do you need on 16.04?  all of them, or mochitest-webgl?
Eventually we'll want all of them for full test coverage with webrender. The graphics-related ones like webgl are probably better to get first.
with the exception of one test, we would be ready for mochitest-gl as per the patch in bug 1319801.

Possibly we can prioritize getting the blocking bugs filed so then others can work on fixing them in the coming months and when ready we can do the final push to get tests all running on 16.04.
Note that even after moving to 16.04 there are failures with webrender which we will need to investigate. See https://treeherder.mozilla.org/#/jobs?repo=try&revision=b2a523da6f5538eb84222aeaa9b557166d84233a for examples.
oh, most of those are the same as non webrender- I would be at least 80% of those failures need to be resolved already.
Depends on: 1365377
Depends on: 1365385
With bug 1319782 fixed, we should be able to run mochitest-plain on linux64-qr with WR enabled.
Not a lot of failures, that's good to see. I might spend some more time on this after I have APZ enabled and cleaned up.
Here's a new one, now that APZ is enabled by default:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=2f61202ad0246f2fe281b044f92d0ab8c2eb501d

More failures than last time, in the e10s variants. Not really surprising.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=dfb5e81fbd7c56b1d6fe92339f7f59b0bee392b0

Looking better than before, I think. For the non-e10s mochitests:
- dom/events/test/test_bug1013412.html is a buggy test. I have a local patch which replaces the synthesizeWheel with sendWheelAndPaint which fixes it
- dom/security/test/mixedcontentblocker/test_frameNavigation.html I'm not able to reproduce locally. Needs investigation
- editor/libeditor/tests/test_bug586662.html is a pre-existing intermittent, tracked in bug 1376382
- layout/base/tests/test_transformed_scrolling_repaints.html - needs to disabled for WR
- layout/base/tests/test_transformed_scrolling_repaints_3.html - ditto
- layout/style/test/test_animations_omta.html - probably needs fixing, not sure what's wrong here
Priority: P3 → P2
Whiteboard: [gfx-noted] → [wr-mvp] [gfx-noted]
Priority: P2 → P3
Whiteboard: [wr-mvp] [gfx-noted] → [wr-reserve] [gfx-noted]
We've been using this bug as specific to linux, so let's make that explicit. I'll file new bugs for the other platforms.
Blocks: webrender-mochitests
No longer blocks: stage-wr-tests
Summary: Get mochitests running on QR builds in automation → Get mochitests running on linux64-qr builds in automation
Latest try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=0ec651f34b07956fe2506c5b38799836e16a309a

There's actually not too many failures I'm going to see if I can mark them skip-if=webrender and turn this on. We can track the skipped mochitests as sub-bugs under the meta bug 1424752.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=954977d0f310b82b9d2376c44edec44978e9becf

Still a lot of low-frequency intermittents. I'm wondering if we should try to make webrender's behaviour more deterministic first. I bet a lot of these failures are due to the invalidation notification issues we have.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=d71ac48f739358d28d16883fbd5193602f9c0763

Also a lot of the failures seem to already have intermittent bugs on file, but they seem to happen more frequently with WR enabled. Probably timing differences tickling existing race conditions.
Hopefully last one: https://treeherder.mozilla.org/#/jobs?repo=try&revision=b74db05d2b94443ffd9faeef98d187e6386e4a4c

I'll try to get this landed and then if there's still frequent-ish intermittents showing up after landing we can continue disabling tests until it stabilizes.
The M-e10s-13 debug failure seems to just jump from the disabled test to the one next to it so I'll probably need to get to the bottom of that first.
Assignee: nobody → bugmail
Comment on attachment 8936793 [details]
Bug 1334189 - Enable mochitest-plain for linux64-qr.

https://reviewboard.mozilla.org/r/207504/#review213934
Attachment #8936793 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/53880e97808d
Enable mochitest-plain for linux64-qr. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/53880e97808d
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.