Closed Bug 1372528 Opened 2 years ago Closed 2 years ago

Change search settings redirects to General section of about:preferences

Categories

(Firefox :: Preferences, defect, P1)

55 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 + verified
firefox56 --- verified

People

(Reporter: petruta.rasa, Assigned: rickychien)

References

Details

(Keywords: regression, Whiteboard: [photon-preference])

Attachments

(3 files)

[Note]:
- This doesn't reproduce on Firefox 54 beta 13 with one-off searches from awesome bar force enabled 

[Affected versions]:
- Firefox 55 beta 1

[Affected platforms]:
- Win 10 64-bit
- Mac OS X 10.12.5
- Ubuntu 14.04 64-bit

[Steps to reproduce]:
1. Click the magnifying glass from Search toolbar and select "Change Search Settings" button
OR 
Select "Change search settings" gear icon from url dropdown

[Expected result]:
- about:preferences#search opens

[Actual result]:
- about:preferences#general-search opens with focus on General section from about:preferences

[Regression range]:
- This could be caused by 1335907 (about:preferences was reorganized) which didn't ride the 55 train. I will continue the investigation.

[Additional notes]:
- The issue also occurs for other about:preferences redirects. Eg: Go to about:telemetry and click the "Change" links - about:preferences#privacy-reports is shown in the url while General section is focused.
about:preferences#search should go to the right place in both cases, if preferences have been reorganized, it will be in #general, otherwise it will be about:preferences#search.

What's the bug? Are we not going to the screen that allows to disable search suggestions in the Location Bar in both cases?
Firefox 55 beta doesn't recognize the new urls from Preferences reorg so it will show the main section.

Change Search Settings should redirect to about:preferences#search.
Hey Tim, can you or someone else working on preference look in to this? This is tracking 55.
Flags: needinfo?(timdream)
Let's take this to triage today. Thanks.
Flags: needinfo?(timdream)
Priority: -- → P1
Whiteboard: [photon-preference][triage]
regression in beta from the pref reorg, tracking for 55.
will be fixed in 55 beta.
Whiteboard: [photon-preference][triage] → [photon-preference]
Assignee: nobody → rchien
Status: NEW → ASSIGNED
Flags: qe-verify+
Note that his issue can be reproduced easily in Nightly by setting `browser.preferences.useOldOrganization = true` in about:config.
Duplicate of this bug: 1373834
Jaws, can you take a look and help review the patch? thanks
Flags: needinfo?(jaws)
Comment on attachment 8877927 [details]
Bug 1372528 - Change search settings redirects to General section of about:preferences

https://reviewboard.mozilla.org/r/149332/#review155418

::: browser/components/search/content/search.xml:1476
(Diff revision 2)
>  
>        <method name="showSettings">
>          <body><![CDATA[
>            BrowserUITelemetry.countSearchSettingsEvent(this.telemetryOrigin);
> +
> +          if (Preferences.get("browser.preferences.useOldOrganization")) {

I don't see the Preferences object referenced in this file already. Have you tested this to confirm that it will work?
Attachment #8877927 - Flags: review?(jaws) → review+
Jared, this is triggered by browser's url search bar not in Preferences itself.

I've tested and confirmed that clicking "Change Search Settings" button can redirect to the right preferences sub-panel whatever opt-in or opt-out the `browser.preferences.useOldOrganization`.
Flags: needinfo?(jaws)
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f4a46277935b
Change search settings redirects to General section of about:preferences r=jaws
https://hg.mozilla.org/mozilla-central/rev/f4a46277935b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Confirmed that this grafts cleanly to Beta. Please request approval when you get a chance.
Flags: needinfo?(rchien)
Comment on attachment 8877927 [details]
Bug 1372528 - Change search settings redirects to General section of about:preferences

Approval Request Comment
[Feature/Bug causing the regression]: unknown
[User impact if declined]: Search toolbar's "Change Search Settings" doesn't work
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: see STR in description
[List of other uplifts needed for the feature/fix]: no
[Is the change risky?]: no
[Why is the change risky/not risky?]: fixed button behavior will not crash entire Firefox.
[String changes made/needed]: none
Flags: needinfo?(rchien)
Attachment #8877927 - Flags: approval-mozilla-beta?
Comment on attachment 8877927 [details]
Bug 1372528 - Change search settings redirects to General section of about:preferences

fix search settings link, beta55+
Attachment #8877927 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Thanks for the quick fix :)
https://hg.mozilla.org/releases/mozilla-beta/rev/a6aa59c61c8d
Flags: needinfo?(ryanvm)
Duplicate of this bug: 1376001
I have reproduced this bug with Nightly 56.0a1 (2017-06-13) on Windows 8, 64-bit.

The bug's fix is now verified on Latest Beta 55.0b6

Build ID 	20170629005143
User Agent 	Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

[bugday-20170628]
Verified as fixed using Firefox 55 beta 6 under Win 10 64 bit, Ubuntu 14.04 32-bit and Mac OS X 10.12 and logged follow-up bug 1378136.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: qe-verify+
QA Contact: hani.yacoub
You need to log in before you can comment on or make changes to this bug.