Closed Bug 1372911 Opened 3 years ago Closed 2 years ago

Single locale builds on Beta Channel don't open

Categories

(Firefox for Android :: General, defect, P1, critical)

55 Branch
ARM
Android
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
fennec + ---
firefox55 --- affected
firefox56 --- affected
firefox57 --- ?
firefox58 --- ?

People

(Reporter: oana.horvath, Unassigned)

References

Details

(Keywords: qablocker)

Device: LG G4 (Android 6.0);
Build: Beta 55.0a1 (2017-06-14);

Steps to reproduce:
1. Go to http://archive.mozilla.org/pub/mobile/candidates/55.0b1-candidates/build2/android-api-15/zh-TW/ and install the build.
2. Open Firefox Beta.

Expected result:
Localized Beta opens.

Actual result:
The app launches and closes repeatedly, closing after a few attempts. Cannot launch the zn-TW localized build.

Notes: Does not repro on Nightly 56 or Firefox 54.
Duplicate of this bug: 1373263
Single locale builds "de" and "fr" are also affected, probably more. "en-US" and "multi" are OK.
Duplicate of this bug: 1374172
Reproducing again on several single-locale builds on Beta 55.0b14 (2017-01-08): cs, da, de, es-ES, fr, etc.
*Not crashing if the language is changed from the multi-locale build's language settings.
Severity: blocker → critical
tracking-fennec: --- → ?
Keywords: qablocker
Priority: -- → P1
QA Contact: oana.horvath
Summary: Single locale build zn-TW on Beta 55 doesn't open → Single locale builds on Beta 55 don't open
See Also: → 1386995
Ioana tested 56 and 57 nightly builds and they don't appear to be affected by this issue, so I guess whatever caused this was fixed in the 56 nightly cycle.
Yikes. I can repro this with the zh-TW build. It repeatedly tries to show the crash reporter, which fails with:

08-03 10:25:24.574  1376  1376 E AndroidRuntime: FATAL EXCEPTION: main
08-03 10:25:24.574  1376  1376 E AndroidRuntime: Process: org.mozilla.firefox_beta.CrashReporter, PID: 1376
08-03 10:25:24.574  1376  1376 E AndroidRuntime: java.lang.RuntimeException: Unable to start activity ComponentInfo{org.mozilla.firefox_beta/org.mozilla.gecko.CrashReporter}: java.lang.IllegalArgumentException: AppCompat does not support the current theme features: { windowActionBar: false, windowActionBarOverlay: false, android:windowIsFloating: false, windowActionModeOverlay: false, windowNoTitle: false }
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2817)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2892)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at android.app.ActivityThread.-wrap11(Unknown Source:0)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1593)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at android.os.Handler.dispatchMessage(Handler.java:105)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at android.os.Looper.loop(Looper.java:164)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at android.app.ActivityThread.main(ActivityThread.java:6541)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at java.lang.reflect.Method.invoke(Native Method)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at com.android.internal.os.Zygote$MethodAndArgsCaller.run(Zygote.java:240)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:767)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: Caused by: java.lang.IllegalArgumentException: AppCompat does not support the current theme features: { windowActionBar: false, windowActionBarOverlay: false, android:windowIsFloating: false, windowActionModeOverlay: false, windowNoTitle: false }
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at android.support.v7.app.AppCompatDelegateImplV7.createSubDecor(Unknown Source:192)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at android.support.v7.app.AppCompatDelegateImplV7.ensureSubDecor(Unknown Source:5)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at android.support.v7.app.AppCompatDelegateImplV7.setContentView(Unknown Source:0)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at android.support.v7.app.AppCompatActivity.setContentView(Unknown Source:4)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at org.mozilla.gecko.CrashReporter.onCreate(CrashReporter.java:128)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at android.app.Activity.performCreate(Activity.java:6982)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1213)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2770)
08-03 10:25:24.574  1376  1376 E AndroidRuntime: 	... 9 more
repro: fennec 55.0b14 te build

download and install http://archive.mozilla.org/pub/mobile/releases/55.0b14/android-api-15/te/

device: lyf flame 3 [ ls-4001 ]
os: android 5.1
Jim can you see if you can figure out what's going wrong here?
Flags: needinfo?(nchen)
tracking-fennec: ? → +
Hi Axel, who's familiar with Fennec single locale repacking? We suspect there was some change to the way we repack our (non-en-US) single locale builds that made them crash on startup (maybe some resource got mangled / left out).
Flags: needinfo?(nchen) → needinfo?(l10n)
Callek maybe.

It'd be good to validate the builds before branch day, as the beta automation is different to the nightly automation.
Flags: needinfo?(l10n)
Flags: needinfo?(bugspam.Callek)
I believe the only difference between beta and nightly android single locale automation is, we have specified in-tree locale revisions for beta, and we use `default` for central. Otherwise we use the same script in TC. There are also branding and mh config/mozconfig differences, but I think that would affect the multilocale build as well.
Pike, snorp, I'll second what :aki said here, I don't see anything of note different between beta and central in terms of l10n repack logic.

https://tools.taskcluster.net/groups/dbkMXklXRGa7FqVgMo3FWg/tasks/IfOq_n3KShu4hhsnPjHMsg/details was a repack for the 55.0b14 release of android. and when comparing that against a recent successful m-c I don't see anything that strikes me as bad.

If there is something more going on that you want some insight on from releng, I'm open to helping, but until then I don't know what could be different here to cause an issue.
Flags: needinfo?(bugspam.Callek) → needinfo?(snorp)
This affects now 56 too (56.0b3)
Summary: Single locale builds on Beta 55 don't open → Single locale builds on Beta Channel don't open
I spent some time looking at this and really have no idea what's going on.
Flags: needinfo?(snorp)
See Also: → 1403084
Setting affected-57-? since I suspect its affected in BB-Based L10n Repacks, and that we currently don't know what is going on here. (Note: todays Fennec Beta has no successful single-locale repacks due to Bug 1403084)
I'm going to wonftix this due to the just filed Bug 1408083
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
See Also: → 1408083
You need to log in before you can comment on or make changes to this bug.