Closed Bug 137674 Opened 18 years ago Closed 12 years ago

Adobe Acrobat plug-in needed for OSX

Categories

(Core :: Plug-ins, defect, P3)

PowerPC
macOS
defect

Tracking

()

VERIFIED DUPLICATE of bug 91559
mozilla1.2beta

People

(Reporter: Glow11, Assigned: arun)

References

()

Details

(Whiteboard: [Acrobat issue])

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9+)
Gecko/20020414
BuildID:    2002041408

PDF files should beable to be opened within the browser because of Acrobat's PDF
plug-in. Instead you are asked to download the file you are trying to open.

Reproducible: Always
Steps to Reproduce:
1.Install/Make sure Acrobat Reader 5.0.5 is installed
2.Check /library/Internet Plug-ns folder to make sure the PDF plug-in is installed.
3.Open a .pdf file in mozilla
or goto Help/About Plug-ins

Actual Results:  asked to download the file. The plugin dosn't show up in About
Plug-ins

Expected Results:  Acrobat Reader should open up and the file should be
displayed within the browser window. The plug-in should show up in About Plug-ins
Status: UNCONFIRMED → NEW
Ever confirmed: true
peter says adobe's beta version of the latest acrobat fixes this. I have sent a 
mail to Liz inquiring about it. Wasn't this working before? I think it was..or I 
might have been drunk.
I see this too on winxp with acrobat 5.0.5 and pdf .dll v. 5.0.0.327 with latest
nightlies and rc2.. also other pdf related problems with loading: bug 136560 and
bug 144750 and bug 106112 and bug 140416.
acrobat has not yet released a version with this fix..nothing we can do...
setting note in whiteboard
Whiteboard: [ACROBAT]
Whiteboard: [ACROBAT] → [Acrobat issue]
added Liz
giving to Peter to track mac issue
Assignee: beppe → peterl
Priority: -- → P3
Target Milestone: --- → mozilla1.2beta
--->INVALID, notice the same thing in IE.

Adobe has not released an Acrobat plugin for OSX to the public.
(beta versions actually warrent this bug being marked WFM)
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → INVALID
yep
Status: RESOLVED → VERIFIED
Re-opening this bug for tracking purposes.

Once Adobe releases a working build for Mac OSX and we verify that it passes 
installation and some functional testing on PPEmbed and Mozilla, we should 
then mark this bug resolved-fixed prompting QA to regress and verify it fixed.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---
Not an engineering issue, 
--->over to Arun for evangelism.

Those behind the Netscape firewall can find an older pre-release build in my
home directory:
http://warp.mcom.com/u/peterlubczynski/AcrobatOSX/
Assignee: peterl → aruner
Status: REOPENED → NEW
Summary: PDF plugin does not work. → Adobe Acrobat plug-in needed for OSX
Just for those who maybe are tempted to try, of course Acrobat 5.1 still doesn't
have the plugin.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020826
and just downloaded a fresh plug-in (supposedly for Mac 9.1-10.2.1)

Still cannot view PDF in Mozilla browser window.

I added a vote for this bug.

As far as I know Mozilla has never been able to display PDF's in browser, only
download.  Even if I try to open a PDF from my HD it attempts to download it only.

When I try to open with application Acrobat Reader it errors with "[filename]
could not open, becasue an unknown error occured. Sorry about that, Try saving
to disk first and then opening the file."

This does not sound like an Adobe Error message.  Sounds more like a Mozilla
programmer to me.

Alan
We are working on it.  Rudi Sherry at Adobe is the contact person
and I have asked him to sign up for bugzilla.mozilla.org and put
his name as a CC: on this bug. 

Feel free to contact Rudi ... he probably can get you guys a development
version to play with just as soon as he has something cooking.

rsherry@adobe.com
Hey!

Is there a distinct possibility you might be able to release information on a
time schedule/plan on the release of an Acrobat plug-in for OSX Mozilla?

Regards
Hello "the beast...",

This may be splitting hairs, but Mozilla does not release the plug-in, Adobe
releases the plug-in and Mozilla make use of it.  But I'm still uncertain if
this issue lies with the plug-in or the use of the plug-in by Mozilla.

Hopefuly someone will address that soon.

Meanwhile, put your vote on this issue and maybe we'll prove some interest and
we could get some attention to this matter.

Reader for OSX works, it's just that Mozilla only downloads the file instead of
displaying it in the browser window.  At least in MY case.

Alan
Note that as of Quicktime 6.5.2, the Quicktime plugin will display Acrobat PDF
in the browser by default. [Disabling this setting is a bit tricky, see Bug 194986.]
Duplicate of this bug: 373760
I've complained to Adobe on this front. Can you not put pressure on them from Mozilla, you surly have more pull than users do. Also, can you not simple pretend to be Safari when loading the plugin?
Whatever happened to this?
Complaints to Adobe seem to fall on deaf ears (despite the fact that this affects paying customers with Acrobat Pro as well as those just using the free reader). Is anyone on the Firefox team still tracking this or trying to find a resolution?
Is there a way that Firefox could be made to lie to the plugin to make it think it's working is Safari?
The desire to view PDFs inline on Mac OS X is bug 91559; this bug is ultimately a dupe of that, although it's not phrased that way.
Status: NEW → RESOLVED
Closed: 18 years ago12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 91559
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.