release promotion changes for TC mac and win builds

RESOLVED FIXED

Status

enhancement
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: rail, Assigned: rail)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(7 attachments, 5 obsolete attachments)

59 bytes, text/x-review-board-request
jlorenzo
: review+
Details
6.67 KB, patch
aki
: review+
Details | Diff | Splinter Review
1.08 KB, patch
Callek
: review+
Details | Diff | Splinter Review
1.41 KB, patch
aki
: review+
Details | Diff | Splinter Review
55 bytes, patch
mtabara
: review+
Details | Diff | Splinter Review
11.16 KB, patch
mtabara
: review+
Details | Diff | Splinter Review
15.18 KB, patch
mtabara
: review+
Details | Diff | Splinter Review
No description provided.
This is a bare minimum that I need to land in order to test other patches on jamun. There will be more after I'm done.
Comment on attachment 8884820 [details]
Bug 1379261 - release promotion changes for TC mac and win builds

https://reviewboard.mozilla.org/r/155698/#review160710

LGTM module the nits on "repackage".

::: mozilla/config.py:2179
(Diff revision 1)
>              "unsigned": "gecko.v2.mozilla-release.revision.{rev}.firefox.macosx64-opt",
> +            "ci_system": "bb",
> +            # Uncomment when TC is tier-1
> +            # "ci_system": "tc",
> +            # "repacakge": "gecko.v2.mozilla-release.revision.{rev}.firefox-l10n.macosx64-nightly-repackage.en-US",
> +            # "repacakge-signing": "gecko.v2.mozilla-release.revision.{rev}.firefox-l10n.macosx64-nightly-repackage-signing.en-US",

Nit: `repackage` and `repackage-signing`. Same comment applies to the lines below and to the other files.
Attachment #8884820 - Flags: review?(jlorenzo) → review+
Putting the patches together before I start testing them...
Posted patch gecko_indexes.diff (obsolete) — Splinter Review
In-tree Beetmover config changes. Splitting things into 4 (vs 2) tasks.
Posted patch tools.diff (obsolete) — Splinter Review
Duplicate of this bug: 1354604
Blocks: 1354608
Attachment #8886252 - Flags: review?
Attachment #8886252 - Flags: review? → review+
Use dep certs on jamun
Attachment #8886293 - Flags: review?
Attachment #8886293 - Flags: review? → review+
Posted patch gecko_indexes.diff (obsolete) — Splinter Review
Attachment #8886227 - Attachment is obsolete: true
(In reply to Rail Aliiev [:rail] ⌚️ET from comment #13)
> Comment on attachment 8886293 [details] [diff] [review]
> jamun-signing.diff
> 
> https://hg.mozilla.org/build/buildbot-configs/rev/
> 588e922ab919d8e9872a9faec18fa8ec05d89d85

Merged to prod - https://hg.mozilla.org/build/buildbot-configs/rev/8b4445eb311e.
Posted patch gecko: beetmover configs (obsolete) — Splinter Review
Attachment #8886359 - Attachment is obsolete: true
Posted patch release-runner changes (obsolete) — Splinter Review
Attachment #8886228 - Attachment is obsolete: true
Attachment #8887627 - Flags: review?(aki) → review+
Attachment #8887935 - Flags: review?(mtabara)
Attachment #8887597 - Attachment is obsolete: true
Attachment #8887936 - Flags: review?(mtabara)
Blocks: 1382240
Attachment #8887935 - Attachment is patch: true
Attachment #8887935 - Attachment mime type: text/x-github-pull-request → text/plain
Attachment #8887935 - Flags: review?(mtabara) → review+
Comment on attachment 8887936 [details] [diff] [review]
release-runner changes

Review of attachment 8887936 [details] [diff] [review]:
-----------------------------------------------------------------

::: lib/python/kickoff/__init__.py
@@ +166,5 @@
> +                taskid=unsigned_task["taskId"]
> +            )
> +            if platform.startswith("mac"):
> +                # FIXME: dirty dirty hack
> +                mar_tools_url = "https://archive.mozilla.org/pub/firefox/nightly/2017/06/2017-06-21-03-02-08-mozilla-central"

This looks indeed suspicious. How long are we planning to keep this hack?
Attachment #8887936 - Flags: review?(mtabara) → review+
(In reply to Mihai Tabara [:mtabara]⌚️GMT from comment #23)
> > +            if platform.startswith("mac"):
> > +                # FIXME: dirty dirty hack
> > +                mar_tools_url = "https://archive.mozilla.org/pub/firefox/nightly/2017/06/2017-06-21-03-02-08-mozilla-central"
> 
> This looks indeed suspicious. How long are we planning to keep this hack?

This is bug 1381495 :/
Attachment #8887935 - Flags: checked-in+
Deployed. The only remaining patch is the gecko patch.
Comment on attachment 8887596 [details] [diff] [review]
gecko: beetmover configs

We will need to update this after bug 1372260 lands
See Also: → 1372260
(In reply to Rail Aliiev [:rail] ⌚️ET - PTO in August from comment #27)
> Comment on attachment 8887596 [details] [diff] [review]
> gecko: beetmover configs
> 
> We will need to update this after bug 1372260 lands

Uplifted + adjusted for jamun (change also in repackage)
https://hg.mozilla.org/projects/jamun/rev/de332d82d056efa1396012a11e56062ff6c27ca1
Refreshed, with stub installer renamed.
Attachment #8887596 - Attachment is obsolete: true
Attachment #8889510 - Flags: review?(mtabara)
Comment on attachment 8889510 [details] [diff] [review]
gecko: beetmover configs

Looks good to me, assuming I got this right :)
Attachment #8889510 - Flags: review?(mtabara) → review+
Pushed by raliiev@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8f72d0cb7441
Update release promotion beetmover manifests r=mtabara DONTBUILD
https://hg.mozilla.org/mozilla-central/rev/8f72d0cb7441
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.