Closed Bug 1384392 Opened 2 years ago Closed 2 years ago

Don't show manual migration offer on existing profiles

Categories

(Firefox :: New Tab Page, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 56
Tracking Status
firefox56 --- fixed

People

(Reporter: Dolske, Unassigned)

References

Details

Attachments

(1 file)

Updating to today's Nightly gave me a message (see screenshot) suggesting that I import favorite sites and bookmarks from another browser.

This is a little weird, because this is the Firefox profile that I've been using for 6+ years now. Why suddenly offer to import data?

I'm not sure what the current logic/intent is for this, but seems like this should only be triggering for recently created profiles.
bryantmao can provide more context. He provided the spec in https://github.com/mozilla/activity-stream/issues/2787#issuecomment-316946571

Short summary is that users will see it for at most 3 active days and can dismiss the prompt to not see it again.
Flags: needinfo?(bmao)
Blocks: 1374560
After the discussion with Michael, the proposal is to show the import option if the user checks the auto refresh option in the stab installer. Check here for more detail: https://github.com/mozilla/activity-stream/issues/2967
Flags: needinfo?(bmao)
Duplicate of this bug: 1384494
At least for 56, we'll use some way to estimate profile creation time, and if it's older than 3 days, don't offer the manual migration.
Fixed with https://github.com/mozilla/activity-stream/pull/2990 to be uplifted via bug 1385133.
Blocks: 1385133
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
See Also: → 1385066
Target Milestone: --- → Firefox 56
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.