Developer Tools disappeared on Nightly for many users on July 27 [devtools]

RESOLVED FIXED in Firefox 56

Status

defect
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: pascalc, Assigned: jdescottes)

Tracking

({regression})

Trunk
Firefox 56
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56blocking fixed)

Details

Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0 ID:20170727100240 CSet: e5693cea1ec944ca077c7a46c5f127c828a90f1b

In today's  build, the Web Developer menu is empty, the only devtool available is View Source, the shortcut key to activate the devtools is not doing anything.

This was seen and reported by multiple people, mostly on Linux but also Windows.
I imagine it comes from bug 1369801.
Depends on: 1369801
This fixed itself for me after a restart, but shouldn't have been broken in the first place.
Summary: Dev tools disapperared on Nightly for many users today → Dev tools disappeared on Nightly for many users on July 27
Blocks: 1369801
No longer depends on: 1369801
Summary: Dev tools disappeared on Nightly for many users on July 27 → Developer Tools disappeared on Nightly for many users on July 27 [devtools]
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #3)
> This fixed itself for me after a restart, but shouldn't have been broken in
> the first place.

I can confirm the problem and that a restart solved for me too.
Thanks for the reports.

Unfortunately, automation doesn't cover profile/app-update issues... nor, is it easy to manually test that.

Now, if there is any breakage that occur even after a restart, please drop a word.
It looks like for most people, it works fine after a restart.
This has been fixed by the backout of bug 1369801, new nightlies have been requested.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Assignee: nobody → jdescottes
Target Milestone: --- → Firefox 56

Comment 7

a year ago
When trying to open the developer tools, by any means (shortcut key, right-click "inspect element" or selecting from Tools > Webdeveloper). The developer tools do not open (nothing happens).

This started to happen this morning:
Version: 62.0a1 (2018-06-08) (64-bit)
(In reply to Matt Gale from comment #7)
> When trying to open the developer tools, by any means (shortcut key,
> right-click "inspect element" or selecting from Tools > Webdeveloper). The
> developer tools do not open (nothing happens).
> 
> This started to happen this morning:
> Version: 62.0a1 (2018-06-08) (64-bit)

Hi Matt, please check https://bugzilla.mozilla.org/show_bug.cgi?id=1467760
This is probably the same problem as the one fixed in bug 1467679.
Will go away as soon as this bug lands and a new nightly is built.
In the meantime, you can set pref devtools.toolbox.host (in about:config) to right, instead of side.

Comment 10

a year ago
This is solved now, thanks for the quick response.

Updated

a year ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.