TEST-UNEXPECTED-FAIL | /builds/slave/test/build/tests/mozmill/quick-filter-bar/test-filter-logic.js | test-filter-logic.js::test_filter_tags

RESOLVED FIXED in Thunderbird 64.0

Status

defect
RESOLVED FIXED
2 years ago
9 months ago

People

(Reporter: jorgk, Assigned: aceman)

Tracking

({intermittent-failure})

Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird63 fixed, thunderbird64 fixed)

Details

(Whiteboard: [Thunderbird-testfailure: Z Mac only][Thunderbird-disabled-test] )

Attachments

(3 attachments)

Reporter

Description

2 years ago
First seen Fri Aug 4, 2017 11:38:35 after quite a bit of bustage fix:
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=13e8fa67e60a3180c22702527f6f1079f290ce90

Mac only, perma red.

Log says:
04:17:28     INFO -  TEST-START | /builds/slave/test/build/tests/mozmill/quick-filter-bar/test-filter-logic.js | test_filter_tags
04:17:28     INFO -  The view is showing the following message header and should not be:
04:17:28     INFO -    Subject: Fun Ray-Gun Tomorrow
04:17:28     INFO -    Date: Tue Feb 01 2000 13:00:00 GMT-0800 (PST)
04:17:28     INFO -    Author: "Zig Zig" <zig@zig.invalid>
04:17:28     INFO -    Recipients: "Andy Bell" <andy@bell.invalid>
04:17:28     INFO -    Read: false   Flagged: false   Killed: false   Junk: false
04:17:28     INFO -    Keywords:
04:17:28     INFO -    Folder: QuickFilterBarTags  Key: 2
04:17:28     INFO -  View State:
04:17:28     INFO -  ********* Current View Contents
04:17:28     INFO -  . Fun Ray-Gun Tomorrow [QuickFilterBarTags,2]
04:17:28     INFO -  . Lame Pen Yesterday [QuickFilterBarTags,3]
04:17:28     INFO -  . Funky Sword In a Fortnight [QuickFilterBarTags,4]
04:17:28     INFO -  . Big Party Tomorrow [QuickFilterBarTags,5]
04:17:28     INFO -  ********* end view contents
04:17:28     INFO -  View: [xpconnect wrapped (nsISupports, nsIMsgDBView, nsITreeView)]
04:17:28     INFO -    View Type: eShowQuickSearchResults   View Flags: 0
04:17:28     INFO -    Sort Type: byDate   Sort Order: ascending
04:17:28     INFO -    Search Terms:
04:17:28     INFO -      Virtual Folder Terms:
04:17:28     INFO -        (none)
04:17:28     INFO -      View Terms:
04:17:28     INFO -        (none)
04:17:28     INFO -      User Terms:
04:17:28     INFO -        tag,isn't empty,
04:17:28     INFO -      Scope (Folders):
04:17:28     INFO -        QuickFilterBarTags

and

04:17:38     INFO -  SUMMARY-UNEXPECTED-FAIL | test-filter-logic.js | test-filter-logic.js::test_filter_tags
04:17:38     INFO -    EXCEPTION: view contains header that should not be present! [msgHdr mailbox://nobody@Local%20Folders/QuickFilterBarTags#2]
04:17:38     INFO -      at: test-folder-display-helpers.js line 108
04:17:38     INFO -         do_throw test-folder-display-helpers.js:108 13
04:17:38     INFO -         mark_failure logHelper.js:649 3
04:17:38     INFO -         verify_messages_in_view viewWrapperTestUtils.js:415 7
04:17:38     INFO -         assert_messages_in_view test-folder-display-helpers.js:1769 3
04:17:38     INFO -         test_filter_tags test-filter-logic.js:163 3
04:17:38     INFO -         Runner.prototype.wrapper frame.js:585 9
04:17:38     INFO -         Runner.prototype._runTestModule frame.js:655 9
04:17:38     INFO -         Runner.prototype.runTestModule frame.js:701 3
04:17:38     INFO -         Runner.prototype.runTestDirectory frame.js:525 7
04:17:38     INFO -         runTestDirectory frame.js:707 3
04:17:38     INFO -         Bridge.prototype._execFunction server.js:179 10
04:17:38     INFO -         Bridge.prototype.execFunction server.js:183 16
04:17:38     INFO -         Session.prototype.receive server.js:282 3
04:17:38     INFO -         AsyncRead.prototype.onDataAvailable server.js:88 3

M-C last good: fa1da3c0b200abbd9cfab3cab199628243
M-C first bad: 32083f24a1bb2c33050b4c972783f06643

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fa1da3c0b200abbd9cfab3cab199628243&tochange=32083f24a1bb2c33050b4c972783f06643

Range is one M-C merge at Fri Aug 04 01:07:14 2017. We can't get better than that.

Aceman, can I get you interested here? I know you love to work on Mac bugs (not!).
Flags: needinfo?(acelists)
Reporter

Comment 1

2 years ago
Setting intermittent-failure so the treeherder will offer it, it's perma though.
Reporter

Updated

2 years ago
Keywords: leave-open

Comment 3

2 years ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/d240ea7abfd5
temporarily disable test-filter-logic.js::test_filter_tags on Mac. rs=bustage-fix
Assignee

Comment 4

2 years ago
I am looking at this but do not see why only clicking tagC fails and only on OS X. Maybe it is just a timing problem.
Reporter

Updated

2 years ago
Whiteboard: [Thunderbird-testfailure: Z Mac only] → [Thunderbird-testfailure: Z Mac only][Thunderbird-disabled-test]

Comment 6

Last year
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/8a8e32962e47
temporarily disable test-filter-logic.js::test_filter_tags on Linux. rs=bustage-fix
Reporter

Comment 7

9 months ago
Jolly good, now this is also happening on Windows.
https://taskcluster-artifacts.net/OETFyI-RTC6R0qgOrMvyew/0/public/logs/live_backing.log

INFO -  The view is showing the following message header and should not be:
INFO -    Subject: Fun Ray-Gun Tomorrow
INFO -    Date: Tue Feb 01 2000 13:00:00 GMT+0000 (Greenwich Mean Time)
INFO -    Author: "Zig Zig" <zig@zig.invalid>
INFO -    Recipients: "Andy Bell" <andy@bell.invalid>
INFO -    Read: false   Flagged: false   Killed: false   Junk: false
INFO -    Keywords:
INFO -    Folder: QuickFilterBarTags  Key: 2
INFO -  View State:

and

INFO -  SUMMARY-UNEXPECTED-FAIL | Z:\task_1537612609\build\tests\mozmill\quick-filter-bar\test-filter-logic.js | test-filter-logic.js::test_filter_tags
INFO -    EXCEPTION: view contains header that should not be present! [msgHdr mailbox://nobody@Local%20Folders/QuickFilterBarTags#2]
INFO -      at: test-folder-display-helpers.js line 109
INFO -         do_throw test-folder-display-helpers.js:109 13
INFO -         mark_failure logHelper.js:650 3
INFO -         verify_messages_in_view viewWrapperTestUtils.js:415 7
INFO -         assert_messages_in_view test-folder-display-helpers.js:1797 3
INFO -         test_filter_tags test-filter-logic.js:165 3

Same as in comment #0.

Already switched off on Mac and Linux, if I switch off one more platform, we lose the test.
Reporter

Comment 8

9 months ago
mozmake SOLO_TEST=quick-filter-bar/test-filter-logic.js mozmill-one
passes locally for me on Windows. So hard to fix something that isn't quite broken.
Assignee

Comment 9

9 months ago
Yes I also can't reproduce it locally. I enabled the test on try on Mac an Linux. Notice the interesting screenshot when the test failed on Mac: https://taskcluster-artifacts.net/PJ2lpfKISzexoeMoDaS-0g/0/public/test_info/test-filter-logic.js__test_filter_tags-CEdg0r.png

The folder pane is too large and the button for tagC that is failing isn't even visible on the message pane due to low width. It may be possible the test has problems clicking the off-screen button. Yes, it works sometimes, but may be fragile and we must not rely on it as it does something a user wouldn't be able to do.
Assignee

Comment 10

9 months ago
Similar problem exists on Windows, even though the third tag button is partly visible: https://queue.taskcluster.net/v1/task/KTTQCpkCQ5KKlFmI4_WdKg/runs/0/artifacts/public/test_info/test-filter-logic.js__test_filter_tags-qncey4.png
Assignee

Comment 11

9 months ago
The test didn't fail on Linux this time.
It is the test test-display-issues.js that messes with the pane and window sizes. On Linux, this one ran after test-filter-logic.js.
Let's try the theory:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=b96f58ea3ba76f3515275cc4d6a2de69e4e89904
Flags: needinfo?(acelists)
Reporter

Comment 12

9 months ago
OK, if you need to fix the test that leaves funny geometries behind, that's fine. Otherwise I had this idea: Apparently the tags are placed into a scrollbox with little scroll arrows on either side. How about just doing something like
  this.arrowScrollbox.ensureElementIsVisible(this.selectedItem);
Assignee

Comment 13

9 months ago
(In reply to Jorg K (GMT+2) from comment #12)
> fine. Otherwise I had this idea: Apparently the tags are placed into a
> scrollbox with little scroll arrows on either side. How about just doing
> something like
>   this.arrowScrollbox.ensureElementIsVisible(this.selectedItem);

Good idea, I have added that into the new patch too.
Assignee: nobody → acelists
Status: NEW → ASSIGNED
Component: General → Testing Infrastructure
Keywords: leave-open
OS: Unspecified → All
Hardware: Unspecified → All
Assignee

Updated

9 months ago
Attachment #8898014 - Attachment description: 1387704.patch - temporarily disable test on Mac → 1387704.patch - temporarily disable test on Mac [landed in comment 3]
Assignee

Updated

9 months ago
Attachment #8957341 - Attachment description: 1387704-linux.patch → 1387704-linux.patch [landed in comment 6]
Reporter

Comment 15

9 months ago
Comment on attachment 9011243 [details] [diff] [review]
1387704.patch fix

Supercalifragilisticexpialidocious!

Five more failing disabled tests are waiting:
Bug 1373809, bug 1406717, bug 1413851, bug 1440951 and bug 1461173. The last one is a mystery, perhaps a screenshot could shed some light onto it.
Attachment #9011243 - Flags: review?(jorgk) → review+
Assignee

Comment 16

9 months ago
Thanks.
Keywords: checkin-needed
Assignee

Updated

9 months ago
Blocks: 1493461

Comment 17

9 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/32fc6e969e27
ensure tag label buttons are visible in quick-filter-bar/test-filter-logic.js. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Reporter

Updated

9 months ago
Target Milestone: --- → Thunderbird 64.0
Reporter

Comment 18

9 months ago
Comment on attachment 9011243 [details] [diff] [review]
1387704.patch fix

Seen in beta too, so let's get the fix there.
Attachment #9011243 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.