Zonealarm pro interference

RESOLVED INCOMPLETE

Status

Plugins Graveyard
Checkpoint Zonealarm
--
major
RESOLVED INCOMPLETE
16 years ago
2 years ago

People

(Reporter: yshkolni, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
Zone alarm pro with privacy options on makes Mozilla RC1 stop working with any 
site which has the ads blocked.  Zonealarm doesn't prevent anything else from 
working.
How are you blocking the ads, exactly?
(Reporter)

Comment 2

16 years ago
Zone alarm pro comes with options to block adds.  I suppose it looks for images 
which come from add servers and blocks them.  If I keep zone alarm on, and 
remove the privacy options, mozilla works again.  Was not an issue with older 
Zone alarms since privacy feature only got implemented in v3.

I seem to recall having the same problem with adfilter with Mozilla 0.9.6, but 
Mozilla had to many problems for me to use it full time at that point so I 
ignored it (adfilter stopped giving updates so I uninstalled it and did't 
really have a chance to test mozilla later).

Comment 3

16 years ago
Probably zonealarm is blocking socket API calls to the banned sites. Perhaps
these fail and necko does not recover from the blow?

Just an idea: I can't confirm this because I do not have zonealarm pro. But I
have seen socket calls fail with regular zonealarm running.

Comment 4

16 years ago
tever: any chance we can get a hold of a zonealarm pro installation?

-> future
Target Milestone: --- → Future

Comment 5

16 years ago
I believe it's a ZoneAlarm bug, since other firewalls work normal with Moz.
wfm with adguard and full Ad-blocking enabled

Comment 7

16 years ago
darin, I'll look into getting a copy.

Comment 8

16 years ago
Reporter, please try a new, fresh, unaltered Mozilla profile with your
configuration. Does Mozilla then work?

Comment 9

16 years ago
*** Bug 144223 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
Same problem with RC3 and the latest version of ZoneAlarm Pro (v3.0.118); caused
a great deal of headache when installing RC3 - it so totally stalls the browser
and mail that you believe it's a Moz installation problem. Sadly, I uninstalled
and re-installed RC3 twice and backed-up and then deleted the profile (thinking
this was where the problem lay) before I figured out where the issue really
originated. RC2 and the old ZoneAlarm Pro did not suffer from this problem. It
really should be mentioned as an advisory issue in the installation notes for
Win while it’s being looked into.

The conflict seems to be between Moz 1’s Advanced>Scripts & Windows settings and
ZoneAlarm’s Privacy setting which attempts to carry out a similar function. The
expedient/simple answer is that you must switch ZoneAlarm Pro’s ‘privacy’
feature to ‘off’ for Mozilla in order to use Moz. (As commented upon by others,
this new ZA feature doesn’t seem to conflict too much with IE 5.5 or NN 4.9 -
haven’t tried Opera but I will.)

I don’t believe it is a Moz bug, but I couldn’t say for sure - seems more like a
conflict of function. Have advised ZoneAlarm's Tech Supp about it too, in the
hope that they might consider a FAQ. As I use ZoneAlarm Pro constantly and am a
long-time user, I’m happy to test various combinations of settings etc if Darin
wants to suggest a procedure. Bear in mind though that I’m not a programmer :-))

Comment 11

16 years ago
I can confirm that Mozilla 1.0 RC 2 + (and Netscape 7.0 PR 1) do not work at all
when Zone Alarm Pro has ad blocking + script blocking (i.e. Privacy Control)
enabled. Turning Privacy Control off in Zone Alarm Pro lets Mozilla access
websites. With Netscape 7 - AIM works, but browsing websites does not. 

I don't know if this is a Zone Alarm bug or a Mozilla bug.
But I can confirm that this happens.

Comment 12

16 years ago
can you try downgrading your HTTP connections to HTTP/1.0 instead of HTTP/1.1? 
does that help?  what about disabling "persistent connections"?  thx!

Comment 13

16 years ago
Downgrading HTTP connections to HTTP/1.0 instead of HTTP/1.1 makes no
difference. Neither does disabling 'persistent connections'. (Tried both options
alone and in combination.) Whatever those settings, when you enable ZA's
'privacy' for Mozilla the browser stalls and you have to restart Mozilla.

Comment 14

16 years ago
Somebody posted a message in the browser newsgroup today, and confirmed that
Zone Alarm Pro  (ZAP) 3.0 with privacy settings on does prevent Mozilla 1.0 from
working, on Windows ME. However, on another Windows XP computer of his, Zone
Alarm Pro 3.0 with privacy blocking on did not block Mozilla.

I had the same problem on Windows 98. So, maybe this affects DOS based versions
of Windows only, i.e.: Windows 95 / 98 / ME and not NT based versions of
Windows, i.e.: NT 4, 2000, XP.

Maybe this helps narrow it down.

Regards,

- Jay
PS: Privacy Settings with ZAP 3.0 work with Internet Explorer and Opera 6.02 on
my Windows 98 computer, but not with Mozilla 1.0 or Netscape 7.0 PR 1 .

Comment 15

16 years ago
Had the same problem, but tought it was a Norton Internet Security problem which
I also use (This was reported in Bug 151071).  After switching ZoneAlarm's
Privacy Settings to 'off', the problem was solved

Comment 16

16 years ago
*** Bug 159329 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
I just tried out Mozilla 2002 08 02 08 (pre 1.1) and miraculously - Zone Alarm
Pro 3.x works with Mozilla, even when "Privacy" (within Zone Alarm Pro" is
enabled. I wonder how this magically started working. In any case, this is very
good news! Maybe someone fixed this in another bug ... Can anyone verify this?

Thanks.

- Jay

Comment 18

16 years ago
marking WORKSFORME per comment #17.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
*** Bug 147209 has been marked as a duplicate of this bug. ***
*** Bug 167080 has been marked as a duplicate of this bug. ***

Comment 21

16 years ago
*** Bug 164903 has been marked as a duplicate of this bug. ***

Comment 22

16 years ago
verified wfm

Comment 23

16 years ago
"
Status: RESOLVED → VERIFIED

Comment 24

15 years ago
*** Bug 183243 has been marked as a duplicate of this bug. ***

Updated

15 years ago
No longer blocks: 158887

Comment 25

7 years ago
We're now tracking such bugs. This doesn't mean it's something we can fix, merely something we hope to be able to point vendors to so they can investigate. This is an automated message.
Assignee: darin.moz → nobody
Status: VERIFIED → UNCONFIRMED
Component: Networking: HTTP → Checkpoint Zonealarm
Product: Core → Plugins
QA Contact: tever → checkpoint-zonealarm
Resolution: WORKSFORME → ---
Target Milestone: Future → ---
Version: Trunk → unspecified

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago5 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.