Closed Bug 1391191 Opened 3 years ago Closed 3 years ago

Consolidate navigator toolbox bottom border styling

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 57
Iteration:
57.2 - Aug 29
Tracking Status
firefox57 --- fixed

People

(Reporter: dao, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(1 file)

- move to browser.inc.css
- update color values on Mac on Windows
- remove obsolete [customizing] adjustments on Windows 7 and 8
We can probably get rid of -moz-box-ordinal-group too...
Note that the removal of the negative margin on Mac should make the nav-bar's vertical padding even, as it should be.
Iteration: --- → 57.2 - Aug 29
Flags: qe-verify?
Flags: qe-verify? → qe-verify-
Comment on attachment 8898200 [details]
Bug 1391191 - Consolidate navigator toolbox bottom border styling.

https://reviewboard.mozilla.org/r/169566/#review175262

Quite nice!
Attachment #8898200 - Flags: review?(jhofmann) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2f78aad3c907
Consolidate navigator toolbox bottom border styling. r=johannh
https://hg.mozilla.org/mozilla-central/rev/2f78aad3c907
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Backed out in https://hg.mozilla.org/mozilla-central/rev/3dc98e773869 for Mac wpt permaorange like https://treeherder.mozilla.org/logviewer.html#?job_id=124264709&repo=mozilla-central, /scroll-anchoring/anchoring-with-bounds-clamping.html | Anchoring combined with scroll bounds clamping in the document. - assert_equals: expected 100 but got 101, the return of bug 1390246 and thus apparently of an extra pixel of Mac tabbar, after a few hours of that being fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 57 → ---
Depends on: 1391695
Blocks: 1391695
No longer depends on: 1391695
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5e8fc0f71bcf
Consolidate navigator toolbox bottom border styling. r=johannh
https://hg.mozilla.org/mozilla-central/rev/5e8fc0f71bcf
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
No longer blocks: 1391695
Duplicate of this bug: 1391695
There is a regression: I filed Bug 1393406.
Depends on: 1393406
Screenshots:

https://screenshots.mattn.ca/compare/?oldProject=mozilla-central&oldRev=a9d372645a32b8d23d44244f351639af9d73b96a&newProject=mozilla-central&newRev=c7570eb46382ee56d081e549b484341f400c864b

Two things to note here:

- The navbar height on OSX has increased by ~1px. (Might have caused bug 1393406)
- The bottom border on Windows has become slightly lighter.
(In reply to Johann Hofmann [:johannh] from comment #14)
> Screenshots:
> 
> https://screenshots.mattn.ca/compare/?oldProject=mozilla-
> central&oldRev=a9d372645a32b8d23d44244f351639af9d73b96a&newProject=mozilla-
> central&newRev=c7570eb46382ee56d081e549b484341f400c864b
> 
> Two things to note here:
> 
> - The navbar height on OSX has increased by ~1px. (Might have caused bug
> 1393406)

This should be intended. --> See my comment in Bug 1393406. Thanks.
Depends on: 1406353
You need to log in before you can comment on or make changes to this bug.