Closed Bug 1392572 Opened 5 years ago Closed 5 years ago

Help button doesn't link to preference-specific articles

Categories

(Firefox :: Preferences, defect, P3)

56 Branch
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- disabled
firefox56 --- disabled
firefox57 --- verified

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression, ux-efficiency, Whiteboard: [photon-preference])

Attachments

(1 file)

Attached image screenshot
[Tracking Requested - why for this release]: Regression of UX

Please make user friendly.

Reproduced: always

Steps To Reproduce:
1. Open Preferences


Actual Results:
? button is missing, See attached screenshot


Expected Results:
? button should be provided as Firefox55
Expected Results:
? button should be provided as Firefox55
Clicking ? button jumps to associated help page.
Keywords: ux-efficiency
Whiteboard: [photon-structure]
Whiteboard: [photon-structure] → [photon-structure] [triage]
Whiteboard: [photon-structure] [triage] → [photon-preferences] [triage]
Hi Francis,
Can you help chech if the issue is by design or a regression?
Flags: needinfo?(frlee)
Flags: needinfo?(frlee)
Whiteboard: [photon-preferences] [triage] → [photon-preference][triage]
According to Photon visual redesign, the Help button has been moved to bottom left side of Preferences.

https://mozilla.invisionapp.com/share/X8BGCX9PD#/screens/244683005

As a result, this issue is invalid.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
Whiteboard: [photon-preference][triage]
Before landing Photon structure,
Clicking ? button jumps to associated help page.
in this case,
https://support.mozilla.org/en-US/kb/applications-panel-set-how-firefox-handles-files?redirectlocale=en-US&as=u&redirectslug=Options+window+-+Applications+panel&utm_source=inproduct


After landing Photon structure,
https://support.mozilla.org/en-US/products/firefox/manage-preferences-and-add-ons-firefox/install-and-manage-add-ons

Convenience of HELP has declined markedly.
This fact is definitely regression. NOT INVALID
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
The help button used to be associated with a helpTopic, which pointed to different help topics at https://support.mozilla.org. But now you always end up at https://support.mozilla.org/1/firefox/57.0a1/Darwin/en-US/preferences when clicking the button.
(moving this to Firefox, since this code is in /browser)
Product: Toolkit → Firefox
(In reply to Stefan [:stefanh] from comment #5)
> But now you always end
> up at https://support.mozilla.org/1/firefox/57.0a1/Darwin/en-US/preferences
> when clicking the button.

Ah, probably because the help content isn't ready yet.
It looks like https://support.mozilla.org/en-US/kb/firefox-options-preferences-and-settings is more updated.

ricky, should we change the link to this page?
Flags: needinfo?(rchien)
Summary: Lack of HELP button in New Preferences page → Help button doesn't link to preference-specific articles
Priority: -- → P3
The current SUMO website will redirect

https://support.mozilla.org/1/firefox/58.0a1/Darwin/en-US/preferences

to

https://support.mozilla.org/en-US/products/firefox/manage-preferences-and-add-ons-firefox


But I agree that it would be more useful if we can redirect to

https://support.mozilla.org/en-US/kb/firefox-options-preferences-and-settings

I believe this is a url redirect issue of SUMO site like (bug 1394746), which can be done in SUMO website instead of patching in-product link.

Joni, could you help us fix the link?
Status: REOPENED → NEW
Flags: needinfo?(rchien) → needinfo?(jsavage)
Whiteboard: [photon-preference][triage]
Thanks for looking me in, Ricky. I've changed the link and it works on my end. Please let me know if you need anything else.
Flags: needinfo?(jsavage)
Thanks! it works :)
Status: NEW → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Whiteboard: [photon-preference][triage] → [photon-preference]
I verified this issue using latest Nightly 58.0a1 and Firefox Release 56 on Windows 10 x64, Ubuntu 16.04 and Mac OS X 10.12.
I will mark this as verified fixed.
Status: RESOLVED → VERIFIED
See Also: → 1353915, 1361969
You need to log in before you can comment on or make changes to this bug.