Intermittent TEST-UNEXPECTED-TIMEOUT | /webdriver/tests/state/get_element_attribute.py | expected OK

RESOLVED FIXED in Firefox 58

Status

Testing
geckodriver
P5
normal
RESOLVED FIXED
6 months ago
21 days ago

People

(Reporter: Treeherder Bug Filer, Assigned: whimboo)

Tracking

({intermittent-failure, regression})

Version 3
mozilla59
intermittent-failure, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox56 unaffected, firefox57 wontfix, firefox58 fixed, firefox59 fixed)

Details

(Whiteboard: [stockwell unknown])

Duplicate of this bug: 1393264
(Assignee)

Comment 2

6 months ago
I'm fairly sure this is another regression from bug 1392346. A fix for bug 1392854 should also fix this bug.
Blocks: 1392346
status-firefox56: --- → unaffected
status-firefox57: --- → affected
Depends on: 1392854
Keywords: regression
Priority: P5 → P3

Comment 3

6 months ago
25 failures in 908 pushes (0.028 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-central: 14
* try: 6
* autoland: 4
* mozilla-inbound: 1

Platform breakdown:
* linux64-ccov: 19
* linux64: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-08-21&endday=2017-08-27&tree=all

Updated

6 months ago
status-firefox57: affected → fix-optional
(Assignee)

Comment 4

6 months ago
(In reply to Henrik Skupin (:whimboo) from comment #2)
> I'm fairly sure this is another regression from bug 1392346. A fix for bug
> 1392854 should also fix this bug.

Andreas, do you think that this failure has also been fixed now?
Flags: needinfo?(ato)
(In reply to Henrik Skupin (:whimboo) from comment #4)

> (In reply to Henrik Skupin (:whimboo) from comment #2)
> 
> > I'm fairly sure this is another regression from bug 1392346. A
> > fix for bug 1392854 should also fix this bug.

To me a timeout isn’t consistent with the fallout we saw from
https://bugzilla.mozilla.org/show_bug.cgi?id=1392346, which was to
do with staleness checks on XUL elements.  There are no XUL elements
in use for the Get Element Attribute as far as I know.
Flags: needinfo?(ato)
Whiteboard: [stockwell needswork]
(Assignee)

Comment 7

6 months ago
The failing test in question here is:

https://dxr.mozilla.org/mozilla-central/rev/04b6be50a2526c7a26a63715f441c47e1aa1f9be/testing/web-platform/tests/webdriver/tests/state/get_element_attribute.py#160

And that specifically for the parameters `button` and `autofocus`:

[task 2017-09-01T00:36:14.250563Z] 00:36:14     INFO - STDOUT: testing boolean attribute <button autofocus>
[task 2017-09-01T00:36:14.266554Z] 00:36:14     INFO - PID 2704 | 1504226174255	Marionette	DEBUG	Received DOM event "beforeunload" for "data:text/html;charset=utf-8,%3Caudio%20muted%3E"
[task 2017-09-01T00:36:14.268527Z] 00:36:14     INFO - PID 2704 | 1504226174264	Marionette	DEBUG	Received DOM event "pagehide" for "data:text/html;charset=utf-8,%3Caudio%20muted%3E"
[task 2017-09-01T00:36:14.270237Z] 00:36:14     INFO - PID 2704 | 1504226174265	Marionette	DEBUG	Received DOM event "unload" for "data:text/html;charset=utf-8,%3Caudio%20muted%3E"
[task 2017-09-01T00:36:14.270829Z] 00:36:14     INFO - PID 2704 | ++DOMWINDOW == 11 (0x23364c0) [pid = 3073] [serial = 12] [outer = 0x1917240]
[task 2017-09-01T00:36:14.307394Z] 00:36:14     INFO - PID 2704 | 1504226174300	Marionette	DEBUG	Received DOM event "DOMContentLoaded" for "data:text/html;charset=utf-8,%3Cbutton%20autofocus%3E"
[task 2017-09-01T00:36:14.315459Z] 00:36:14     INFO - PID 2704 | 1504226174309	Marionette	DEBUG	Received DOM event "pageshow" for "data:text/html;charset=utf-8,%3Cbutton%20autofocus%3E"
[task 2017-09-01T00:36:14.800589Z] 00:36:14     INFO - TEST-UNEXPECTED-TIMEOUT | /webdriver/tests/state/get_element_attribute.py | expected OK

This is a new test which landed 10 days ago by David via bug 1376625. David, can you please have a look at this?
Flags: needinfo?(dburns)

Comment 8

6 months ago
60 failures in 939 pushes (0.064 failures/push) were associated with this bug in the last 7 days. 

This is the #39 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* mozilla-central: 39
* mozilla-inbound: 10
* try: 7
* autoland: 4

Platform breakdown:
* linux64-ccov: 39
* linux64: 21

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-08-28&endday=2017-09-03&tree=all
Left this running for 1h30 to try reproduce and couldn't. yay for consistent environments!
Managed to recreate it!

It looks like the the new photon "Nightly - Tip: Get Help by looking...." seems. I dont have proof by when that appears the test times out, when it doesnt then it works.
Flags: needinfo?(dburns)

Comment 11

6 months ago
10 failures in 924 pushes (0.011 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-central: 9
* mozilla-inbound: 1

Platform breakdown:
* linux64-ccov: 9
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-09-04&endday=2017-09-10&tree=all
Whiteboard: [stockwell needswork] → [stockwell unknown]
(Assignee)

Comment 12

6 months ago
(In reply to David Burns :automatedtester from comment #10)
> It looks like the the new photon "Nightly - Tip: Get Help by looking...."
> seems. I dont have proof by when that appears the test times out, when it
> doesnt then it works.

I think we should disable this popup by default in both Marionette and geckodriver.
Bulk priority update of open intermittent test failure bugs. 

P3 => P5

https://bugzilla.mozilla.org/show_bug.cgi?id=1381960
Priority: P3 → P5

Comment 14

5 months ago
4 failures in 1032 pushes (0.004 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-inbound: 3
* mozilla-central: 1

Platform breakdown:
* linux64: 4

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-09-11&endday=2017-09-17&tree=all

Comment 15

5 months ago
3 failures in 943 pushes (0.003 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-inbound: 2
* mozilla-central: 1

Platform breakdown:
* linux64: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-09-18&endday=2017-09-24&tree=all

Comment 16

5 months ago
2 failures in 885 pushes (0.002 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-inbound: 1
* autoland: 1

Platform breakdown:
* linux64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-09-25&endday=2017-10-01&tree=all

Comment 17

5 months ago
1 failures in 824 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-inbound: 1

Platform breakdown:
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-10-02&endday=2017-10-08&tree=all

Comment 18

4 months ago
1 failures in 947 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 1

Platform breakdown:
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-10-09&endday=2017-10-15&tree=all

Comment 19

4 months ago
7 failures in 864 pushes (0.008 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 4
* autoland: 3

Platform breakdown:
* linux64: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-10-16&endday=2017-10-22&tree=all

Comment 20

4 months ago
10 failures in 912 pushes (0.011 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-inbound: 9
* autoland: 1

Platform breakdown:
* linux64: 9
* linux64-qr: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-10-23&endday=2017-10-29&tree=all

Comment 21

4 months ago
11 failures in 857 pushes (0.013 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 5
* mozilla-inbound: 3
* mozilla-central: 3

Platform breakdown:
* linux64: 11

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-10-30&endday=2017-11-05&tree=all

Comment 22

3 months ago
3 failures in 849 pushes (0.004 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 2
* mozilla-central: 1

Platform breakdown:
* linux64: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-11-06&endday=2017-11-12&tree=all

Comment 23

3 months ago
1 failures in 762 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 1

Platform breakdown:
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-11-13&endday=2017-11-19&tree=all

Comment 24

3 months ago
12 failures in 744 pushes (0.016 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 6
* mozilla-inbound: 4
* mozilla-beta: 1
* autoland: 1

Platform breakdown:
* linux64-ccov: 5
* linux64: 4
* linux32: 2
* linux64-devedition: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-11-20&endday=2017-11-26&tree=all

Comment 25

3 months ago
3 failures in 792 pushes (0.004 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 2
* mozilla-central: 1

Platform breakdown:
* linux32: 2
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-11-27&endday=2017-12-03&tree=all

Comment 26

2 months ago
3 failures in 423 pushes (0.007 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 3

Platform breakdown:
* linux64: 2
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-12-11&endday=2017-12-17&tree=all

Comment 27

2 months ago
2 failures in 590 pushes (0.003 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* autoland: 2

Platform breakdown:
* linux64: 1
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2017-12-18&endday=2017-12-24&tree=all

Comment 28

2 months ago
1 failures in 462 pushes (0.002 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-beta: 1

Platform breakdown:
* linux64-devedition: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2018-01-01&endday=2018-01-07&tree=all

Comment 29

2 months ago
31 failures in 149 pushes (0.208 failures/push) were associated with this bug yesterday.    

Repository breakdown:
* autoland: 31

Platform breakdown:
* linux64: 21
* linux32: 9
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2018-01-09&endday=2018-01-09&tree=all
(Assignee)

Comment 30

2 months ago
The increase of failures yesterday is due to the landing of my patch on bug 1403923. A follow-up should hopefully land soon, which then will also fix this bug.

Why do we fail here? It's because the test exceeds the 25s default timeout for opt builds, and takes even way longer for debug builds. Via bug 1403923 the test requests a long timeout now.

[task 2017-12-19T23:52:14.669Z] 23:52:14     INFO - TEST-UNEXPECTED-TIMEOUT | /webdriver/tests/state/get_element_attribute.py | expected OK
[task 2017-12-19T23:52:14.669Z] 23:52:14     INFO - TEST-INFO took 30013ms

[task 2017-12-19T18:31:14.574Z] 18:31:14     INFO - TEST-UNEXPECTED-TIMEOUT | /webdriver/tests/state/get_element_attribute.py | expected OK
[task 2017-12-19T18:31:14.574Z] 18:31:14     INFO - TEST-INFO took 80010ms
Depends on: 1403923
(Assignee)

Comment 31

2 months ago
This failure is gone now with the increased timeout via bug 1403923.
Assignee: nobody → hskupin
Status: NEW → RESOLVED
Last Resolved: 2 months ago
status-firefox59: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla59

Comment 32

2 months ago
39 failures in 152 pushes (0.257 failures/push) were associated with this bug yesterday.    

Repository breakdown:
* autoland: 20
* mozilla-inbound: 11
* try: 8

Platform breakdown:
* linux64: 24
* linux32: 11
* linux32-nightly: 2
* linux64-nightly: 1
* linux64-devedition: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2018-01-10&endday=2018-01-10&tree=all
status-firefox57: fix-optional → wontfix
status-firefox58: --- → fixed
status-firefox-esr52: --- → unaffected

Comment 33

a month ago
92 failures in 788 pushes (0.117 failures/push) were associated with this bug in the last 7 days. 

This is the #10 most frequent failure this week. 

** This failure happened more than 75 times this week! Resolving this bug is a very high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 1 week, the affected test(s) may be disabled. **   

Repository breakdown:
* autoland: 57
* try: 17
* mozilla-inbound: 13
* mozilla-central: 5

Platform breakdown:
* linux64: 54
* linux32: 32
* linux32-nightly: 3
* windows7-32: 1
* linux64-nightly: 1
* linux64-devedition: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2018-01-08&endday=2018-01-14&tree=all
Depends on: 1431058
(Assignee)

Updated

a month ago
No longer depends on: 1431058

Comment 34

21 days ago
1 failures in 735 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-inbound: 1

Platform breakdown:
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1393051&startday=2018-01-29&endday=2018-02-04&tree=all
You need to log in before you can comment on or make changes to this bug.