Closed Bug 1402577 Opened 2 years ago Closed 2 years ago

Title bar text is not visible on macOS

Categories

(Core :: Widget: Cocoa, defect)

All
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 + fixed
firefox58 --- fixed

People

(Reporter: dani, Assigned: spohl)

References

Details

(Keywords: nightly-community)

Attachments

(2 files)

Attached image FirefoxWindow.png
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20170922220129

Steps to reproduce:

Open a regular Firefox Nightly session with the browser configured to display the title bar.


Actual results:

The title bar is visible but there is no text on it.


Expected results:

The title bar text is visible and displays the title for the current tab.
Duplicate of this bug: 1402576
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
Attached patch PatchSplinter Review
Thanks for reporting and it was immediately clear what's going on here. This mistake was left over from the previously, only intermittently working patch in bug 1398582 (attachment 8908650 [details] [diff] [review]). Switching between showing and hiding the native title bar works because setDrawsContentsIntoWindowFrame: is called every time. However, if a profile is set to display the native title bar and Firefox is restarted, we don't get an initial call to setDrawsContentsIntoWindowFrame:. Therefore, we should default to showing titles and titlebars and hide them as soon as we get a setDrawsContentsIntoWindowFrame: call.
Assignee: nobody → spohl.mozilla.bugs
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8911524 - Flags: review?(mstange)
Blocks: 1398582, 1401297
OS: Unspecified → Mac OS X
Hardware: Unspecified → All
Attachment #8911524 - Flags: review?(mstange) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/f55d4f566a2d93202e55983fa6ccffa469628f5b
Bug 1402577: Display titles in titlebar on macOS when the native titlebar is in use. r=mstange
let's uplift this to beta once verified in nightly.
https://hg.mozilla.org/mozilla-central/rev/f55d4f566a2d
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Comment on attachment 8911524 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1398582
[User impact if declined]: Window titles don't display when users have native title bars enabled on macOS.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Isolated, well understood change.
[String changes made/needed]:
Attachment #8911524 - Flags: approval-mozilla-beta?
(In reply to Stephen A Pohl [:spohl] from comment #6)
> [String changes made/needed]:

This should have been "none".
Comment on attachment 8911524 [details] [diff] [review]
Patch

Fix a visual glitch.
Taking it, should be in 57b4
Attachment #8911524 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
No longer blocks: 1404036
You need to log in before you can comment on or make changes to this bug.