[meta][10.13] Serious rendering issues in the browser chrome when building with the 10.11 SDK and running on 10.13

RESOLVED FIXED

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mstange, Assigned: mstange)

Tracking

({regression})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed, firefox58 fixed)

Details

Attachments

(1 obsolete attachment)

There are a number of issues with the browser chrome when running Firefox on the current macOS 10.13 Beta and building with the 10.11 SDK:
 - There's a window title overlaid on top of our rendering in the area where you'd expect the window title if there was a titlebar.
 - Vibrant areas of the window are empty, e.g. the tab bar and the sidebar. The vibrant background blocks out all of our own rendering.
 - The top corners of the window have empty squares instead of just being rounded.

I don't think we can switch to the 10.11 SDK until we've fixed this.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Keywords: regression
Let's use bug 1398582 for just the titlebar issue. All three issues may end up being fixed by the same changes, but that's not clear at this point.
Depends on: 1398582
Priority: -- → P1
Depends on: 1400057
Making this a meta bug to track fallout in macOS 10.13 from the switch to the 10.11 SDK.
Summary: [10.13] Serious rendering issues in the browser chrome when building with the 10.11 SDK and running on 10.13 → [meta][10.13] Serious rendering issues in the browser chrome when building with the 10.11 SDK and running on 10.13
Depends on: 1402054
Depends on: 1399542
Depends on: 1401957
Depends on: 1401297
High Sierra was released today, and at least a few of these problems are present with today's nightly on High Sierra.
Posted image screenshot of tab bar when focused (obsolete) —
Note that the screenshot captures does not match my actual screen, since the tab bar has gone from black to white. I'm not sure what causes that. But you can see the weird object in the tab bar (on my screen it appears greenish) and the pixelated rounded corners.
(In reply to Jack Moffitt [:jack] from comment #4)
> Created attachment 8911969 [details]
> screenshot of tab bar when focused
> 
> Note that the screenshot captures does not match my actual screen, since the
> tab bar has gone from black to white. I'm not sure what causes that. But you
> can see the weird object in the tab bar (on my screen it appears greenish)
> and the pixelated rounded corners.

Thanks. This bug is a meta bug, used to track various issues. The problem you've reported is covered by the dependent bugs.
Depends on: 1402501
Duplicate of this bug: 1403112
Duplicate of this bug: 1402993
Duplicate of this bug: 1402980
Attachment #8911969 - Attachment is obsolete: true
Depends on: 1403562
Depends on: 1402577
Depends on: 1404036
Duplicate of this bug: 1404109
The patch in bug 1400057 fixed this.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.