[Regression] Findbar button labels are unreadable with the dark theme

VERIFIED FIXED in Firefox 57

Status

()

P1
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: nhnt11, Assigned: nhnt11)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 58
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 verified, firefox58 verified)

Details

(Whiteboard: [reserve-photon-visual] )

Attachments

(1 attachment)

(Assignee)

Description

a year ago
Seems like bug 1387762 was supposed to fix this, but it regressed at some point. I'm investigating.
Flags: qe-verify?

Updated

a year ago
Duplicate of this bug: 1402326

Comment 2

a year ago
(In reply to Ashish Vijayaram [:ashish] from bug 1402326 comment #0)
> Created attachment 8911180 [details]
> dark-theme-find-bar
> 
> Attached a screenshot from macOS 10.12.6 Nightly 58.0a1 20170922100051.
> 
> mozregression narrowed it down likely to Bug 1399498:
> 
> > 12:47.75 INFO: Narrowed inbound regression window from [0a26b0e8, 1d37fb0f] (3 builds) to [0a26b0e8, ab1e0e06] (2 builds) (~1 steps left)
> > 12:47.75 INFO: No more inbound revisions, bisection finished.
> > 12:47.75 INFO: Last good revision: 0a26b0e8ffeb6a26e0c2149091a6942e6920fb58
> > 12:47.75 INFO: First bad revision: ab1e0e06445226d0cadf3a1f12fac576c770584d
> > 12:47.75 INFO: Pushlog: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=0a26b0e8ffeb6a26e0c2149091a6942e6920fb58&tochange=ab1e0e06445226d0cadf3a1f12fac576c770584d
Blocks: 1399498
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED

Comment 3

a year ago
Uh, I don't understand why this got resolved. I certainly didn't intend that - I just wanted to comment. :-\
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → ASSIGNED
Duplicate of this bug: 1402855
Nihanth, considering that I introduced this regression, I just wanted to offer taking this bug in case you don't have time to work on it. In case you want to fix this, it shouldn't be hard to do, you probably just need to trace the change that started in https://bugzilla.mozilla.org/show_bug.cgi?id=1399498#c19 and restore the correct rules I removed.

Thanks!

Updated

a year ago
Duplicate of this bug: 1402698
Flags: qe-verify? → qe-verify+
QA Contact: ovidiu.boca
Comment hidden (mozreview-request)

Comment 8

a year ago
mozreview-review
Comment on attachment 8912667 [details]
Bug 1402614 - Ensure findbar buttons inherit foreground color.

https://reviewboard.mozilla.org/r/183998/#review189396

Ah, very observant! I think that works.
Attachment #8912667 - Flags: review?(jhofmann) → review+
Are you going to land this? :)
Flags: needinfo?(nhnt11)
(Assignee)

Updated

a year ago
Flags: needinfo?(nhnt11)

Comment 10

a year ago
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e7027c5f0cb2
Ensure findbar buttons inherit foreground color. r=johannh
(Assignee)

Comment 11

a year ago
Comment on attachment 8912667 [details]
Bug 1402614 - Ensure findbar buttons inherit foreground color.

Approval Request Comment
[Feature/Bug causing the regression]: 1399498
[User impact if declined]: Button labels in findbar are unreadable
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: Sets the color correctly, minor CSS change
[String changes made/needed]: none
Attachment #8912667 - Flags: approval-mozilla-beta?

Comment 12

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e7027c5f0cb2
Status: ASSIGNED → RESOLVED
Last Resolved: a year agoa year ago
status-firefox58: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
status-firefox57: --- → affected
I verified this issue using Nightly 58.0a1 with Build ID 20171001220301 on Windows 7 x32, Windows 10 x64, Ubuntu 16.04, Mac OS x 10.12.
I will mark this as verified fixed.
status-firefox58: fixed → verified
Status: RESOLVED → VERIFIED
status-firefox57: affected → unaffected
Comment on attachment 8912667 [details]
Bug 1402614 - Ensure findbar buttons inherit foreground color.

Polish photon, taking it.
Should be in 57b5
Attachment #8912667 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
status-firefox57: unaffected → fixed
I have reproduced this issue on an affected Nightly build from 2017-09-23.

This is also verified fixed on 57.0b6 (20171005195903) across platforms:
- Windows 10 x64
- Mac OS X 10.11
- Ubuntu 16.04 x64
status-firefox57: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.