Considering a new Thunderbird icon on par with Firefox’s new one

RESOLVED FIXED in Thunderbird 61.0

Status

enhancement
RESOLVED FIXED
2 years ago
3 months ago

People

(Reporter: nicolas, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 61.0

Thunderbird Tracking Flags

(thunderbird60 fixed, thunderbird61 fixed)

Details

Attachments

(20 attachments, 1 obsolete attachment)

1.45 MB, image/png
Details
258.46 KB, image/png
Details
2.66 MB, application/illustrator
Details
940.44 KB, image/jpeg
Details
360.52 KB, image/jpeg
Details
216.37 KB, image/jpeg
Details
327.88 KB, image/jpeg
Details
137.80 KB, image/jpeg
Details
53.58 KB, application/x-zip-compressed
Details
36.76 KB, image/png
Details
2.11 MB, patch
jorgk
: review+
Details | Diff | Splinter Review
1018.96 KB, application/zip
Details
180.76 KB, image/png
Details
121.58 KB, image/x-icon
Details
135.34 KB, image/png
Details
61.48 KB, patch
jorgk
: review+
Details | Diff | Splinter Review
15.17 KB, image/svg+xml
Details
35.31 KB, image/png
Details
40.84 KB, image/x-icon
Details
47.23 KB, patch
jorgk
: review+
Details | Diff | Splinter Review
(Reporter)

Description

2 years ago
I like to think of Thunderbird as Firefox’s little sibling, and their icons historically get along well side to side together in an app launcher.

Firefox is introducing a new icon in v57 though, with a far more minimal style and brighter colours, which make Thunderbird sad and complicated in comparison.

So this is a space to think about a new icon for Thunderbird (if there’s no discussion already).
(Reporter)

Comment 2

2 years ago
Posted image Draft Iteration 1
(Reporter)

Comment 3

2 years ago
(Reporter)

Comment 4

2 years ago
I’m attaching a first draft, a quick try on where a new icon could be directed towards. The blue and dark purple shades come from Firefox’s new globe, and the number of elements is reduced considerably.

It’s just a first iteration though, there’s a million things to do to make this into a working icon:

— The feathers here are basically the original ones with some clumsy adjustments and gradients applied to them. Without shading they look off, and are still too complex to be on par with Firefox’s elegant tail. I think they have to be redrawn entirely in a more thoughtful way, which will also have the benefit to clean up the vectors which are a mess. 
— The level of detail in the head is still too high.
— The envelope should probably not use lines, the different folds could be done just with surfaces with offset gradients.
— All the gradients and colours have to be tweaked and tweaked again.
— It’s not working at small sizes as such, there’s some shaping, contrast and volume work to do in order to make it legible.
— etc.

Comment 5

2 years ago
Very interesting. Let me publish this a little wider.
Flags: needinfo?(richard.marti)

Comment 6

2 years ago
The new Firefox logo is awful, but the simplified TB is not as bad. It does not need any more dumbification.
(Assignee)

Comment 7

2 years ago
The new icon looks already good. I think the feathers are looking good now. Yes the letter could maybe be simplified by using different shades instead of the lines.

Let's wait to see how your next iteration would look.
Flags: needinfo?(richard.marti)

Comment 8

2 years ago
I like the draft, but I definitely wouldn't remove even more details as in this first draft.

Comment 9

2 years ago
I like the idea of a new icon to delineate the arrival of a major new feature,  such as webextensions  or perhaps in 59 as most add-ons will not make it without work.
If this doesn't belong in Theme, please move to general for a wider audience.
Component: Untriaged → Theme

Comment 12

a year ago
I think this looks amazing nicolas! Amazing, in fact. I think that we should move to adopt this. Are you in the IRC nicolas?

Updated

a year ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 13

a year ago
Nicolas, had you time to work on your very promising wip? It would be great if we could get a working icon for the next ESR release.
Flags: needinfo?(nicolas)
Ryan, and Richard...
heads up - if any logo/icon changes are going to happen for version 60 in-product, and on the website and start page, it will need to move soon so that it can be approved by Council and MoFo.  (because of branding implications)
Flags: needinfo?(ryan)

Comment 15

a year ago
Yeah, elio has also proposed a new icon as well, I've sent him a message to ask him to post here. Hopefully he can pop it in here today or tomorrow and we can discuss. I think getting it in for 60 would be good for branding, especially given that we did the "Proton" changes as well (as Firefox). You can see his proposed icon/logo in this mockup on the Thunderbird website's git repo: https://user-images.githubusercontent.com/5436686/38329584-86639736-384e-11e8-97d5-60c5601006b5.png
Flags: needinfo?(ryan)
Hi there,

Thanks for pointing me to this bug, I was not aware of it before. Nicolas, thanks for initiating this! Your drafts look really solid!

Over 7 months ago or so I was doing the same thing with the logo in fact, Good to see that there is more momentum around that.
As Ryan said, you can see it in the mockups above. But I really liked the color choice of Nicolas so I did a similar treatment to the version I created. You can find it here (where you can also comment on various spots of the image:

https://presentator.ura.design/en/0Lv7dIbK

>The new Firefox logo is awful, but the simplified TB is not as bad. It does not need any more dumbification.

Let's not go on this level as this feedback is not useful and more damaging than constructive.

Also, some things I wanted to mention:

- The shape behind the eye gives the bird a more natural shape, so it needs to get right, otherwise the eye looks kinda creepy and wide open. I had that problem too as that shape had gaussian blur applied which doesn't render as SVG. So I removed that and it looks fine I'd say (I see Nicolas did the same thing).

- I'd rather suggest leaving the envelope in white, as the current Thunderbird logo.

- Having the bird's shadow on the envelope is a little skeuomoprhistic, so removing it to make the envelope clearer would be beneficial for the logo, especially on smaller sizes.

- In the corner of the image you can see an updated Thunderbird wordmark which is in the same style as the new Firefox wordmark (Fira Sans). I'd suggest to adapt it regardless of the choice for the logo mark.

These are my 5 cents. We are doing a Usability Study and Styleguide for Thunderbird in the coming months, so it would be great to have the new logo be part of this. I'd be happy to jump into a meeting if you would like that.
(Assignee)

Comment 18

a year ago
Many thanks, Elio! Would it be possible to make the blue a little bit less bright? And what do you think about adding a darker line on the bottom of the letter to better separate the letter when the icon is on a white background?

With this two questions considered, I think this icon could be ready for production.

Comment 19

a year ago
Which version will we be using? Elio 1 or 2? I like Elio 2 better. In Nicholas' draft the head and the eyes look fiercer and the bird has more feathers.
(Assignee)

Comment 20

a year ago
My comment 18 was for Elio 2 on which we should focus.
Thanks for the feedback! I just updated it according to the comments. They colors are a bit more muted now, yet still brighter than in the current Thunderbird logo. If you are happy with this direction, I can clean the illustration up and make sure it works as SVG as well (the current Thunderbird logo is not SVG friendly). 

The screen is added on the link I shared (Elio 3)
https://presentator.ura.design/en/0Lv7dIbK
Added a 4th version with body shadow on the envelop, which is more subtle than in the current Thunderbird logo due to its different angle as well. Let me know which you prefer
(Assignee)

Comment 25

a year ago
I think version 4 is good for bigger icons. But for small icons I think we should use the one without shadow to not get blurry edges. If this doesn't happen, then it's naturally not needed. :)
It should be fine. The new Firefox Quantum logo has a similar shadow behind the fox body as well.

The logo mark should be the same for everything, no matter what size.

Comment 27

a year ago
Maybe consider using the eye of Nicolas' version? I like that it's a bit brighter than the origial eye.

Comment 28

a year ago
+1. It looks fiercer, see my comment #19.

Comment 29

a year ago
I've looked at this quite a lot, I actually prefer the logo without the shadow. Other than that, I'm very on board.
I agree with that. Should we move forward with it Ryan?

Comment 31

a year ago
Would like to know if there has been any process to this in the past when making final decisions. @jorg @paenglab - could you let me know? What do we need to do to move on this?
Flags: needinfo?(richard.marti)
Flags: needinfo?(jorgk)
Comment hidden (obsolete)
(Assignee)

Comment 33

a year ago
We need either a patch with all images/icons of https://dxr.mozilla.org/comm-central/source/mail/branding/thunderbird changed to the new one, or the images/icons are attached here and I can create a patch. It would be good if we could, after the landing, do a beta build to check the icons are correctly exchanged while updating.

Elio, could you create this images?
Flags: needinfo?(richard.marti)
(In reply to Ryan Sipes from comment #31)
> Would like to know if there has been any process to this in the past when
> making final decisions. 

I believe Philipp and Kohei(NI) have been involved in past efforts. From what I can glean from the most recent efforts - bug 729064 and bug 1196942 - after our UX signoff it must have Mozilla legal signoff because they own the brand. (comment 14 and I think it's also been stated in council communications)  

Whether the council (as a group) wants to be included in signoff hasn't been decided afaik.
Flags: needinfo?(kohei.yoshino)
As the Council is the controlling body of Thunderbird, I am certain that anything related to branding needs to be approved by the Council. In addition, as already mentioned, there needs to be a legal review from Mozilla as they hold the trademarks.
>How about making the eyes a little fiercer?

"Fiercer" doesn't really mean anything. As what you understand as fierce I might understand differently. The eye is the same from the old logo as I don't think I'm that great at anatomy to do such big changes and I don't think that would be part of a refresh, rather than a rebrand.

@Richard: I'd be happy to create the images once there is signoff from the Council and later a review from legal. I tweaked the logo a bit yesterday to improve for appearance. You can find it here: https://presentator.ura.design/en/0Lv7dIbK
(Assignee)

Comment 37

a year ago
Elio 5 looks better without the dark line between the letter and the wing on the right and the implied shadow on the left. Thumbs up:

(In reply to Elio Qoshi  [:Elio] from comment #36)
> >How about making the eyes a little fiercer?
> 
> "Fiercer" doesn't really mean anything. As what you understand as fierce I
> might understand differently. The eye is the same from the old logo as I
> don't think I'm that great at anatomy to do such big changes and I don't
> think that would be part of a refresh, rather than a rebrand.

Maybe you could try to make shadow (or the lid?) above the eye a bit darker. That could make it a bit "fiercer".

Philipp, what do you need for the Council signoff and legal review? Would something like https://presentator.ura.design/en/0Lv7dIbK page 4 (Elio 5) be enough?
Flags: needinfo?(philipp)

Comment 38

a year ago
What I mean is: Make the eye colour a little lighter, as in attachment 8914002 [details] or attachment 8914003 [details].
We evolved past nicolas' initial proposal, and other questions have been answered, so clearing NI
Flags: needinfo?(philipp)
Flags: needinfo?(nicolas)
Flags: needinfo?(kohei.yoshino)
Summary: Considering a new icon on par with Firefox’s new one → Considering a new Thunderbird icon on par with Firefox’s new one
(Assignee)

Comment 40

a year ago
Philipp's n-i was for the: "what do you need for the Council signoff and legal review? Would something like https://presentator.ura.design/en/0Lv7dIbK page 4 (Elio 5) be enough?" Setting it again.
Flags: needinfo?(philipp)
I think the steps would be:

1) Everyone already involved here agrees on a preliminary version for proposal
2) Once consensus has been reached, council is notified for final feedback (which may be just rubberstamping if we are happy)
3) Council gets in touch with MoFo to determine who will do legal/brand review
4) We needinfo those people on this bug, and they approve.
5) Council considers approval final or takes action if there are comments from the legal/brand review.

Given there have been 40+ comments on this bug we might file a new bug just for the legal review, but the council will take care of that. A one pager with the logo and all possible variations we'd use (beta, etc) should be sufficient for the review, we can provider further info if needed.
Flags: needinfo?(philipp)

Comment 42

a year ago
Posted image elio5.jpg
What do you think of this Jorg? The eyes appear to be lighter.
Flags: needinfo?(jorgk)

Comment 43

a year ago
Yes. This is nice. Can we get this rolling? I think we need to get the new image approved as per comment #41 and then Richard will prepare a patch as per comment #33.
Flags: needinfo?(jorgk)

Comment 44

a year ago
Looks good to me too. Can the white envelope cause problems (low contrast/distinguishing) on white background as seen in the image?
Posted image 10-01.jpg
Attached a version with slightly fixed feathers. More contrast on the envelope outline (to be even more recognizable on white background) and slightly brighter eyes.

I am happy with this progress as of now.
nice.
Posted file defaultsizes.zip
Here is the icon in the appropriate sizes. Let me know if these are okay.

Comment 48

a year ago
Paenglab, can you verify this is good? ^
Flags: needinfo?(richard.marti)
(Assignee)

Comment 49

a year ago
Already began with the patch. I'm in contact with Elio because I need more icons for Mac.

Ryan could you check with the counsel that this version is okay to go further? Not that we create the patch and then it's been denied.
Flags: needinfo?(richard.marti)

Comment 50

a year ago
I have raised this, working through discussion (currently no dissenting voices). Vote to finalize this coming (hopefully before the end of the week).

Comment 51

a year ago
Approved, reaching out to MoFo to finalize.
(Assignee)

Comment 52

a year ago
Posted patch WIP TB-icon.patch (obsolete) — Splinter Review
This is a WIP patch. The Mac icons are missing. All other are complete. Feedback welcome.
(Assignee)

Comment 53

a year ago
This is the about dialog made with the Daily to show how it looks.

Comment 54

a year ago
This looks quite good IMO.
Please do not forget to add a "symbolic" variant to be used in the GNOME panel.

Information on symbolic icons:
https://developer.gnome.org/hig/stable/icons-and-artwork.html.en
https://developer.gnome.org/ThemedIcons/

Examples:
https://github.com/GNOME/gnome-icon-theme-symbolic
(Assignee)

Comment 57

a year ago
Posted patch TB-icon.patchSplinter Review
This is the final patch with all icons exchanged.

I removed the about-background.png because this is not used on Thunderbird (the image is from Firefox Nightly).

I added Jörg, Magnus and Philipp as reviewer as the representatives of the Counsil. I would be also okay with only one r+.
Assignee: nobody → richard.marti
Attachment #8972400 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8972669 - Flags: review?(philipp)
Attachment #8972669 - Flags: review?(mkmelin+mozilla)
Attachment #8972669 - Flags: review?(jorgk)

Comment 59

a year ago
Comment on attachment 8972669 [details] [diff] [review]
TB-icon.patch

I've looked through all the images and they all look fine. I don't know when we're going to get legal approval.
Attachment #8972669 - Flags: review?(jorgk) → review+

Comment 60

a year ago
We can move forward incorporating these now. Interestingly enough, the new logo must be in use for us to trademark it.

Comment 61

a year ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/129a1bd94b34
Update the Thunderbird icon. r=Thunderbird Council DONTBUILD
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED

Updated

a year ago
Target Milestone: --- → Thunderbird 61.0

Comment 63

a year ago
(In reply to nicolas m from comment #0)
> I like to think of Thunderbird as Firefox’s little sibling, and their icons
> historically get along well side to side together in an app launcher.
> 
> Firefox is introducing a new icon in v57 though, with a far more minimal
> style and brighter colours, which make Thunderbird sad and complicated in
> comparison.
> 
> So this is a space to think about a new icon for Thunderbird (if there’s no
> discussion already).

any plans to also work on a refresh for the Thunderbird Daily logo?

Comment 64

a year ago
The new Icon looks really ugly on dark backgrounds. There seem to be white pixels instead of transparent pixels on the outside.

Comment 66

a year ago
Strange, I'm looking at the images and there are no white pixels on the circumflex.
(Assignee)

Comment 67

a year ago
Alex, what screen depth do you use (8bit, 16bit, 24bit)? The low depth icons do have this whit pixels.
(Assignee)

Comment 68

a year ago
Posted image messengerWindow.ico
Alex, please could you try to exchange the messengerWindow.ico in your "TB beta directory"\chrome\icons\default with the one I attached here and check if the icon looks better? Maybe a refresh of the icon cache is needed.
Flags: needinfo?(AlexIhrig)

Comment 69

a year ago
We should roll this back out of the Beta, I was too hasty. Legal would like to review the changes, they know we'd like to get this out ASAP. Can we roll this change back?
Flags: needinfo?(richard.marti)
Flags: needinfo?(jorgk)
(Assignee)

Comment 70

a year ago
We can, but it's already in b6.

Jörg, do you do the back-out or do you want a patch?
Flags: needinfo?(richard.marti)

Comment 71

a year ago
TB 60 beta 6 has shipped. Maybe you should have been a bit more precise in comment #60: "We can move forward incorporating these now."

I see no point rolling anything back. Too late. If they dislike it, we can see what we will do.
Flags: needinfo?(jorgk)

Comment 72

a year ago
BTW, if you really need a new beta, talk to Wayne, he can build one from a changeset just below landing of the icons on beta. No backout required.
(In reply to Ryan Sipes from comment #69)
> We should roll this back out of the Beta, I was too hasty. Legal would like
> to review the changes, they know we'd like to get this out ASAP. Can we roll
> this change back?

You are in contact with someone at legal?

It is only in the beta, but if they are not OK with us shipping it unapproved in the beta we can build a new one (but I'd certainly prefer only tto go through that if we *absolutely* must)
Flags: needinfo?(ryan)

Comment 74

a year ago
This is the screenshot with the updated icon.

Screen depth should be 24 bit.
Flags: needinfo?(AlexIhrig)
(Assignee)

Comment 75

a year ago
Fixed icons (see comment 74).
Attachment #8973446 - Flags: review?(jorgk)

Comment 76

a year ago
Comment on attachment 8973446 [details] [diff] [review]
icon-fix.patch

Checked in GIMP and the bright pixels around the right and bottom edge are gone now.
Attachment #8973446 - Flags: review?(jorgk) → review+
(Assignee)

Updated

a year ago
Status: RESOLVED → REOPENED
Keywords: checkin-needed
Resolution: FIXED → ---

Comment 77

a year ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/7a9c437d31e2
Follow-up: Fix the light pixels on edges on the 8bit icons. r=jorgk
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

a year ago
Duplicate of this bug: 1459490

Comment 80

a year ago
Final say, we're all good on this. Sorry for the confusion.
Flags: needinfo?(ryan)
(Assignee)

Updated

a year ago
Duplicate of this bug: 1459650
(Assignee)

Comment 82

a year ago
Elio, do you have a SVG version of the icon? If yes, please could you add it to this bug?
Flags: needinfo?(ping)
I've filed an issue on github for this: https://github.com/thundernest/thunderbird-website/issues/37

We used to have a logo guidelines page, but it was removed recently. See https://web.archive.org/web/20180315075337/https://www.mozilla.org/en-US/styleguide/identity/thunderbird/logo/

Now that we have an updated logo, there should be an updated page on thunderbird.net.
Sadly the symbolic variant I mentioned in comment 56 is still missing.
(Assignee)

Comment 85

a year ago
(In reply to Michael Monreal [:micmon] from comment #84)
> Sadly the symbolic variant I mentioned in comment 56 is still missing.

In the FX bug about the symbolic variant is also not much activity. I'm waiting for the SVG, then I can hopefully do it.
SVG's are here:
https://demo.identihub.co/project/thunderbird

Attaching them here as well.

For symbolic icons, using a mail icon would make the most sense, right?
Flags: needinfo?(ping)
(Assignee)

Comment 87

a year ago
(In reply to Elio Qoshi  [:Elio] from comment #86)
> For symbolic icons, using a mail icon would make the most sense, right?

I think yes, a 32px icon should do it. Then also HiDPI should be sharp.
(In reply to Richard Marti (:Paenglab) from comment #87)
> (In reply to Elio Qoshi  [:Elio] from comment #86)
> > For symbolic icons, using a mail icon would make the most sense, right?
> 
> I think yes, a 32px icon should do it. Then also HiDPI should be sharp.

Symbolic icons in GNOME are SVG on a 16x16 pixel canvas. Ideally it should be more than just the mail envelope but considering the share of the TB icon this could be hard. For Firefox, it worked out just fine.

Comment 89

11 months ago
Comment on attachment 8972669 [details] [diff] [review]
TB-icon.patch

This has long been approved and shipped elsewhere.
Attachment #8972669 - Flags: review?(philipp)
Attachment #8972669 - Flags: review?(mkmelin+mozilla)

Comment 90

11 months ago
Posted image Zoomed up comparison
Elio, I noticed that the 32px icons used by Windows for the desktop and the taskbar aren't as good as the predecessors. Basically the eye isn't as clearly visible and I think it's lacking contrast. It's basically just like a blue blob on top of a white envelope where before you could see the eye and some structure in the feathers.

Richard modified the 32px icon to make the eye (which is only 2px by 2px big) a little brighter. I'll attach that in the next comment. I think there should be more contrast, too.

That raises the question: How did you create those small versions? From the SVG in attachment 8974937 [details]. Can we please fine-tune that a little?
Flags: needinfo?(ping)
(In reply to Jorg K (GMT+2) from comment #91)
> Created attachment 8982918 [details]
> messengerWindow.ico - Richard's attempt

This shows a little more detail and looks less fuzzy at the edges. Still, I'd like even a bit more detail.
(Assignee)

Comment 93

11 months ago
This patch makes the 16px and 32px icons a bit more contrasty. The bird's eye is for example a bit better visible. This sizes are mostly used on Linux and Windows.

The messengerWindow.ico has now, like FX, only the 32 bit icons.
Attachment #8984663 - Flags: review?(jorgk)
Attachment #8984663 - Flags: approval-comm-esr60?
Attachment #8984663 - Flags: approval-comm-beta?

Comment 94

11 months ago
Comment on attachment 8984663 [details] [diff] [review]
Bug1404648-contrast.patch

Thanks, I already had a private preview of these icons ;-)
Flags: needinfo?(ping)
Attachment #8984663 - Flags: review?(jorgk)
Attachment #8984663 - Flags: review+
Attachment #8984663 - Flags: approval-comm-esr60?
Attachment #8984663 - Flags: approval-comm-esr60+
Attachment #8984663 - Flags: approval-comm-beta?
Attachment #8984663 - Flags: approval-comm-beta+

Comment 95

11 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/918b82bdfd9c
Increase contrast of some of the new Thunderbird low resolution icons. r=jorgk

Comment 97

10 months ago
It probably might differ bit depending on how the PNG's are exported. The SVG shouldn't be changed however. Is this fixed?

Comment 98

10 months ago
We didn't touch the SVG, but we tweaked the PNG and ICO files a little.

Comment 99

10 months ago
Just wanted to update you that I also added a glyph version for monochrome usages of the icon:
https://demo.identihub.co/project/thunderbird
(Assignee)

Comment 100

10 months ago
Filed bug 1469213 for the 22x22, 24x24 and symbolic icons.

Comment 102

4 months ago
re :The new Firefox logo is awful, but the simplified TB is not as bad. It does not need any more dumbification.

I have some agreement with this statement.

The new icons are flat, childish and lack definition. They look unfinished; that's assuming the lack of definition really is part of the intended design. This type of 'look' is not going to be appreciated by everyone. It is like a tempoarary fad that  will not last. Classic quality looks have always lasted.

It would be much appreciated; probably by many in community, if the previous 'default theme' as used pre version 60 for general UI and logo, could be made available as as one the selectable 'default themes'.

Comment 103

4 months ago
Why do we hide critical comments with tag "advocacy"? Please don't.

Comment 104

3 months ago

I am honest and honesty should not be seen as a bad thing. My opinion was meant to be taken as a useful piece of critic to be taken on board. What purpose is served if you do not allow honest opinons when it comes to design. Not everyone will agree on everything, but it is useful to have some idea on how the target audience may react. Deliberately attempting to suppress important critic comments is not helpful to anyone.

As the new design is rolled out you will expect some people to like the new design, others will not and some will not have even noticed anything. Some people will not appreciate radical changes as it harder to adjust for a number of reasons.
A comment from the support forum:
https://support.mozilla.org/en-US/questions/1247027

Hi @Anje

I would not consider your comment very constructive and calling that "honest" is not helping as well.

The new icons are flat, childish

Classic quality looks have always lasted

You stating your opinion in a way which makes it sound ultimately the sole thing which is right, is not really an opinion anymore.

For the time being, Thunderbird is still part of Mozilla and is following the Photon Design System, similarly to Firefox. There are various reasons why the logos and icons are updated and this is mostly due to legibility and fidelity on very small sizes. adding more color contrast as well.

It would have been helpful to have a discussion on this level, rather than "it's childish" and blowing off steam here. If you'd like to pursue that, I'd gladly address any of your points.

Comment 106

3 months ago

(In reply to Elio Qoshi [:Elio] from comment #105)

this is mostly due to legibility and fidelity on very small sizes. adding more color contrast as well.

What small screen devices is Thunderbird designed to be installed on? There is a community version out there I understand that will run on a chrome book. However Thunderbird is still a desktop application. Most folk I would assume are on at least 15 inch laptops (Dell entry level appears around 15 inches) and most desktop users are playing in 20 or more inches.

For 10 years I have been seeing more and more design decisions based on the size of someones finger and the size of their iphone screen. All very good if you are using a small touch screen device and are developing applications designed to appeal to that market. Just as putting touch controls at the bottom of the screen on a phone makes sense, (even if it is not intuitive for those used to a desktop), doing such on a desktop is a seriously poor decision. Microsoft proved just how much of a mistake it is to build touch interfaces for non touch devices (Windows 8 anyone).

The reality is Thunderbird is a desktop application and if it survives the transition to Firefox becoming blindingly great will be for some time to come. While there might come a time when there is a version for these small screen devices Firefox is aiming for, some serious decisions are going to have to be made over memory requirements and storage space. You don't dump a +20Gb profile into a cheap phone and not expect trouble.

So lets talk design. We are mostly dealing with large screens in high resolution colour with slow drives where the users primary interface to the software is visual cues and a mouse. When my copy of Visual studio arrived with glyphs on the tool-bar I was unbelieving that they could conceive of it as a good Idea. Then I got to god awful Windows 10 apps. So it became clear to me that we had a new design fad in town. Flat ugly and difficult to describe, such is life.

Now in support we are trying to describe glyphs using words (no colours any more) So you have people talking about the "hamburger" icon and the Three horizontal lines.

Seriously we should be moving to something that is visually appealing and easy to navigate. Dare I say it Outlook appears to have something happening there. https://office-watch.com/2018/outlooks-new-simplified-ribbon/

So please lets not down on Anje for expressing her opinion, however unwelcome it was, and move on to designing an outstanding user interface for Thunderbird. If we have to follow the touch interface model, then we need more default choices in the themes than dark and light.

I am now talking through my hat, but it is my feeling that Thunderbirds user base contains a significant number of "silver surfers" so any design decisions need to take into account the realities of life as you age. New things become harder to learn, eyesight is failing and old habits die hard. So telling someone that they no longer use the green icon because we don't use colour now is an affront to their independence as they have extreme difficulty unlearning the icon is green.

Comment 107

3 months ago

Let's have the discussion about design concepts somewhere else. This bug is closed and we adopted a proposed icon/logo.

If we want to revisit changes to that, I think we should start the conversation on the design mailing list: https://thunderbird.topicbox.com/groups/ux

Or on Discourse: https://discourse.mozilla.org/c/thunderbird

You need to log in before you can comment on or make changes to this bug.