Closed Bug 1408461 Opened 4 years ago Closed 4 years ago

Update webrender to 7892f5364bc4d35c7a9b42949f0ace4cc54f8b3c

Categories

(Core :: Graphics: WebRender, defect, P1)

58 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 1 open bug)

Details

(Whiteboard: [wr-mvp])

Attachments

(8 files, 1 obsolete file)

59 bytes, text/x-review-board-request
jrmuizel
: review+
Details
59 bytes, text/x-review-board-request
jrmuizel
: review+
Details
59 bytes, text/x-review-board-request
kats
: review+
Details
59 bytes, text/x-review-board-request
Gankra
: review+
Details
59 bytes, text/x-review-board-request
jrmuizel
: review+
Details
59 bytes, text/x-review-board-request
Gankra
: review+
Details
59 bytes, text/x-review-board-request
jrmuizel
: review+
Details
59 bytes, text/x-review-board-request
Gankra
: review+
Details
+++ This bug was initially created as a clone of Bug #1407213 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
WR @ db3209e9343b483788b05341627c5dfc05481345

https://treeherder.mozilla.org/#/jobs?repo=try&revision=1ec9d3ce1bd24eb50625f4bab80ef5863868c807
https://treeherder.mozilla.org/#/jobs?repo=try&revision=2d0f3a65adf515099df1ef05cbc655cc1c75326a

Some reftest changes. The regression range here is

* db3209e9 Auto merge of #1822 - nical:aa-distance, r=kvark
* 8c429bef Update reference images.
* b87efa94 Tweak the aa constant factor.
* 2cad56d1 Share the antialiasing code between shaders.
* 92535457 Fix the math behind antialiasing in the shaders.

nical did say there would be reftest changes. Although all the changes look fuzzable, the one at box-shadow/boxshadow-large-border-radius.html in R3 is visibly different so we might want look at that closer.

Anyway I'll add a patch to my queue for these for now.
WR @ 9c6b79f29fc979536f1146fe4b645ed26f6f1c43

https://treeherder.mozilla.org/#/jobs?repo=try&revision=bbf9734f4fe3f5845ae6d6a398fe2dceb45b71e4
https://treeherder.mozilla.org/#/jobs?repo=try&revision=bd8cfb42e507003e61675eac1dfd8d13fbdefcd2

Some reftest changes. There are two unexpected-passes from #1873 (see bug 1407213 comment 16). There is also an unexpected-fail on transform-3d/preserve3d-6a.html and an unexpected-pass on transform-3d/split-intersect1.html. Regression range for these is:

*   9c6b79f2 Auto merge of #1873 - Gankro:proper-aa, r=kvark
|\
| * 621ffdde Add reftest for aa clamping of transparent text
| * fd80c82f Fix aa clamping for transparent text
* fbe01b2e Auto merge of #1869 - mephisto41:fix-plane-split-precision, r=kvark
* 00e5a3c7 Add reftest.
* 949933da Using f64 to calculate plane splitting to prevent precision error.

So probably #1869.
WR @ 0b52dd7363a7c290718a506e6a5e6db2571db63c

https://treeherder.mozilla.org/#/jobs?repo=try&revision=a56e04a95152d1999f0bc4d649c13ed5f1188746
https://treeherder.mozilla.org/#/jobs?repo=try&revision=4b1354331d3dadbacd8ce2fbd954bb6ddd653e76

Same as before.

Note also that the unexpected-fail I mentioned in the last comment is just off by one pixel, so I'll fuzz it.
Here are the reftest changes corresponding to the aa work in webrender.
Comment on attachment 8918799 [details] [diff] [review]
Update the reftest fuzziness values

Review of attachment 8918799 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/reftests/css-break/reftest.list
@@ +1,5 @@
>  default-preferences pref(layout.css.box-decoration-break.enabled,true)
>  
>  == box-decoration-break-1.html box-decoration-break-1-ref.html
>  fuzzy(1,20) fuzzy-if(skiaContent,1,700) fuzzy-if(webrender,8-8,242-242) == box-decoration-break-with-inset-box-shadow-1.html box-decoration-break-with-inset-box-shadow-1-ref.html
> +fuzzy(45,460) fuzzy-if(skiaContent,57,439) fuzzy-if(Android,57,1330) fuzzy-if(styloVsGecko,45,1410) fuzzy-if(webrender,7,316) == box-decoration-break-with-outset-box-shadow-1.html box-decoration-break-with-outset-box-shadow-1-ref.html # Bug 1386543

I'm going to change this to be a precise range (7-7,316-316) instead. Same for the one in transform-3d.
WR @ 47b016ac665231361a924598161a04cfeb710a96

https://treeherder.mozilla.org/#/jobs?repo=try&revision=8a58315c658d84bd5157dd1c60bda84e7c6ade29
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ad66834ceba44dfc203a5314a2e7a19c26a0a474

Green

WR @ 48406ed94466bd412e6a8efc24a90a6c5e2028a0

Busted, cbindgen won't run on it. Regression range:

*   48406ed9 (HEAD -> master, origin/master, origin/auto, origin/HEAD) Auto merge of #1886 - glennw:subpx-alpha-fade, r=nical
|\
| * 60e8027e Fix alpha fading on subpixel text. Allow subpx with alpha.
|/
* 5e30fb41 Auto merge of #1861 - kvark:query, r=glennw
* e7dda138 Query feature

Given that cbindgen barfs at a #[cfg(feature = "query")] token, presumably this is from servo/webrender#1861.
This is the top of the cbindgen output (which I truncated)

ERROR: Parsing crate `webrender`:
unparsed tokens after crate: "#[cfg(feature = \"query\")]\nimpl<T> GpuProfiler<T> {\n    pub fn new(gl: &Rc<gl::Gl>) -> Self {\n        GpuProfiler {\n            next_frame: 0,\n            frames: [\n                GpuFrameProfile::new(Rc::clone(gl)),\n                GpuFrameProfile::new(

The tokens it's complaining about is about a third of the way into device.rs, and there are other similar cfg statements previous to that so I'm not sure why it would complain about this one specifically.
Ah, the problem seems to be the cfg statements inside the body of the functions (add_marker, add_sampler, done_sampler). If I comment out those statements it works. It's not clear to me why those statements are needed, since the entire impl is wrapped inside the cfg anyway.
Blocks: 1403333
Blocks: 1408780
Blocks: 1370839
WR @ a9e7ec793de7248569163dfb5521ccdbca52fe8a

https://treeherder.mozilla.org/#/jobs?repo=try&revision=2e33837af5fcbafe277ac73b35973dae3dfb987a
https://treeherder.mozilla.org/#/jobs?repo=try&revision=e1d97f1c7e23c29455dd48dce690c9fbeffb8011

Some reftest differences. Regression range:

*   a9e7ec79 Auto merge of #1883 - nical:update-pipeline, r=kvark
|\
| * 62447245 Allow resource updates to affect pipeline epochs.
* 6a7b5381 Auto merge of #1841 - glennw:brush-bs-6, r=kvark
* 5c3b489e Switch box-shadows to use brush masks (and add basic brush prim).

I'll update the reftest expectations per the discussion in #1841.
WR @ 7892f5364bc4d35c7a9b42949f0ace4cc54f8b3c

https://treeherder.mozilla.org/#/jobs?repo=try&revision=1db734c40ba4b239e989fd381216801c23247d6f
https://treeherder.mozilla.org/#/jobs?repo=try&revision=360c65f962398da8eb9cb51d1e6f05104efa20ca

Same as before, plus one more UNEXPECTED-PASS for bugs/660682-1.html. Range:

* 7892f536 Auto merge of #1888 - staktrace:ci, r=kvark
* 7857403f Update the TaskCluster debug commands to match travis.yml
* 642350ea Fix debug <-> release commands on TaskCluster OS X builders
* f21f4231 Update webrender CI to 1.21.0 to match gecko as of bug 1408215.

... these are all unrelated, what actually happened was that mattwoodrow marked this test failing in m-c but it's fixed by Gankro's AA patches from #1873 (there was some mention of this on IRC yesterday). I'll mark it passing again as part of the #1873 reftest updates.
Alias: wr-future-update
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to 7892f5364bc4d35c7a9b42949f0ace4cc54f8b3c
Version: unspecified → 58 Branch
Comment on attachment 8918799 [details] [diff] [review]
Update the reftest fuzziness values

Obsoleting this as it will go into the mozreview
Attachment #8918799 - Attachment is obsolete: true
Comment on attachment 8919720 [details]
Bug 1408461 - Update webrender to commit 7892f5364bc4d35c7a9b42949f0ace4cc54f8b3c.

https://reviewboard.mozilla.org/r/190654/#review195866
Attachment #8919720 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8919721 [details]
Bug 1408461 - Update Cargo lockfiles and re-vendor rust dependencies.

https://reviewboard.mozilla.org/r/190656/#review195868
Attachment #8919721 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8919724 [details]
Bug 1408461 - Update reftest results for changes in WR PR 1869.

https://reviewboard.mozilla.org/r/190662/#review195870
Attachment #8919724 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8919726 [details]
Bug 1408461 - Update reftest results and regenerate bindings for changes in WR PR 1841.

https://reviewboard.mozilla.org/r/190666/#review195872
Attachment #8919726 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8919723 [details]
Bug 1408461 - Update reftest results for changes in WR PR 1873.

https://reviewboard.mozilla.org/r/190660/#review195874
Comment on attachment 8919723 [details]
Bug 1408461 - Update reftest results for changes in WR PR 1873.

https://reviewboard.mozilla.org/r/190660/#review195876
Attachment #8919723 - Flags: review?(a.beingessner) → review+
Comment on attachment 8919725 [details]
Bug 1408461 - Update reftest results for changes in WR PR 1868.

https://reviewboard.mozilla.org/r/190664/#review195878
Attachment #8919725 - Flags: review?(a.beingessner) → review+
Comment on attachment 8919722 [details]
Bug 1408461 - Update reftest results for changes in WR PR 1822.

https://reviewboard.mozilla.org/r/190658/#review195882
Attachment #8919722 - Flags: review?(bugmail) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dd8eb671df75
Update webrender to commit 7892f5364bc4d35c7a9b42949f0ace4cc54f8b3c. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/c654a712755b
Update Cargo lockfiles and re-vendor rust dependencies. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/cd0e3778a5ba
Update reftest results for changes in WR PR 1822. r=kats
https://hg.mozilla.org/integration/autoland/rev/d9818c8042f4
Update reftest results for changes in WR PR 1873. r=Gankro
https://hg.mozilla.org/integration/autoland/rev/d1a2ea63196c
Update reftest results for changes in WR PR 1869. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/b3d8a0eb09e6
Update reftest results for changes in WR PR 1868. r=Gankro
https://hg.mozilla.org/integration/autoland/rev/882e0b30bc0e
Update reftest results and regenerate bindings for changes in WR PR 1841. r=jrmuizel
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: [gfx-noted] → [wr-mvp]
Backed out for failing reftests border-dotted/border-dotted-interaction.html and border-radius/curved-stripe-border.html on Linux QuantumRender:

https://hg.mozilla.org/integration/autoland/rev/2fe4b5ce14d5c5f7d85ed4312b2312f3fa13adc0
https://hg.mozilla.org/integration/autoland/rev/34685b6d5efaea92c35e17b9805ed9603b06c12f
https://hg.mozilla.org/integration/autoland/rev/14773de4ee986f55b2b410decf0829c3b261507b
https://hg.mozilla.org/integration/autoland/rev/45b0ed388e067029c5872f5a42d1306904feae0d
https://hg.mozilla.org/integration/autoland/rev/7e4c733298cefab8b632b175ccd3d3312e9990ee
https://hg.mozilla.org/integration/autoland/rev/da91aa76c4d75db0a83a1a7612fc669e60ee4101
https://hg.mozilla.org/integration/autoland/rev/501c477652d835e5fc188078ff9856cb3623b953

This is fallout from https://hg.mozilla.org/integration/autoland/rev/27029757c81b6a946c5c29f1b01016925b773314 / bug 1396491.

Push with failure: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=882e0b30bc0eaed2d78bee279e51b67e6ee6bbbf&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=usercancel&filter-resultStatus=runnable
Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=137894705&repo=autoland

 REFTEST TEST-UNEXPECTED-PASS | file:///builds/worker/workspace/build/tests/reftest/tests/layout/reftests/border-dotted/border-dotted-interaction.html == file:///builds/worker/workspace/build/tests/reftest/tests/layout/reftests/border-dotted/masked.html | image comparison, max difference: 0, number of differing pixels: 0
REFTEST TEST-UNEXPECTED-FAIL | file:///builds/worker/workspace/build/tests/reftest/tests/layout/reftests/border-radius/curved-stripe-border.html == file:///builds/worker/workspace/build/tests/reftest/tests/layout/reftests/border-radius/curved-stripe-border-ref.svg | image comparison, max difference: 72, number of differing pixels: 906
Flags: needinfo?(bugmail)
Agreed, this is basically a merge conflict with bug 1396491. I'll update the annotations and reland.
Flags: needinfo?(bugmail)
Comment on attachment 8919826 [details]
Bug 1408461 - Update additional reftests due to merge conflict with bug 1396491 and something (not sure what) in the WR update.

https://reviewboard.mozilla.org/r/190764/#review195934
Attachment #8919826 - Flags: review?(a.beingessner) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f1601f3c1704
Update webrender to commit 7892f5364bc4d35c7a9b42949f0ace4cc54f8b3c. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/307f224ab3c2
Update Cargo lockfiles and re-vendor rust dependencies. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/864b65613641
Update reftest results for changes in WR PR 1822. r=kats
https://hg.mozilla.org/integration/autoland/rev/4523799ced29
Update reftest results for changes in WR PR 1873. r=Gankro
https://hg.mozilla.org/integration/autoland/rev/8a6efd025d51
Update reftest results for changes in WR PR 1869. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/c8b9081fe93d
Update reftest results for changes in WR PR 1868. r=Gankro
https://hg.mozilla.org/integration/autoland/rev/452d33f9ef41
Update reftest results and regenerate bindings for changes in WR PR 1841. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/6d41d7f7eafe
Update additional reftests due to merge conflict with bug 1396491 and something (not sure what) in the WR update. r=Gankro
Blocks: 1406608
Blocks: 1409479
Depends on: 1419528
Depends on: 1421272
Depends on: 1434503
You need to log in before you can comment on or make changes to this bug.