Closed Bug 1416927 Opened 3 years ago Closed 3 years ago

Intermittent leakcheck | tab process: 44 bytes leaked (CancelableRunnable, Runnable)

Categories

(Core :: DOM: Navigation, defect, P2)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: aryx, Unassigned)

References

Details

(Keywords: intermittent-failure, memory-leak, Whiteboard: [stockwell unknown])

https://treeherder.mozilla.org/logviewer.html#?job_id=143712532&repo=mozilla-inbound

[task 2017-11-10T14:51:35.497Z] 14:51:35     INFO - TEST-PASS | leakcheck | tab process: no leaks detected!
[task 2017-11-10T14:51:35.499Z] 14:51:35     INFO - 
[task 2017-11-10T14:51:35.500Z] 14:51:35     INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4598
[task 2017-11-10T14:51:35.500Z] 14:51:35     INFO - 
[task 2017-11-10T14:51:35.501Z] 14:51:35     INFO -      |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2017-11-10T14:51:35.503Z] 14:51:35     INFO -      |                                      | Per-Inst   Leaked|   Total      Rem|
[task 2017-11-10T14:51:35.503Z] 14:51:35     INFO -    0 |TOTAL                                 |       28       44|   40692        2|
[task 2017-11-10T14:51:35.504Z] 14:51:35     INFO -   21 |CancelableRunnable                    |       24       24|     126        1|
[task 2017-11-10T14:51:35.505Z] 14:51:35     INFO -  171 |Runnable                              |       20       20|     342        1|
[task 2017-11-10T14:51:35.506Z] 14:51:35     INFO - 
[task 2017-11-10T14:51:35.507Z] 14:51:35     INFO - nsTraceRefcnt::DumpStatistics: 510 entries
[task 2017-11-10T14:51:35.508Z] 14:51:35     INFO - TEST-INFO | leakcheck | tab process: leaked 1 CancelableRunnable
[task 2017-11-10T14:51:35.509Z] 14:51:35     INFO - TEST-INFO | leakcheck | tab process: leaked 1 Runnable
[task 2017-11-10T14:51:35.510Z] 14:51:35    ERROR - TEST-UNEXPECTED-FAIL | leakcheck | tab process: 44 bytes leaked (CancelableRunnable, Runnable)
[task 2017-11-10T14:51:35.511Z] 14:51:35     INFO - runtests.py | Running tests: end.
Thanks for filing a new bug!

Bug 1410209 will help diagnose this issue by indicating what the runnable is.

It has only started showing up recently, but that's because I recently landed bug 1411259 to reduce the leak threshold on tab processes. I expect that the underlying leak is older.
Depends on: 1410209
Duplicate of this bug: 1411644
As I said in the dupe, the content process that is leaking this runnable is being created during test_bug1209621.xul. I'll move this to Document Navigation for now.
Component: XPCOM → Document Navigation
Priority: -- → P2
There are 31 failures associated with this bug in the last 7 days. This occur for Linux, Linux 64, debug, mochitest-chrome.

:mccr8 any updates for this?
Flags: needinfo?(continuation)
Whiteboard: [stockwell needswork:owner]
This is blocked on bug 1410209, which is blocked on both XPCOM peers being away.
Flags: needinfo?(continuation)
Since December 4th, this started occurring again and it registered 31 failures for the last week.

The failures occur only on the debug build type and on the following platforms: 
- linux32-stylo-disabled: 16
- Linux: 14
- Linux x64: 1

This a recent log file: https://treeherder.mozilla.org/logviewer.html#?repo=mozilla-central&job_id=150920540&lineNumber=15082
and a relevant snippet from it: 

[task 2017-12-08T23:01:28.068Z] 23:01:28     INFO -    0 |TOTAL                                 |       29       44|   40981        2|
15076
[task 2017-12-08T23:01:28.069Z] 23:01:28     INFO -   21 |CancelableRunnable                    |       24       24|     127        1|
15077
[task 2017-12-08T23:01:28.070Z] 23:01:28     INFO -  174 |Runnable                              |       20       20|     348        1|
15078
[task 2017-12-08T23:01:28.070Z] 23:01:28     INFO - 
15079
[task 2017-12-08T23:01:28.071Z] 23:01:28     INFO - nsTraceRefcnt::DumpStatistics: 516 entries
15080
[task 2017-12-08T23:01:28.072Z] 23:01:28     INFO - TEST-INFO | leakcheck | tab process: leaked 1 CancelableRunnable
15081
[task 2017-12-08T23:01:28.073Z] 23:01:28     INFO - TEST-INFO | leakcheck | tab process: leaked 1 Runnable
15082
[task 2017-12-08T23:01:28.074Z] 23:01:28    ERROR - TEST-UNEXPECTED-FAIL | leakcheck | tab process: 44 bytes leaked (CancelableRunnable, Runnable)
15083
[task 2017-12-08T23:01:28.075Z] 23:01:28     INFO - 
15084
[task 2017-12-08T23:01:28.077Z] 23:01:28     INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4896

:mccr8, would you please have a look?
Flags: needinfo?(continuation)
I rebased my patch for bug 1410209. At this point, I'll probably just wait until Nathan gets back from leave.
Flags: needinfo?(continuation)
Bug 1410209 will have (hopefully) changed this leak to something new.
See Also: → 1426801
See Also: → 1427525, 1427444
This has gone away, as expected. The leaks will show up as something else now. Note that this signature (or something like it) will still happen on beta and release.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.