Let Accel+W in a pinned tab select the first unpinned tab

VERIFIED FIXED in Firefox 59

Status

()

enhancement
P3
normal
VERIFIED FIXED
a year ago
a day ago

People

(Reporter: vakho, Assigned: dao)

Tracking

(Depends on 1 bug)

Trunk
Firefox 59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 verified, firefox60 verified)

Details

(Whiteboard: [parity-Safari])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171123161455

Steps to reproduce:

Pin a tab. Than try to close it with Command+W key combination (Mac OS X)


Actual results:

Nothing.


Expected results:

Command+W should close the active pinned tab.
I think that's intentional. Pinned tabs should not be easily closed.
Component: Untriaged → Tabbed Browser
(Reporter)

Comment 2

a year ago
Well, maybe you are right. But, Google Chrome closes pinned tab with Command+W; Safari activates next non-pinned tab (or new blank tab) instead. Firefox does nothing :)
(Assignee)

Comment 3

a year ago
(In reply to Vakho from comment #2)
> Safari activates next non-pinned tab (or new blank tab) instead.

Interesting. Should we do something similar?
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(philipp)
Keywords: uiwanted
Summary: Can't close pined tab with Command+W key combination → Let Accel+W in a pinned tab select the next tab
(Reporter)

Comment 4

a year ago
(In reply to Dão Gottwald [::dao] from comment #3)
> Interesting. Should we do something similar?

Why not?! I think Safari's behavior is the best. 
See short demo video for Safari and Chrome: https://imgur.com/fqg7D8d
Yeah, selecting the next non-pinned tab seems like a sensible choice.
Flags: needinfo?(philipp)
(Assignee)

Updated

a year ago
Keywords: uiwanted
OS: Unspecified → All
Priority: -- → P3
Hardware: Unspecified → All
Whiteboard: [parity-Safari]
Version: 58 Branch → Trunk
(Assignee)

Updated

a year ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)
(Assignee)

Comment 8

a year ago
Comment on attachment 8932857 [details]
Bug 1420601 - Let Accel+W in a pinned tab select the first unpinned tab.

hmm, Philipp said "the next non-pinned tab" rather than "the next tab"...
Attachment #8932857 - Flags: review?(dharvey)
(Assignee)

Updated

a year ago
Summary: Let Accel+W in a pinned tab select the next tab → Let Accel+W in a pinned tab select the next unpinned tab
Comment hidden (mozreview-request)
(Assignee)

Updated

a year ago
Summary: Let Accel+W in a pinned tab select the next unpinned tab → Let Accel+W in a pinned tab select the first unpinned tab

Comment 10

a year ago
mozreview-review
Comment on attachment 8932857 [details]
Bug 1420601 - Let Accel+W in a pinned tab select the first unpinned tab.

https://reviewboard.mozilla.org/r/203900/#review210130

This is a nice change and code looks good by me, cheers
Attachment #8932857 - Flags: review?(dharvey) → review+

Comment 11

a year ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3575e010c493
Let Accel+W in a pinned tab select the first unpinned tab. r=daleharvey

Comment 12

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/3575e010c493
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59

Comment 13

a year ago
I have reproduced this bug with Nightly 59.0a1 (2017-11-25) on Windows 10 , 64 Bit ! 

This bug's fix is Verified with latest Beta !

Build   ID    20180215111455
User Agent    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
QA Whiteboard: [testday-20180216]
I tested this fix using latest Nightly 60.0a1 and beta 59.0b10 on macOS 10.13 and Ubuntu 16.04 x 64 and the bug is not reproducing.
According to this result and the one from comment 13, I will mark this bug as verified.
Status: RESOLVED → VERIFIED

Updated

11 months ago
Duplicate of this bug: 1111855
Duplicate of this bug: 1464358
(Assignee)

Updated

11 months ago
Depends on: 1464358
(Assignee)

Updated

a day ago
Depends on: 1545611
You need to log in before you can comment on or make changes to this bug.